Roon keeps freezing and crashing on Windows (mostly when resuming from minimized) [Partially Solved]

I have the latest version of Roon installed

@Darren_Monk all devices? remote and core?

remote gets updated auto on my phone and iPad and the same with Roon on my PC as soon as you load the program up if there is one .
And streaming to my OPPO 203 . its actually the PC software that’s the issue here its like the software is not compatible with windows 10 which i am running windows 10 64bit

1 Like

According to your system diagnostics, you haven’t installed Build 970 on your Roon Server machine, you’ve installed it on one remote, your Core and 2 other remotes remain on Build 952.


Yes, my comment was made before i installed the update to the server. I had only updated the one remote and will only update one remote as the other two are not in use. They are for back-ups only incase i need an old revision that worked prior. I have had so many problems with new releases that i have learned to make sure i always have a backup and delay any new install.

Since my original post, I did install the update (or started it) to the server and it locked up. Roon will not start. I am currently working trying to find a resolution to this new problem. Hopefully its simple as i would hate to have to do what i see others have had to do to clear up problems. I am concerned about me doing something to corrupt my db.

Since you can see my diagnostics but others cant … here is the fault i get from the most recent attempt at server install.

Faulting application name: RoonServer.exe, version:, time stamp: 0x628686cc
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1706, time stamp: 0x458acb5b
Exception code: 0xe0434352
Fault offset: 0x0000000000034fd9
Faulting process id: 0x1088
Faulting application start time: 0x01d87ff87723add9
Faulting application path: C:\Users\chuck\AppData\Local\RoonServer\Application\RoonServer.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 05b9b42d-5b66-4df5-a556-27848e4af2b9
Faulting package full name:
Faulting package-relative application ID:


Application: RoonServer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeLoadException
at Sooloos.App.InitPing()
at Sooloos.App.Init()
at Sooloos.App.Main(System.String[])strong text

Roon will not restart after the update and server restart.
Any suggestions from someone who may have experienced this before. My auto response would be to install and uninstall the pgm. If i do this will the db need to be reindexed (another week long process i would appreciate avoiding)?

I am sorry to report that the new patch has not resolved my issue. I started Roon this morning, put on a playlist and minimized the Roon client (I run the client and server on same machine) and then proceeded to do other things on the same machine. After about an hour of trouble free playback and with music still playing, I attempted to maximize the Roon client and rather than maximize, the Roon application terminated. This is a DIFFERENT behavior, in that it immediately failed after attempting to maximize, rather than maximizing and then hanging and finally crashing. There was NO WINDOWS SYSTEM EVENT logged, in contrast to previous behavior.

Verdict: the problem I was experiencing is not fixed although the manifested behavior is different than previously.


  • Windows 10 Home, all patches applied using latest NVIDIA graphics driver.
  • Roon version 1.8 (build 970) stable (64 bit)
  • Roon was minimized while in the playlist view showing the tracks in the playlist, though I don’t think this has any impact.
  • I was using an application during the time that used the system audio while using Roon to stream to a Sonos Connect.
  • Core directly wired to Router which the Sonos Connect was also directly wired to.
  • I do not use any audio processing in Roon (it is disabled in options, not even volume levelling is enable.)
  • My next test today will be to run the Roon output to the system output and see if that makes any difference.

edit: sending output to system had same results. Still crashed after being maximized over about 45 minutes.

1 Like

In line with above experiences, build 970 did not solve the issue for me. Today I experienced a mix of familiar crashes and new behaviour:


  • When pulling up Roon remote from the background, it generates a Windows 10 error message (A new guard page for the stack cannot be created), upon closing that message Roon terminates.


  • When attempting to pull up Roon remote, it simply self-terminates.
  • When pulling up Roon remote from the background, it is unresponsive and displays a loading mouse icon. After approx. 10 seconds it becomes responsive and playback is unaffected.

The last case is a slight improvement. It means that sometimes Roon is just slow to respond and otherwise does not behave unexpectedly. However, the underlying issue seems to be pervasive and still also causes full-on crashes.

What did not happen anymore is that Roon skips to another track when it recovers.

Add-on: crashes seem to be less frequent…

1 Like

Sorry to report 970 doesn’t stop my Roon Core crashes. Same as before, minimized comes up and bombs out. As other’s said, seemed like it crashed quicker.

Event Log

Faulting application name: Roon.exe, version:, time stamp: 0x62a332af
Faulting module name: clr.dll, version: 4.8.4510.0, time stamp: 0x62461f56
Exception code: 0xc00000fd
Fault offset: 0x000000000000b3a4
Faulting process id: 0x3ab4
Faulting application start time: 0x01d880102f59c38a
Faulting application path: C:\Users\minky\AppData\Local\Roon\Application\Roon.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Report Id: e21af0ad-6624-4793-a6d7-ea34d3e39584
Faulting package full name:
Faulting package-relative application ID:

Sort of a mixed bag after being forced to uninstall and reinstall the core due to the corrupt install that occurred when updating.
So far, in about an hour of playing, i have not had a crash on the remote the other than its initial turn on after uninstall and reinstall of roon core software.
Disappointed to have to report my memory usage has not changed and is well beyond what i had seen in the past and what others are reporting. I am currently using (now and before the update) around 3.8G +/- 10% (with peaks above 9G) and this is without playing anything or using dsp (both of which dont seem to affect the memory usage number which seems odd).

Roon is working again for me - by only installing the server part on machine mentioned in previous post. The latest build keeps running, so thats a definite heads up! Will keep on testing using multiple clients.

So far its still freezing/lagging for me after the update. I am either not as sensitive to this issue as other users or its not as bad on my machine, but it does happen.

Roon does “catch up” and it doesn’t crash, but it freezes for 5 - 20 secs.

1.) It does not really have relation to minimizing / maximizing the app, I’ve noticed it both ways. It just has to do with me not doing anything with Roon and music is playing in the background for a while.
2.) I haven’t tested this. My Roon sits in now playing/track listings 99% of the time.

Ryzen 3 2200G 3.5 Ghz
16 GB Ram
Radeon Vega 8 graphics


Still seeing the same behavior in the Windows app. Leaving it alone while music is playing will eventually result in it becoming unresponsive for 5-10 seconds… or even crashing. My server (which runs on Linux) is unaffected, continues playing music and can be controlled by my smartphone.


I just noticed that my roonserver on my Windows Server wasn’t working and stumbled across this thread.

This is the error that I’m seeing:

Application: RoonServer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeLoadException
at Sooloos.App.InitPing()
at Sooloos.App.Init()
at Sooloos.App.Main(System.String[])

Is there a known fix to this? I can’t get Roon to start at the moment due to this. It immediately terminates when I try to run it.

---- EDIT -----

My issue is resolved.

It was fine last night after update. However, it start freezing again the next day.

I would suggest opening a new support thread filling in all the requested information.

The last update seems to have fixed this for me so far

1 Like

Hi All , I have the same issues described here but is new to me. Now I’m using a mini PC to run the Core but when I used the Core with my surface I don’t have the issue…

yes same , after minimise, crashes roon randomly ! getting very annoying! SUPPORT PLEASE HELP


Start your own thread in the support category and fill in the system information requested