ROON keeps losing connection to ROCK (Intel NUC)

Roon Core Machine

Intel NUC 10 Performance Kit NUC10i5FNH

  • 970 EVO Plus NVMe M.2 SSD - 250 GB (MZ-V7S250BW)
  • WD Blue Mobile 2TB 2,5’’ HDD (WD20SPZX)
  • 8GB (1x 8GB) G.Skill Ripjaws DDR4-2400 SO-DIMM CL16-16-16-39 Single

Networking Gear & Setup Details

  • FRITZ!Box 6660 Cable
  • CSL CAT 8.1 ethernet cables

Connected Audio Devices

  • Stereo setup with a Bluesound NODE 2i connected to the router via ethernet cable
  • Headphone setup with an ifi ZEN DAC V2 connected to Macbook / PC via USB, both hooked up to the router via ethernet

Number of Tracks in Library

35,000

Description of Issue

ROON keeps losing connection to the ROCK. The disconnect usually lasts 10-15 seconds at minimum, sometimes more than 30 and occurs repeatedly. Music playback is interrupted and has to be restarted manually after the connection has been re-established. All devices running ROON (i.e. Macbook, PC and the mobile app) start looking for the core. Accessing the ROCK web admin interface through a browser works during these disconnects though. Rebooting the ROCK usually helps but there doesn’t seem to be a reliable pattern to that method. One thing I’ve tried is changing my router’s DNS server to Google’s because that seemed to help someone with a similar issue but it didn’t do anything for me.

Last time it happened was today at 14:01 CET.

Thanks in advance for any advice or helpful tips!

I am sorry you’re having problems. This kind of thing is pretty hard to troubleshoot. The easiest thing to try first is to ping your Roon server (from your Mac or Windows PC) to see if there’s any packet loss. If you find out that there some packet loss, you can try rebooting the router. Next, try setting up static IP set up in the Roon Optimized Core Kit web interface.If that doesn’t help, you can then try a different network adapter to rule out a hardware/driver issue of your NUC. I have a Linux-compatible USB 3 Ethernet adapter lying around for troubleshooting purposes. Here’s a link to Amazon.

1 Like

Thanks for your reply, I’ll give it a shot!

Edit: I just checked the log file from when yesterday’s last disconnect occurred and found this line:

02/22 14:01:23 Trace: [broker/accounts] [heartbeat] now=02/22/2022 14:01:23 nextauthrefresh=02/22/2022 14:01:54 nextmachineallocate=02/22/2022 16:56:23

Can anyone tell me what this means?

Its a good start you are using wired connections.

Are you running mulitple mesh endpoints?
I.e. do you have your NUC and Bluesound sitting on different Mesh endpoints?

If you are running a mesh with multiple WAP’s/nodes, try rebooting them.
I had an issue whereby my Rock NUC was sitting wired to one Orbi, and my Endpoint was sitting on another orbi endpoint. The Mesh was a dedicated 5ghz link (As Orbi does).

Rebooting fixed the issue. Just a suggestion.

Is your router running the latest firmware?

How many connection does your router support? Are you exceeding the limit?
Some basic routers might only support connections in the teens.

Some ideas here: https://help.roonlabs.com/portal/en/kb/articles/networking-best-practices#Avoiding_Common_Network_Troubles

From the link:
Are you using IPv6?

  1. IPv6 has been known to cause issues with network communications. Some ISPs have started rolling out IPv6 support, and customers in those regions have had issues communicating with our services. We recommend disabling IPv6 on the router and all devices.

From the link:
The FRITZ OS 7 update includes a feature called “Software Packet Acceleration” that can cause issues with remote connectivity. We recommend disabling this setting from the FRITZ GUI.

1 Like

Thanks for your input, that gives me quite a lot to look into.

I’m not using a mesh network so that can’t be the source of the issue.

I’m running the current version of my router’s firmware, IPv6 was disabled all along and I’m definitely not exceeding the number of connections. The FRITZ!Box 6660 Cable is a fairly new device and supports hundreds of concurrent connections.

I disabled that feature now, we’ll see if that does something. I’ll report back after I’ve done some more testing/listening!

I just wondered if you still have the issue, since I’m experiencing something similar.

Hi @Paul_Hermans,

I haven’t been home since yesterday due to work but I’ll do some more testing over the weekend. Haven’t had any disconnects since disabling the software packet acceleration on my fritzbox but I think it’s too soon to say whether that actually did the trick or not.

Good luck with your setup!

Here’s an update on my issue:

  1. Disabling the software packet acceleration on my FRITZ!Box initially seemed to have had a positive effect, disconnects happened less frequently but they still happened from time to time.
  2. Ever since updating to build 913, the issue got a lot worse (I’m now on 918 but the update didn’t fix anything)
  3. ROCK now disconnects every couple of minutes and is not reachable via the web browser interface during these disconnects

I’m not sure what to do next… I guess the logs might contain some clues? @support

Hi @vessmier ,

Can you please check to see if build 923 had any impact on this issue? There was a change that may help with your issue here, so it would be good to confirm.

Hi @noris,

thanks for your reply! Actually yes, the update seems to have improved the connection issues a lot. I’ve been listening to music for several hours yesterday and today and only had one disconnect! Fingers crossed :slight_smile:

1 Like

Good Day:

If you click start button and type CMD.

First thing to type is: ipconfig /flushdns.
Once successful type: ping -t (number) ip address roon interface reports. Will cause constant ping requests to typed ip address of your roon server. So if you get a miss in sound now its important to note if connection is dropped or if it goes from small number of MS to reply lets say 4-10ms to hundreds (means busy) or disconnected.

If it now doesn’t increase in MS latency you could be looking at faults in library.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.