Roon keeps losing control of my Auralic Aries G2

(kyle millsap) #1

Roon loses control of my Aries streamer and gives message; Roon lost control of the device because the output changed. Anyone else having similar issues, or, have any ideas how to correct the issue?
Thanks.

(kyle millsap) #3

Any ideas what may be causing this. Ruckus network, 150Mbs WIFI

(Dylan Caudill) #5

Hi @kyle_millsap,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this issue occur with any other devices?

Can you share a screenshot of Device Setup for the Aries? Can you also share a screenshot of the Signal Path when playing to this device?

(kyle millsap) #6

Hi @dylan. My network is Ruckus hardware. My other streaming devices work perfectly.


Thanks for your help.

(Dylan Caudill) #7

Hi @kyle_millsap,

Is there any difference in how the Aries is connected to the network compared to the other streaming devices that are working?

Can you confirm that the firmware on the Aries and the PS Audio are fully up to date?

(kyle millsap) #8

Same connection for my other streaming devices. Aries and PSA DSD up to date.
The sound is incredible while it works, wish I could get this sorted.
Thanks @dylan.

(Dylan Caudill) #9

Hi @kyle_millsap,

I checked with the team on this, and they’ve asked to confirm that the PS Audio has the latest firmware found here installed. They’ve let me know that there was a recent update which may help with this issue.