Roon keeps reinitialising

Roon has been pretty stable but over the last couple of days my whole system has become very unstable.

I’m running ROCK on a dedicated i7NUC which is operating ROCK 1.0 (build 159) stable and Roon Server 1.5 (build 363) stable. The NUC is wired into a NetGear GS724T with hardwire Cat5E throughout the house.

The Roon Server software seems to reinitialize itself on a regular basis meaning the connection to my Roon Control points is lost. I’ve tried reinstalling the Roon operating system but this made no difference. On my Mac I tried binning the Roon software and reinstalling a new copy fresh from the Roon website. I was surprised when I was told that my software was out of date after this, as I thought that the download direct from the Roon site would always be the most up-to-date.

Despite all this there is no change in the behaviour of Roon. Even whilst typing this out the Roon Server software has reinitialized itself with the running time reset on the browser access to the NUC.

Any thoughts welcome.

Can you put a screen on the NUC and make sure it isn’t having hardware issues? Overheating or such?
(We only know what we have experienced and this was my problem on a previous NUC)

1 Like


Thank you.

Not sure how I’d do that? The NUC sits mounted on a wall in the cellar so it’s not in the heated part of the house.

Well it’s tiny so take it to a screen location maybe? Just a suggestion obviously but ruling out hardware might help in diagnosis especially if it has all been fine until recently.

1 Like

Does ROCK have a screen if I plug one in? The ROCK OS itself is running fine, it’s the Roon Server software that is crashing.

Just reinitiliazed itself again after running for 7 minutes 40.


In that case probably best for @support to enable diagnostics and have a look.


where is your music stored? Did you make any changes or additions to the library just before the issue started?

1 Like

Music is stored on a NAS, so remote from the NUC.

The NAS is currently rebuilding its RAID after a false disk failure.

1 Like

Let’s hope that is the issue then. In this type of scenario, Roon could really be more helpful by way of some sort of error message IMHO. Plenty of space on the ROCK homepage to show them. They needn’t intrude on the Roon Control display itself.

How warm is the NUC to the touch…have you restarted the NUC?

If its running rather warm if you have some compressed air maybe blow some in thru the fan vents to see if the fan is maybe clogged with diet. do this with the power off and in an open area in case its full of dust :open_mouth:

1 Like

The NUC is at the ambient temperature (bear in mind it’s in the cellar) and not warm to touch at all.

After the download of an update I cant bring Roon upo to where i had it.

Hello @dpstjp,

Thanks for contacting support regarding this issue. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. I will be sure to let you know what we are able to ascertain from the diagnostics.


1 Like

Hello @dpstjp,

I have taken a look at the diagnostics and I do notice the disconnect but the reason for them is not clear yet. I have a few suggestions:

  • Can you please verify that you have added Roon as an exception to your OSX Firewall?

  • Is the behavior the same when you connect the Mac directly to your router via Ethernet?

  • I noticed the Netgear switch you have is managed, can you please check to see if you have any “flow control” settings on it or “IGMP Proxying”/“IGMP Snooping” settings?

  • Do your iOS Remotes work as expected?

  • What is your router model/manufacturer?

Please let me know if my above suggestions help.


Your NAS most likely is the cause. Shut it down or remove it from the network. Roon server on ROCK probably will stop freaking out. If so, the NAS is the issue.

I have been there, done that.




I think you’re right. The RAID rebuild stopped at 1538 yesterday afternoon, and the Roon Server has been stable since almost precisely then.

Hello @dpstjp,

Just want to confirm with you here, since the RAID rebuild was completed, are you seeing any other strange behavior in Roon? Please let me know.


1 Like


Thank you, yes. Stable for over 2 days now.


Did you upgrade your Mac OS to Mojave?

On the Mac Mini yes.

The NUC is running ROCK though.