Roon Library Questions/Issues

I just installed roon on an iMac and imported my library from iTunes by pointing to the specific folder I am currently using in iTunes. In iTunes, I only have imported ALAC files and that is all that shows up when I view them in iTunes. After I imported that folder into roon, I notice that it is picking up AIFF files from a completely different folder location. I’m not sure why it would do this but to resolve it, I’m trying to completely re-create a new library in roon and then re-import the music. However, after I delete roon and re-install it, it still shows all the music I had previously imported. How can I get roon to start with a brand new library?

Hi @John_Lightner ---- Thank you for the report!

Moving forward, in order to completely remove Roon from the mentioned iMac you will need to not only delete the application itself but also the Roon database, which is going to be located in the “library” directory. Your Roon database can be found by using the instructions listed here. So you will need to delete the following:

  1. “Roon” from the applications folder.
  2. Your “Roon” folder (i.e your Roon DB).
  3. “RAATServer” folder which is going to be located in the “library” directory as well.

However, before performing the above I think we should try to get your storage configured as needed before going about deleting the Roon DB etc. To help in my evaluation of why you are seeing the mentioned AIFF files and not the ALAC files, may I very kindly ask you for the following:

Screenshots of…

  1. Your “storage” tab.
  2. The “file path” of one of the mentioned AIFF files being imported into Roon.


Note: I have provided you links to some KB articles that may help to answer the questions you have.

Knowledge Base: iTunes
Knowledge Base: Skipped Files

Hi Eric,

Thanks for the info. See attached screen shots per your request.


Hi @John_Lightner ----- Thank you for getting in touch and providing the requested feedback, both are very appreciated!

Can you please try temporarily disabling the “music folder” as seen in the above screenshot and confirm if this action yields a positive change in behavior here?


Hi Chris,

When I disable the music folder, the riff files in fact do go away in Roon. However, when I add a folder containing only ALAC files, Roon doesn’t recognize them. At this time, I am ok with it using the AIFF files since
I had duplicated these in the ALAC format. Thanks for your help.



Thanks for touching base with me and sharing the observations made after performing the requested test. Very appreciated @John_Lightner!

I’d be happy to take a look at one of the mentioned ALAC files if you could send me a media sample. The best way tp go about this would be to do this would be to send the file via a shared dropbox link (or another upload method of your choosing) in a PM addressed to me.


Thanks Eric…I think I have isolated the problem to ALAC files that were created in batch using the Universal Audio Converter Pro app downloaded from the Apple App store. ALAC files created using iTunes during import work fine with Roon.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.