Roon + Linn Issues (Skipping through tracks)

Hello Noris
I made an inquiry to ROON about canceling my subscription at the end of its current period and was encouraged to reach out to you and attempt to remedy the issues I am having with ROON and my Linn Klimax DS.
I have been using ROON for several years - even prior to its official integration with my Linn Klimax DS (previously using with a Micro Rendu). Since official ROON Linn integration my system has worked flawlessly - until the 1.6 update. Now - in addition to the anemic searches - ROON has COMPLETELY stopped working with my Linn KDS. Linn’s own Kazoo app works fine (both the official version and the beta version) and LUMIN’s control app works equally well. ROON has completely stopped working and I am no longer able to play anything - either TIDAL or local files.

ROON Core is running on an iMac with current Mac OS and my local files are stored on an external hard drive connected to the iMac. ROON sees all local files however when I hit play it just cycles through each track in an album for a few seconds before jumping to the next - all while nothing plays back through the Linn.

Control is being done via ROON on an iPhone XS Max. If the zone is switched to the iPhone music is played on the iPhone. It no longer plays on the Linn

How do we need to proceed to determine why ROON no longer works?


Hi @greggl,

Thanks for reaching out here and for providing more info. I have split your post into it’s own thread as I do not believe you are experiencing the same issues as the previous thread. Can you let me know the following info so that I can better assist you?

  • What version of OSX are you running and how is the Core connected to the network (Ethernet/WiFi?)
  • Is there any change in behavior if you connect the Core and Linn via Ethernet to your router?
  • What is your network setup like, can you let me know the model/manufacturer of your router, any switches, range extenders, powerline adapters, ect?
  • Do you have the correct “Linn Subnet” selected in Roon -> Settings -> Setup?
  • Is the Linn Klimax using the newest firmware version available?
  • Does the same behavior occur if you have DSP disabled?

– Noris

Hello Noris

  1. Current OSX 10.14.5
  2. ROON Core is running directly on a 3.1GHz Core i5 4k Retina iMac late 2015. FLAC files stored on an external USB hard drive connected to the iMac
  3. USA based - FIOS Fiber internet 150/150. Verizon Fios Router ethernet to Google Wifi main base station. Google Wifi main base station ethernet to a Netgear Gigabit 8 port switch. Additional Google Wifi points ethernet cabled to the same switch (not being run in Mesh configuration)
  4. Linn Klimax DS/4 - current hardware version and most recent Linn firmware dated 5/1/19
  5. Cisco commercial grade 2960 switch connected via ethernet back to the Netgear Switch. Linn Klimax ethernet cable direct into this Cisco switch. Many on the Naim and Linn forum have moved to these Cisco commercial switches ($1k when new) which provide ultra low noise, PS etc.
    Effectively the Linn Klimax DS is the only network item connected to the Cisco switch
  6. DSP never enabled or run
  7. Linn subnet as ROON defaulted -
  8. ROON 1.6 build 416

ROON worked prior to official Linn integration via a SonicOrbiter (predecessor to the MicroRendu). Once Linn and ROON implemented integration I was an early adopter and never encountered ANY issues. Issues started with the 1.6 update - typical slow search times as indicated by many other users. Eventually things completely stopped working when attempting to play local files. Linn Kazoo and LUMIN work perfectly fine.

The only problems ever encountered were during the first year of ROON/Linn integration. Others reported similar issues. Sometimes when an album or playlist was selected ROON would cycle through each song for 10 seconds and keep on jumping. It was a random occurrence which required a full reboot of everything.

Another issue would be where the Linn KDS would remain “stuck” on ROON ie the front display would always remain indicating ROON (instead of Playlist, NetAux etc.). A complete reboot would clear this up. If you look at my posting history you will see this issue raised a year or so ago - others perhaps encountered it as well.

Currently if I attempt to play a local stored album ROON will cycle 10 seconds down through each track - audio output never coming from the Linn. If the Zone is switched to iPhone - music successfully plays through the iPhone.

ROON is always controlled from an iPhone XS Max or iPad 10.5" Pro using the current iOS app - iOS on both devices also current.

Hope this detailed information helps.


Have not heard anything back from ROON so:
completely uninstalled ROON
went into system/library and removed all of ROON supporting files.
A fresh clean install was then done

Result - at least ROON is back working again. I will put it through the motions and see if it stays this way.

The only thing I can conclude is that the upgrade to 1.6 must have screwed up the settings. Something like that should not happen with an upgrade. Lets see how things go from here.

Hi @greggl,

Sorry for the slight delay in getting back to you here and thanks for the update! I’m glad to hear that reinstalling Roon seems to have resolved the issue.

Have all of the issues you mentioned subsided since performing the reinstall?

If you notice any specific issues moving forward, can you please let me know the local time + date in your country when you experience them (e.g. 1:14PM on 6/4/19) so that we can take a look at diagnostics? Thanks!

– Noris

Well - spoke too soon. Started playing a track this afternoon via Tidal and it stopped half way through. ROON indicated it was still playing however no sound from the Linn.
June 5 approximately 4pm USA Eastern Time.

Please have a look and reply.

Same track started again 5:24pm - let’s see what happens

Stopped again 5:33

Hi @greggl,

Thanks for letting me know those timestamps. Now that I have this info, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once these are received I will be creating a ticket for you with our QA team who can review the logs to check if there are any signs as to why this issue is occurring.

In the meantime while this occurs on our end I have a few additional suggestions. You mentioned that the Linn is connected to the Cisco switch, can I please ask you to plug both your Core and Linn DAC into an un-managed switch or directly into the router? Even as a temporary test this would give us a great data point and would allow us to eliminate one variable from the equation here.


A post was split to a new topic: Linn Playback Issues

A post was merged into an existing topic: Linn stops at end of track

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.