Roon Linux Tidal error loading page

Roon Core Machine

Roon on Ubuntu 18.04, i5-3570k, 32Gb RAM

Networking Gear & Setup Details

Wired network. TP-Link Archer C8 router. Virginmedia Hub in modem mode.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Everyday after the Ubuntu PC has rebooted Roon shows error loading page on TIDAL searches. Although will continue to play if TIDAL tracks are in the playlist.
To get it working again, I have to log out of TIDAL, restart the roonserver service using systemctl, the log back in to tidal.
I have tried clearing the TIDAL folders from /var/roon/RoonServer/Cache but the problem persists.

Hey @Mike_Hennessey so sorry for the trouble here.

We appreciate you taking those steps - if clearing the TIDAL Cache did not help, could you try changing the DNS?

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

Additionally, have you tried a full reboot of your router and Core device? If not, please do this by turning off the devices, unplugging them for a few minutes, plug them back in, and power them on. You can then log out of TIDAL in Roon and log back in. Does the issue still occur after completing this?

Thanks! :pray:t3:

Sorry I’ve taken a day or two to respond.

I have changed my DNS servers to google’s ( & and rebooted the router, leaving it for a few minutes before turning back on.

The issue still remains.

Is there a log somewhere which may tell me when the fault occurs?

I have managed to get it working. It appears that something about when roon starts during the boot process is the problem. So I applied a clunky fix. I put the command sudo systemctl restart roonserver into a bash script and then set a Cron job to run that script 5 minutes after every reboot.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.