ROON loses connection with TIDAL

Since a few days ROON appears to be very unstable. It starts off with a regular lost connection with TIDAL but it escalates into the ROCK NUC no longer being able to connect on IP-number. For me I ‘feel’ this has to do with the upgrade to 1.8.
It really is more than annoying because I have to go in to the ROON app and tick play in the best case and worst case I have to reboot my NUC.
And my network is still the same as it used to be…

1 Like


Your topic has been moved to the support section of the forum.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.


I suspected that my NUC was giving me the trouble i.e. the internet connection. When I bought the NUC it already had a broken Ethernet-connection so I got a USB-LAN adapter that worked fine.
This morning I decided to rule out if the USB-LAN adapter was not working correctly by enabling the WIFI on ROCK. After making sure that I saw an IP number on the web-ui page I rebooted and now I can’t access ROON on my NUC no longer. The OS starts up and then it says ‘Searching for network address…’ and that’s it.
I already entered numerous time the networkreset-command but that doesn’t work. I guess this defaults back to the built-in Ethernet-connection which is broken.
How can I fix this? Is there a config-file I can edit or what-so-ever?

Hi @Bart_van_den_Bergh, can you share a screenshot of what you see when you have the NUC connected to a monitor via HDMI?

As requested, a screenshot, I blurred the serial partially.

Back on track, I fixed the WIFi issue by disabling the ethernet in the BIOS of the NUC. The networkreset command then did its job so ROON is available again.

I’ll start testing the TIDAL connection once again.

And the Tidal connection gets broken again. It appears that my account token can not be refreshed. Underneath a part of the logging in the Roonserver:

“Debug: [tidal] network reachability changed. refreshing token
08/25 14:27:59 Warn: Error in web request NetworkError (Name or service not known (
08/25 14:27:59 Warn: [broker/accounts] failed to refresh account info: Result[Status=NetworkError, ErrorText=Name or service not known (]
08/25 14:27:59 Trace: [roonapi] network reachability changed. Kicking off discovery cycle”

Any suggestions are welcome :wink:

Hello @Bart_van_den_Bergh ,

How are your DNS servers configured? We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

Thanks for the suggestion @noris

I will give it a shot but for now the issue seems to be resolved. I moved my NUC from the living room to a location close to my router. I guess due to the shorter CAT-cable and 1 hop less Roon seems to be able to keep up with TIDAL.

However now I can no longer use the HDMI connection from the NUC to my Marantz SR6012 and this means a maximum sound quality at the AirPlay level. The HDMI connection was used to stream a protocol as high as possible to my receiver. As alternative to Roon I Will start exploring the bluesound Node 2i which apparently can send decoder MQA to my 7.1 line in on the Marantz.

1 Like

Thanks for the update here @Bart_van_den_Bergh , glad to hear that the issue has been resolved with the network reconfiguration! Please, do let us know if you have any further difficulties with Roon and we can certainly assist if so. Happy listening! :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.