Roon loses connection with Vega DAC


(Magnus) #1

Since upgrading to version 363, I’m experiencing problems on my Mac running Roon. After ~2 minutes of play, it loses the connection with the DAC (an Auralic VEGA, connected through USB). After yet a couple of minutes, the connecting is back (after having first status “No audio resources”, and then “Activating”). Now it works again for a couple of minutes, and then the behaviour repeats itself.
Meanwhile, the DAC works fine with other audio sources on the computer.

Have not seen this before the last upgrade to 363.

Tried restart of Roon, computer, DAC, and reconnecting cables.

Any suggestions?


(Reader of the Internets) #2

There are a lot of hits on the Web if you search for “mac audio dropouts”. The recommended thing to try is to reset your NVRAM. Check it out.

I’ve seen this on my Mac Pro with iTunes and both directly connected headphones, and headphones connected via a USB DAC. The symptom seemed to be that the audio output had changed either from headphone to system output (in the first case), and from the USB DAC to system output (in the second case).


(Magnus) #3

Makes sense. However, it’s not the Mac losing connection, it’s Roon. When Roon cannot find the DAC, I have no problem playing from other audio sources…


(Noris) #5

Hello @Magnus_Ronnang,

Thanks for contacting support, I’d be glad to assist here. I have a few questions:

  • Can you please let me know if your Vega is on the newest firmware?
  • Have you tried using another USB cable as to rule that out?
  • What is your network setup here? Please list your model/manufacturer for the router and model/manufacturer for any switches/range extenders/powerline adapters.

Please let me know your reply to the above and we can continue from there.

Thanks,
Noris


(Magnus) #6

Vega on latest firmware: Yes
USB cables: Tried two different ones, no difference
Network setup: Apple Airport Extreme. Mac connected through Ethernet via a Netgear GS108 to the Airport.


(Noris) #7

Hello @Magnus_Ronnang,

Thanks for confirming that for me. Can you please let me know what your Clock setting on the Vega is configured to? This clock setting can affect USB performance, if you have it set on something other than Auto, I would change it to Auto to see if this improves things.

Please let me know your findings when possible.

Thanks,
Noris


(Magnus) #8

It’s on Auto.


(Noris) #9

Thanks for confirming that for me @Magnus_Ronnang.

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. I kindly ask for you to note the exact local time (ex.4:21PM) that you notice the next disconnect and let me know.

If you have any Chromecast or display zones active, I would try to disable those in Roon Settings -> Audio to see if there is a change in behavior. Please let me know the timestamp for this issue and if disabling additional zones helps at all.

Thanks,
Noris


(Magnus) #10

Brilliant. Thank you for excellent service so far. Will let you know next time it occurs (probably next time my kids will let me borrow my living room again).


(Magnus) #11

Today, Dec 7, at 3.19PM local time, and several times after that until 3.45PM.

(BTW, also tried a new install of the same version 363 on top of the old one).


(Noris) #12

Thanks for letting me know those timestamps @Magnus_Ronnang, I have taken a look at our diagnostics system and it appears that the report for you machine has not arrived yet.

I have re-enabled this feature but can you please let me know if your Roon Core is still powered on, connected to the internet and the Roon App is open? If the app is not open, do you mind opening it once more?

Thanks,
Noris


(Magnus) #13

Powered on, connected and Roon App is open. 3 * yes.


(Noris) #14

Hello @Magnus_Ronnang,

Still no luck on our end unfortunately. Can you please manually send the logs from your machine using these instructions? Getting them to us in a shared Dropbox or Google Drive link would be best, if you don’t have either service I can provide an alternate upload method.

Thanks,
Noris


(Magnus) #15

Sent to you now, through private message.


(Noris) #16

Thanks @Magnus_Ronnang,

I can confirm that we have received the diagnostics from you and have forwarded it to the QA team for analysis. I will be sure to let you know once they have provided their feedback and have suggested next steps. I appreciate your patience while that occurs on our end.

Thanks,
Noris


(Magnus) #17

Here’s a new clue… I have a distinct feeling that this happens when I try to connect to the Roon Core through one of my devices (Android, iPad, another computer). Can’t say for sure that this is 100%, but pretty close…


(John) #18

Hello @Magnus_Ronnang,

After taking a look at your logs, we are seeing a lot of networking related errors that may be impacting the performance of Roon. Could you try playing to the Vega DAC using Roon while the MacBook is not connected to the network at all?

-John


(Magnus) #21

Unplugged Ethernet Cable, shut off WiFi.

Same result though. Still a whole lot of lost Connections to the DAC from Roon, while Spotify seems to work.

Is it possible for me to roll back to previous version of Roon, I think it worked flawlessly back then…?

/Magnus


(John) #22

Hello @Magnus_Ronnang,

Due to the architecture of Roon it is not possible to downgrade Roon versions. We have not received any other reports of USB DACs not working on MacOS with recent updates, and I can’t think of a change that would cause the behavior you are seeing directly.

I have two further troubleshooting diagnostics I would like you to perform that will give us insight into what is occurring here.

  1. Try playing to the “System Output” zone in Settings > Audio while the Vega is selected as your MacOS audio device. This is the mechanism by which Spotify and other applications on the Mac are playing to the DAC.

  2. Try playing to the Vega DAC using the Tidal application with “Exclusive Mode” enabled. This is how Roon is playing to the DAC. In the Tidal application on Mac, enter the audio settings (you can click the HiFi logo next to the volume control), select the Vega in the dropdown menu, click “More Settings” and then enable Exclusive Mode.

  3. Starting with a fresh database may help resolve some of the performance issues we are seeing in your logs. To do this, make sure your Roon Database has been recently backed up, then use the following steps.

A. Open Finder and click Go in the top bar
B. Hold down the Alt key to unhide the Library folder
C. Click the Library folder
D. Rename the “Roon” folder to “Roon_old”
E. Rename the "RAATServer folder to “RAATServer_old”
F. Open the Roon application as normal. It will ask you to log in as if this were a new installation.
G. Only add a small amount of local content for testing purposes. If you have a Tidal account, local content won’t be necessary. Do not add any networked storage device.
H. Once Roon has opened to the overview screen, go to Settings > Audio and only enable the Vega DAC zone.

After you have performed this test, you may close Roon and return to your previous database instance. To do this, go back to the library folder, and name the current “Roon” folder to “Roon_test”. You shouldn’t have to modify the RAATServer folder again.

-John