Roon loses control of Sonos

Roon Core Machine

ROCK, latest version of the OS

Networking Gear & Setup Details

Connected Audio Devices

Limetree Bridge.
4 Sonos units (all series 1).

Library Size

Description of Issue

Roon works fine through other devices, but not to the Sonos units.

All will play fine using the Sonos app but Roon will not play any of them, after a pause I get the Roon has lost control message.

Colin so these are original Sonos only working off 2.4G wireless?
Do you have any Ethernet running to them or a Boost on the network?

Can I ask you to test some lower bitrate MP3 music. I have been through this several years ago when I got into Roon and I could almost always play MP3 files but Flac files would fail consistently. I rebuild my network to get it working.

Be good to know your network setup first

Yes, original series Sonos, no ethernet running to them, no sonos boosters. As i say, sonos systems work fine without roon.

Do you have the ability to plug any of them in to Ethernet?

I have a Sonos Amp and plugged it into Ethernet and things got much better (after removing my Boost) with Roon running the show there is additional data flowing across the network and your system is not coping with that. I was in that same situation.

My fix was to buy an Orbi Mesh system and since then almost never a dropout, but there are other things you can do as well.

If you have SonosNet set make sure it is on a different channel to your Normal wireless, or if pure wireless try to give the 2.4G a different name if you are using pure WiFi and set the music settings to compressed in audio compression to reduce the amount of traffic.

Just a couple of things to try and debug the issues, as everyone’s setup varies so need to follow a path and work through it

Thnaks for the suggestions Michael. I have possibly misunderstood your initial question. I do not have a wifi boost for Sonos but I do for the general wifi network in my house. there is a good wifi signal everywhere.

The Roon system has been fine with Sonos for several months, sudenly stops. I repeat that Sonos all works well with the Sonos app controlling, while Roon is doing its stuff on other parts of my total setup

Colin understand what you are saying and sounds a lot like the problems I used to have.

As a first off Roon do not like WiFi boosters or Ethernet over powerline adapters as they create additional potential network issues. You will often hear the push towards Ethernet and it really does make a big difference, but is also not always practical.

You can’t compare Sonos on its own to Sonos under Roon, because they are driven via the Roon server and there are so many variables involved.

So some more questions?

Is your Roon server connected Via Ethernet?

Have you done a Sonos diagnostic to see which is your current master device and that they are all getting good high quality signal, as your massage could be further out in the network which is a disaster in Roon terms. I had Sonos rest my Master to be the Amp which is plugged in over Ethernet.

These are the sort of questions Roon support will ask you before offering any help, so good to get them answered earlier

Do Roon respond to these requests for support or do I need to do something else?

Colin sometimes things can get a little slow depending on the number of tickets requested.
Hopefully in a day or two someone will pick up the ticket

Maybe a gentle nudge is needed…

Thanks Michael

Does what you have done count as a nudge? I take it there is no direct means of contact

Colin you have already included support by putting it in the support group. Kevin has merely reminded them that there is a customer here that needs help. Usually Monday and Tuesday are really busy as they pick up all the tickets from the weekend.

Thanks again Michael. I will wait

Hello @Colin_Rogers,

Thanks for your patience while we worked our way through the support threads after the weekend :nerd_face:

Also, thanks to @Michael_Harris and @AceRimmer for helpful posts :pray:

I’m sorry about the trouble you ran into, @Colin_Rogers. We’d love to help sort this out.

First thing we’d love to ask is, have you updated your Sonos devices to the latest firmware?

Are your Sonos devices grouped together when trying to use them in Roon? Could you please try adding them one by one as a Zone in Roon? Does that work?

If so, could you please group 2, then 3 and finally 4, testing in the meantime whether control of devices is maintained.

If you haven’t yet, can you please turn off and unplug your Sonos devices and reboot your Core (turn off, unplug for a few minutes, plug back in and turn on), then start adding them one by one?

Thanks in advance :pray:

Thanks for this.

My Sonos system is up to date. I had tried each unit separately and as a group, no difference.

Prior to contacting you I had rebooted Sonos and ROCK to no avail.

While waiting I rebooted ROCK again and this time, earlier today, it got things going again.
I will let you know if this situation chages.

Quite unclear to me why the problem suddenly started and then dissapeared.

1 Like

Hello @Colin_Rogers,

It’s great news - how great would it be for the victory to be permanent? :partying_face:

Thank you for trying again the same solution that didn’t work before. I’m grateful :pray:

I’ll leave this thread open so you can add any updates and, should the issue resurface, we can have our technical team take a closer look to discover the source of the problem :nerd_face:

Thanks. The problem keeps returning. Now it has an impact on apparently randomly selecetd sonos units (from a total of 4). Unplugging the NUC and rebooting usually sorts it, but is hardly a long term solution.

I will be away from home for most of the coming week so will not be able to try anything after tomorrow, but will attempt any suggestions on my return.


Hi @Colin_Rogers

If you play to each of the Sonos zones individually does everything continue to work okay?

What if you group just two zones at a time? Does that work?

I rarely pair zones. There seems to be some randomness to this. At present only 1 of the four zones can be controlled by Roon. All are fine using Sonos

Just tried another test. Played the one sonos unit OK with Roon. Fine. Try pairing with one that isn’t, neither then work.