Roon loses files and rescans [Resolved]

@support. I have had problems in the past with losing files. I followed your advice to remedy this, and reverted to a very straightforward setup. I now have roon core on a macbook pro connected by ethernet to an airport extreme. My Synology nas is also connected by ethernet to the airport extreme. This initially cured the library problems that I had contacted you about.

My new problems started to occur with version 234. One example of my problem is that if I log into my nas from another computer, I lose my roon library and need to restore from backup. This is also true if I perform any activity on my nas – like adding files while roon is running.

My current work around is to quit roon whenever accessing my nas from a computer other than the one containing roon core. This is a pia.

I really would like the option of turning off scanning for new albums/ changes except on restart of roon core. Roon is an expensive program, and if not perfect, it should at least not be annoying.

Are you running roon as a single core on one mac…with the NAS as a single point for music?

Perhaps you give more details about how the NAS share is setup (user / permissions etc) also about your network setup, as in what is on wifi etc, plus what model NAS and mac hardware/OS etc too

I run 2 synology NAS with several cores and many remotes and nothing is out of the norm with respect to files and rescans. I run MAC/PC and ROCK cores and the same with Remotes as well as iOS devices.

Thanks for your response. I don’t know how to answer your questions without them being more specific. My setup really is as simple as possible. I ditched all complications at the request of Eric when I was helped with this issue before.

The problems that I am experiencing are with roon core alone, so I’d rather not complicate the discussion by commenting about my playback equipment, etc.

For the sake of argument, let’s say that there is one more computer, a mac, connected by wifi, and it needs to occasionally access the nas, but it can’t do so without killing my roon library unless I first quit roon core.

Im not wanting info on your playback equipment… its your NAS and network configuration that seems to be somehow impacting your roon situation.

I can’t see how this would be happening however based on your quite typical setup. As I noted I have several cores many remotes and 2 synology NAS in my setup and have no such issues…I even had them all working prior over Apple Airport Extremes tho I have since replaced with better Ubiquiti gear.

I do plenty of other things on my NAS too hence I am wondering if something is way under spec’d for your setup. Without much more info I can’t suggest where you should look.

Thanks again. I really want to answer, but don’t know what information to give. I have a Synology 1813+ running the latest software. My macbook pro runs some version of Sierra. Both are connected to an airport extreme via ethernet cables. The nas appears on the mac via smb.

What other information would be useful?

One further update. I just got rid of the smb connection from nas to macbook pro by running a direct ethernet cable. This is a bit more robust, and I was able to acces my nas from an external computer without a library loss; however when I tried to add files to my music folder on the nas, I lost my library and had to restore from backup. Perhaps I should add that I use itunes for library (I mean on my nas) management.

Hi @ronfint ---- Thank you for the feedback and my apologies for the wait here.

Moving forward, I would definitely like to grab a set of your Roon logs so we can have a closer look into what could potentially be causing this issue. The only thing that you should be aware of is that we would require that this issue be reproduced so we can catch the “failure” in the log traces. Since you’ve been restoring from backups to return the app to a function state, I fear that the information we need will not be present unless we replicate and capture logs immediately afterwards. With the above in mind may I very kindly ask you to please perform the following:

  • Very Important - Please reproduce the issue and note the time when the observation is made.

  • Once the issue has been replicated and the time note, please use this link as a guide, and send us over a set of your Roon logs from your Core.

Furthermore, being as the main symptom (i.e adding musical content to your NAS causes a library failure) has been consistent despite using previously made backups I wonder if there could be something else going on here and would strongly urge you to consider trying the following tests:

  • Start with a fresh DB.

  • Locate your Roon database according to these instructions

  • Rename the entire Roon folder to roon_old

  • Relaunch Roon, sign in, and configure a new install

  • Let us know if you experience the same behavior

  • Test with a different device hosting your Core.

Lastly, outside of using the NAS with Roon, how has the unit been behaving when performing other tasks?


Can you specify if you use the iTunes feature of the Synology or are you accessing a proper iTunes library, which is outsourced from your computer?

Did you try if this issue still occurs if you temporarily disable this feature or use a regular folder on the NAS for music files that is not used tby any other applications or services?

1 Like

Thank you for your response. I am not using any itunes feature of Synology. I am only using itunes to add music files to my nas. There is nothing specifically Apple-oriented in my library. (I think.)

@Eric Thank you very much. I will follow your instructions in a day or so. On Friday one of the drives in my Synology nas failed, and it has taken several days to get a new drive installed and for the nas to repair itself. Before I do anything else, I want to make sure that it wasn’t the failing drive that was causing the problem that I reported.

1 Like

@Eric I tried to add a file to my nas at 5:06 pm today and the library lost over 6000 albums. I have a zipped log, but I do not have a dropbox account. How can I send the logs to you?

1 Like

@ronfint ---- Thank you for the follow up, I have sent you a PM with upload instructions.


@Eric Thanks very much. My logs have uploaded.


Hi @ronfint ----- Thank you for the follow up, confirming the logs have been received and passed over to our techs for evaluation.

Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you ASAP. Your patience is very appreciated!


Thanks, Eric.

Just a bump to see if the techs have a suggestion as yet.

Hi @ronfint ----- Thank you for touching base with us, and more importantly, thank you for your patience. My sincere apologies for the wait here.

Moving forward, our team has an understanding of the reported behavior (i.e losing files and then rescanning on NAS storage) and are vigorously testing a fix in our QA lab. While I can not guarantee that the mentioned fixed will apart of the next release, I would recommend keeping an eye out on our release notes to confirm it’s deployment.


Hi @Eric,

This is very good news indeed. Thanks very much!



I’m assuming this fix did not make it into Build 269, since I just tried to access my NAS while Roon was on and lost a huge number of files from my library. At least I’ve become very efficient at restoring from backups.

Hi @ronfint —— Thank you for touching base with me and my sincere apologies for the slow response here.

To bring you up to speed as to where we are with the mentioned fix in my previous post. We have been doing some extra work to confirm our “fixes” in our QA lab, and that work has now concluded. We actually have the ability to release this fix to you remotely, so I’ve now enabled it on your account.

To be clear, this issue is generally triggered by an interaction between the MacOS operating system and your NAS, and we believe it can be particularly bad in cases when the OS is losing connection to the NAS on a regular basis. The fix we’ve been testing is designed to handle that situation more gracefully, but if the problem perists we can also look at other factors, like your network, environment, or NAS settings.

As we’ve now enabled the fix for you, please re-launch your core machine, test, and let us know how it turns out.

Again, thank you for your patience and understanding. We eagerly await your feedback.