Roon losing connection to audio device

Roon Core Machine

Intel nuc 10th generation i7, 16gb of ram

Networking Gear & Setup Details

Bt Home hub router (rebooted to see if this fixed it)

Connected Audio Devices

SOTM 200 network streamer outputting via usb to the sotm 200 ultra usb cleaner
which then outputs usb to the SRC DX which then converts it to dual bnc to input into my Chord Hugo tt2.

Number of Tracks in Library

about 80,000 plus subscription to tidal and qobuz

Description of Issue

Roon has been working perfectly for me until about two days ago, now it will randomly stop playing files, sometimes when it does I see the error message Roon lost connection to audio device.
I have rebooted my nuc, checked the connection on my devices, and rebooted everything.
My hardware is as follow
Chord Hugo tt2
SOTM 200 ultra network streamer
SRC DX usb to BNC adapter
HQplayer (bought license) on the latest version

Here are my logs, the last time it happened was 12:10 today Wednesday 23rd of Feb

Hi Ryan,

This is the same problem I am having. Roon just randomly loses connection with end points. I can see from other posts they are having the same problem.

Hopefully Roon addresses this problem soon.

1 Like

I was hoping the new update would fix this but alas no such luck so any support from you guys would be appreciated.

1 Like

Hi Ryan,

Fellow user here and sorry to hear about your troubles. Have you tried to simplify your chain to Roonserver > USB > Chord TT2 and see if the connection gets lost? If it doesn’t, then slowly add another devices back into the chain as close to one at a time until you discover the weak link.

I have, it’s fine without HQPlayer in the chain but it had been working flawlessly for months before this with HQP in the chain so I am a little stumped.
I have reinstalled HQP,made sure I have the latest version, rebooted my nuc and checked all the settings.

Hmm, it might be a good idea to layout the audio chain in specifics, from what you posted the chain which works is this…

RoonServer >ethernet>SOTM 200 ultra>USB>200 ultra usb cleaner>USB>SRC DX usb to BNC adapter>DUAL BNC>Chord TT2

And, the chain with HQPLayer is the same except it is [RoonSever local to HQPlayer>Ethernet] to start things off.

And when you mean losing connection, you mean the Roon loses the connection to HQPlayer, meaning that it shows “No Output Zone”?

There have been a couple of updates to both. I would verify that you indeed have the latest of each program. If you, eliminate Roon and just use the HQPlayer Client and play Qobuz tracks, do you loose connection?

Also, it might be a good idea to see if @jussi_laako has any ideas or suggestions.

HQPlayer log of this happening could be useful.

1 Like

Hey @Ryan_Sayce,

I see that you mentioned being on the latest version of HQPlayer but wanted to confirm that and pass along these recent build notes from 911

1 Like

Hi, I can add HQP logs the next time it does it.
Roon is currently at version 913 and HQP is at 4.17.1

Just to be extra clear
Nuc is running Roon server and HQP desktop, my SOTM 200 Ultra then either runs as a Roon or HQP endpoint, it then outputs via usb to the sotm 200 ultra usb cleaner which then outputs to a SRC-DX which converts the signal to dual bnc which goes into the back of my TT2.

I am only getting issues when I have HQP selected in SOTM and not Roon, it says something like Roon lost control of the audio device (I gave the exact error msg in the first post and I can’t remember it off hand).

1 Like

A post was split to a new topic: Roon not detecting any audio devices

9 posts were split to a new topic: Roon Server on Antipodes S30 not fount my Roon Remotes

I am having trouble locating the HQP log in windows 10, where should I look and what will it be called?

You can find it from folder %LOCALAPPDATA%\HQPlayer
file is called HQPlayer4Desktop.log

1 Like

I must be doing something stupid as I am in that folder and there is no log file, there is

but no log file, logs is ticked under settings as well.

I have shared my room log files if you scroll up to my first comment, if you can’t access them then let me know.


Thisis probably the log file, but you have Windows File Explorer set to hide file extensions. You can change this from Control Panel → Folder options.

Here is the HQP log, thanks again for the support.

Yes, I checked and everything is the latest, Roon is build 913 and HQP is 4,17.1
I have also added HQP logs along with Roon onto my google drive for you.

Hopefully between these logs we can work out what is wrong.

# 2022/03/06 10:55:18 clStreamReaderHTTP::Execute(): clStreamReaderHTTP::Execute(): read timeout
  2022/03/06 10:55:23 End of track
& 2022/03/06 10:55:23 Next  (0)
  2022/03/06 10:55:23 Idle request
- 2022/03/06 10:55:23 Control ended from
  2022/03/06 10:55:27 Stop request (tail)
& 2022/03/06 10:55:27 Stop...

This is where it goes wrong. For some reason Roon stops sending data and as result HQPlayer concludes it as premature end of track. And Roon thinks someone else stopped playback and drops the control connection.

Any idea how to fix it?

What kind of source is this? Where is the source content stored? If Roon is not able to fetch the source content fast enough, there could be glitch providing data to HQPlayer.