Roon losing control of device and won't play on other devices [Solved]

Roon Core Machine

Intel NUC with 11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz 2.42 GHz; 16 GB RAM (15.7 GB Usable); running Windows 11 Pro

Networking Gear & Setup Details

ASUS 6600AX Tri-band Wifi Mesh Router System; Sonos device connected to router via ethernet; satellite sonos and Minidsp devices connected via wifi

Connected Audio Devices

  • Minidsp SHD Studio, 4 different sonos speakers and 1 Sonos Connect

Number of Tracks in Library

Music library is from Tidal only

Description of Issue

Background: I was using a laptop for my Roon Core and the system was all working fine and good. Then, I disabled that Core in that laptop and installed Roon on my new NUC to now act as the Core. It appears to be working fine with my Minidsp SHD, but:

  1. My laptop, iPad, and iPhone don’t “see” my new Core and can’t connect to it. The message says, “Looking for your Roon Server” or “Looking for your Roon Core” depending on the device. How can I get these devices to connect to the new Core?
  2. When I choose any of my Sonos devices for playback, I get a note after about 5 seconds that says “Roon lost control of the audio device”
    Can you please help?

How can I get support? I have hours invested in solving this problem. I posted a question and got not response. Could I hire someone to get on the phone with me and help me fix this problem? I would like to keep Roon (for decades) but will have to let it go if I can’t get it to work. How do I get help?

Update on this problem: I switched back to my laptop that used to run Roon well and now it has the exact same problem.

Sounds like a network configuration problem. Please list the IP addresses of all devices - laptop, iPad, iPhone, NUC.

This is the place to get support, there is no phone support (and trying to solve network problems over the phone is pure hell).

It will take a few days (or a week or two) until official support will get to this thread because they are perpetually understaffed. But in the meantime experienced users will try to help.

Mario!
Thank you!! I feel encouraged by your response and again have hope that maybe I can get this stuff to work again! And, helps to know they have staff to get to this but are understaffed.
According to my windows networking, IP addresses are:

192.168.50.109
192.168.50.124
192.168.50.102
192.168.50.174
192.168.50.210
192.168.50.72
192.168.50.80
192.168.50.125
192.168.50.15
192.168.50.125
192.168.50.1
192.168.50.92 (iPad per iOS settings), doesn’t show up in windows for some reason?
192.168.50.131 (sonos bridge)
192.168.50.144 (iPhone per iOS settings), doesn’t show up in windows for some reason?

OK, thanks. Looks reasonable, but which one of the listed addresses is the NUC?

It’s normal that Windows networking does not show the iPad & iPhone as they will be connected to the router’s wifi, so Windows normally won’t know if they are not advertising any network services (which they don’t normally)

OK. Makes sense. Thank you for the color!! I’m looking at my ASUS router app now and see that the NUC is 192.168.50.103

And, thank you for your very kind help!!!

Trying to get my iPad to connect to my Roon Server. For firewall exceptions, I see:
Screenshot 2023-11-10 151254
Screenshot 2023-11-10 151355

Glad to help out!

OK, so the IPs are all on the same subnet, 192.168.50, which is good and as it should be. Unfortunately, this rules out my first hypothesis :slight_smile:

I realize now that you are running Windows on the NUC, so did you ensure that the firewall is open? See here:

1 Like

Mario! Thank you!!! Solved the problem and it is working now! You are a kind person!

1 Like

Glad to be of service :slight_smile: Enjoy!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.