Roon losing device drivers

Dedicated System - runs 24x7:

  • Windows 10 Pro
  • Asus Strix 370 - I
  • Intel Core I-5 8600K
  • 16GB RAM

Roon is version 1.5 (build 363 stable - 64-bit)

Often Roon will loose track of local audio devices and I have to

  1. uninstall Roon + all data and settings
  2. restart computer
  3. reinstall Roon
  4. restart computer

After this sequence, and turning on all of the devices, the devices will come back after 10-15 minutes. [UPDATE] During this time all devices may appear briefly (1-2 seconds), but then disappear. This continues to happen when one or more of the existing devices are present and Roon is “enabling” it (them). The devices only show up and don’t disappear when Roon has enabled them [END UPDATE]

By lose track of devices, I mean when I go to settings/audio only networked devices are present, e.g. Kef wireless, Apple TV. Below is an example.


This issue occurs with Roon and Roon Server and has been an issue for about 6 months, but is now occurring daily whereas it might occur weekly last month. I do not know what’s changed other than a windows update.

If I refresh it will run indefinitely and not show any devices:

This is what it should show the ones below (and others):

I am trying to understand why it keeps losing them and how I can prevent it. The system does not sleep, nor does the screen blank.



Hi @steve_smith1,

This issue you are seeing is often attributed to a firewall blocking Roon somewhere.

Can you please check to see that both Roon and RAATServer are listed as exceptions in your Windows Firewall using these instructions and also make sure that it’s listed as an exception in any Antivirus or other Firewalls you may have?

I have seen Windows Update sometimes revert these firewall settings, so I would double check and possibly even re-add these exceptions to see if it helps. Hope this helps but do let me know your findings!

– Noris

Thanks Noris - will do.

I don’t know for certain, but I suspect this is related to a problem that Roon has with Realtek drivers - the drivers for the sound chip that is on your motherboard. I have seen something very similar, or the same, which is that ALL of the devices on the machine that has Realtek drivers disappear. Looks identical to the behavior I have seen on my son’s PC.

If that is the case, the same workaround that has worked for us may work for you, albeit it is not pleasant. What you do is find the RAATserver folder and delete (or rename, either way, so that Roon cannot find it when it opens) it, and then boot up Roon. That has worked so far for us, although it means not only do you have to delete the RAATserver folder every time before you run Roon, but you have to reconfigure your audio zone every time you boot Roon.

Roon says this is a problem with Realtek drivers. I guess that depends on your frame of reference, but given (1) that deleting the RAATserver folder is a temporary fix and (2) that Realtek drivers are here to stay, that it more be more fairly characterized as a problem Roon has with Realtek drivers, and it is on Roon, and not Realtek, to fix it.


Everything looks fine - defender handed off to Norton (options grayed out) and Norton allows both programs (Roon and RAATServer).


Try replacing the Realtek drivers with Microsoft HD audio class drivers.


Yes, Indeed. :wink:

I don’t remember the exact details since this was first investigated years ago, but I believe that this is not a problem with all versions of the Realtek drivers. For example, I have a similar ASUS motherboard with drivers provided by “Realtek Semiconductor Corp.” that are working OK. I think I may have switched from the ASUS-customized realtek drivers to the “stock” drivers from Realtek’s site to fix this for myself, so it might be that this is not totally Realtek’s fault either. It’s also possible that simply upgrading to the latest driver would fix this–since enough years have passed that they might have fixed their problem.

Anyways–I remember some details of this failure–this was a memory leak in one of the background services related to audio that is a part of Windows. The leak grew on each format switch. Roon runs through a cycle of tests to determine audio format capabilities of the hardware around startup. This procedure puts a lot of pressure on this driver bug compared to most apps.

That doesn’t mean we are doing anything wrong–we do need to accurately detect format support after all…otherwise our audiophile customers would not be able to play all of the formats that their hardware can actually support in a bit-perfect manner. I recall that at the time, this leak was reproducible using other software by setting up a looped queue of short tracks of different formats + configuring it to play in exclusive mode, too. So this definitely wasn’t just impacting us.

Anyways–I trust that our @support team + community can help you figure out a driver version that works + isn’t broken. Just wanted to chime in here on some of the technical details.


Thank you! that was perfect!

Removing the RAATServer folder does eliminate the problem - I was able to reproduce the issue and correct it by removing the folder 3 times by killing and restarting Roon three times - the issue is so bad that I have to remove the folder each time, which I was doing by uninstalling/reinstalling.

This is not a happy circumstance! Is this being worked on?



Glad that helped. See Brian’s response above - perhaps Roon is hoping the memory leak goes away; still I would think if it clears with deleting the RAATserver folder, then there would be a way to fix it within Roon, even if this is fairly characterized as a Realtek problem.

Thanks Brian. It is helpful to understand why this is happening. And yeah I have noticed the memory leak - on my Roon core when I use the system output for the purpose of syncing with a visualizer, memory usage goes up considerably and eventually I have to restart.

And you are right, this is with the Asus set of drivers. Maybe we will try standard Realtek drivers not from Asus.

All that clearing the RAATServer doing is un-enabling the device, which means on next startup we don’t perform format detection for it, thus avoiding all interactions with the buggy driver and avoiding the problem.

OK, I see, thank you for the explanation. So then if Roon did something to avoid this, then we’d have to reconfigure the endpoint anyway, so not so much of a fix.

Maybe there could be a setting to “remember” format capabilities for Realtek drivers or something, that could allow the workaround only to have to be done once? It’s not pretty, I realize, but I must imagine there are a fair number of users out there with Realtek drivers, having issues, and just give up before they can get it working. Seems a shame.

I only figured this much out, using the forum etc., because my 10 year old is committed to being able to use Dad’s Roon to listen to his favorites, Led Zeppelin, David Bowie, Clash, and the Cars and he harassed me until I got to the workaround. I made him a shortcut to the folder so he can rename the RAATserver folder himself.

Guys, stop beating yourself around the head with kludgy workarounds and just replace the faulty drivers.

First check for any updates to existing drivers, which sometimes fix issues. If that doesn’t do it then the MS HD audio Class driver referred to above worked for me when I had a similar problem in 2015 with on-board audio devices.

As andybob suggested, I did replace the Realtek drivers with the Microsoft HD driver - that did not change things.

Specific steps were:

  1. Shutdown Roon and remove the “RAATServer/settings” directory to get rid of any residual Realtek devices.
  2. Reboot after installing the Microsoft HD drivers and restart Roon -> the devices were present as expected,
  3. Enable the devices I needed and shutdown Roon to test and see if the issue would reoccur upon restart.
  4. Restart Roon and the issue reoccurred (no local devices found), meaning it was not the Realtek drivers.

Next steps;
andybob’s advice to reinstall drivers lead me to see what else could be causing it. The only driver I have that’s probably not commonly used in our community is DTS Play-Fi from

[Update- I left out a chunk of the story]: I removed the play-fi device from the RAATServer/settings directory and restarted Roon - the issue went away - all of the devices were present.

Then to see if that may be causing the issue, I enabled the Play-FI device, shutdown and restarted Roon only to find that all devices were still present; I repeated the shutdown/startup sequence several times without any problems (all devices present)… I also used Play-Fi, by selecting as a zone and sending music to the Play-FI speakers, shut down and restarted Roon and went right back to playing music on the same speakers - no issues with other devices either.

Bottom Line: Enabling and using Play-Fi does not seem to cause the issue, but when the issue occurs, removing Play-Fi from “RAATServer/settings/” does seem to correct it. I will have to verify this when it occurs again.

I know Roon is not intended to be compatible with Play-Fi, we had that discussion sometime ago - I just hope they can live together - Having Roon send to Play-FI speakers is a major benefit to me…

My thanks to everyone for their help getting to this point. Let me know if there is something else I should be checking.


1 Like

Hello @steve_smith1,

Thanks for posting the troubleshooting steps you have tried so far. Since we know that Play-Fi causes issues at times, I would suggest disabling it completely and confirm that Roon is stable without it.

It seems like it might be an intermittent issue so getting a clean test without the Play-Fi driver anywhere in the mix would be a good troubleshooting strategy.

If you can confirm that the issue still exists after completely disabling Play-Fi and running with the setup like that let me know and we can take another look at what could be going wrong here.


@noris, thanks I will do that and let you know if there is still an issue.