Roon losing DS in 'Linn Streaming' mode

I have an AEDSM and trialling Roon. Roon sees the DS two ways, as ‘AirPlay’ (I have no Apple devices…) and ‘Linn Streaming’. Linn streaming gives control over the volume in the Roon app, AirPlay does not.

‘AirPlay’ displays as ‘Net Aux’ on the DS, ‘Linn Streaming’ displays as ‘Roon’.

More importantly, when I play via ‘Linn Streaming’, Roon loses the DS after a random amount of time (10-30 minutesish) and won’t see it again until some random time in the future.

If I play via ‘AirPlay’/Net Aux, I don;t have this problem, but also don’t have volume control.

Can anyone explain what protocols the two methods are using and why ‘Linn Streaming’ only works for a short while?

If the answer to the first question is ‘OpenHome’, that probably explains the latter question. :frowning:

Airplay is using airplay which is a streaming protocol.
Linn roon is a collaboration between roon and Linn I believe to use the native linn stream.

It sounds like a possible problem with your network.

I have a KDS on my network, using a Roon Nucleus, and it works perfectly.

How is your DS connected to your network?

Depends on your definition of ‘problem’, but I suspect you are right that there is something going on with SongCast and my network (which I understand is what Roon is using the ‘Linn Streaming’).

Disappointing as Roon (albeit ludicrously expensive) was doing such a good job of being instantly available and reliable compared to Linn’s apps/server. If I use AirPlay to the DS, it doesn’t miss a beat, but doesn’t sound as good and doesn’t allow in-app volume control.

I’ve really had it with Linn and their networking. I can shift nearly two orders of magnitude more bandwidth than a 24 bit Flac is using around the wifi parts of my network (more still round the gigabit ethernet parts of course) and have ping times of around 3 ms to the DS, despite wifi being in there. It is ridiculous that the Linn protocols (SongCast, OpenHome) are so unreliable when every other protocol to the same device work fine. I can pump multiple hidef video streams around the house (via AC3200 wifi), but the Linn DS can’t cope with audio. It’s a joke and despite the superb sound I wish I hadn’t blown all this money on it.

Apologies for the grumble, thanks for replying and I suspect you are right that this is not the fault of Roon.

1 Like

I admit, it’s very off-putting.

When I first connected my DS to my network, I connected it directly to my ASUS router. I had horrendous problems, and the DS kept dropping off the network/undiscoverable.

I then followed Linn’s advice:

I put a NETGEAR GS108 in the system, in-between the router and the DS. It now works perfectly. Maybe worth a try in your system?

My internet router is actually on a different subnet, to keep problems due to the rubbish ISPs tend to provide, away from the home network. I have multiple Netgear GS105s on the network (five-port version of the 108) and one of those is actually between the server and the DS. I’ve run a home network for twenty years and never had problems before getting the DS. I have a cheap Yamaha streamer that has no problem (including with 24 bit FLAC) runing from the same sever on the NAS, despite being more hops away from the NAS than the DS is. The Linn stuff is just a nightmare from this perspective.

My opinion is that they made decisions/bets on protocols years ago when they were basically the first high-end streamer on the market, they didn’t pan out and now they are stuck with it.

Just in case the loss of connection was due to running Roon from an (intel) QNAP NAS, I installed Roon on a linux PC, exactly the same problem, connection dies after 10-15 minutes. Ah well.

Puzzling indeed. I’ve attached a schematic of my home network. The Klimax required a power-cycle a few times in the last year, but otherwise everything works really well with Roon.

My set-up is not dissimilar. Internet router on one subnet through to a Netgear Orbi (AC3200) router, ethernet backbone to an Orbi mesh point, ethernet from that to a GS105, with a QNAP NAS connceted to that. Dual 5GHz link to a netgear RP3700 (which is in wireless receiver mode only) and ethernet from there to the DS.

Various other spurs with ethernet backbone.

I have ongoing issues with the Linn protocols (and no others or other devices). Linn’s OpenHome discovery with various control apps is a nightmare too, but once a playlist is established it works fine. I haven’t tried Songcast before, but looks like it is another problem.

As I said, Roon seemed so much more reliable, but looks like the Linn protocol that Roon is using is still a problem… :cry:

The Lumin streamers are just faultless in their integration in a network. I’ve run D1 & A1 without any problems whatsoever.

I have no idea why Linn DS’s are so problematic…

1 Like

T2 looks like a sweet spot. Wonder how they compare with Linn gear? Problem is Linn are very good at locking you in and I do like the idea of pushing the DAC as close to the speakers as possible (I have an Exaktbox-6).


I use two different Linn setups and I do have absolutely no problem with Roon.

Akkurate DSM & Klimax 350Exakt
Majik DSM, Majik 4100, Isobarik (partly activated)
Roon Nucleus+

All network connection are hardwired, I use a Extreme Networks Switch as main switch and distribute all connections via cat 6. All devices are plugged in a rj45 wall outlet.

Everything works fine, no dropouts, all gapless and no network packet loss.

However, I agree Linn could make the protocol native, but that would be against their philosophy. One of the reason why I like Linn is exactly this point. So it’s difficult for me to to have a 100% firm position.

However, I cannot agree that Linn has a problem by design.

Kind regards


I don’t want to get into a pointless internet arguement, but I find the brand loyalty on this subject weird.

For reference, I first bought a Linn amp 20 years ago and my system eventually became 100% Linn (which it still is). So I have a lot of brand loyalty there.

But why do people defend a $10,000 device that is often unable to cope with any but the most basic Ethernet network with nothing else on it? We wouldn’t accept a $30 wireless network device regularly losing connections in this way. This is decades old technology and a 24 bit pcm file is not much bandwidth to modern WiFi.


Good morning.

I cannot speak to why these specific issues are occurring on these specific networks but in general it sounds like all the issues are network and/or non-Linn device issues.

There really is no such thing as network devices that never-ever have issues and Linn is not exempt from that. Yes I have had an issue or two over the 3-decades as a Linn Hi-Fi owner; and an issue or two over the past ten years as a DS / DSM owner. However overall I am beyond impressed with where Linn is today and their direction going forward.

I have a bit of a demanding home network environment, that has evolved and even again recently by replacing my entire network… during all of this Linn has never had network related issues like I am reading in this thread. And that is a big statement - especially when one is running (23) DS / DSM’s on a network, with all (23) running 24bit SongCast music without missing a beat (no pun intended - lol)

Everything I have stated has all been “Pre-Roon”… I have only this summer added Roon. I resisted it at first, tried it but didn’t really give it a fair shake but now that I have rolled it out, myself and everyone in the family now loves Roon.

I did have an issue initially trying to get the Roon Server and Linn working with the new network but after I made two changes on the router settings (IGMP snooping and IGMP Querier) everything immediately began working like a champ.

Regarding Air Play vs Linn Streaming via Roon: Air Play is reduced quality and I think it may be only 16bit whereas Linn Streaming is very high quality; I never choose Air Play.


You are not taking the point. I am not defending Linn, I only say in my setup are no issues and if it would be design issue all Linn DSM / DS user would have the same issue with Roon.


When a network device works well for some people and not well for others, the most likely problem is some interaction between different network components. We all hope that networking is just plug-and-play, but unfortunately the network protocols we rely on are complex and their implementations on different devices have bugs, sometimes really hard-to-track-down timing or edge-case bugs that only show up rarely on a few combinations of gear. Anything that involves IP multicast on home LANs (including Roon discovery, but also widely used services like mDNS) is problematic because of IGMP bugs or unwarranted assumptions widely used gear (Netgear GS108, I’m staring at you!).

Those problems with Linn gear are frustrating, but is it the Linn gear, or its interactions with the rest of the network? If you really want to the bottom of it, the only solution is to rebuild your network step by step from a known good state. Sorry, that’s what I’ve had to do twice (before I had Linn gear, BTW), which is how I discovered the worthlessness of powerline Ethernet adapters (two houses ago), the bugs in a well-known streamer (sent back for a refund), and the problems with the GS108. Given all those experiences, I worked in a very deliberate way with my Linn dealer when I bought Linn systems last year for our new house – discovering some really bad stuff with my Xfiniti service in the process that required a lot of other work – but the result is a network that works with all the gear I have (well, with the occasional exception of WiFi lossage with a Chord 2go, but that’s for a different thread).

1 Like


I‘ve had the same Problem with 3 different Linn ds systems!

Even with one which was hardwired to the same switch as the qnap with the roon core and the control PC.

I didn’t had network Problems!

The problems started somewhat after updating to the new roon core version.

I found the solution for my problem:

you need just stopp rooncore and then start the roon core again on the qnap. after that it now works for me since 1 week without a „hang“.

Since I didn‘t restart any network components to solve the problem, i believe roon is just like Microsoft in early day‘s.

If the problem comes back i write a cron script to restart roon on a daily basis at 3:00.

best regards,

PS.: don‘t waste your time and money in a new network if it is just a instable software.