Roon losing Microrendu

Computer Aspire Z3-715 using Windows 10 Home, latest build of Roon

The last three weeks or so Roon has been losing my Microrendu. I send music to microrendu and it just skips songs and will not play any. I have to unplug Microrendu. Sometimes I have to restart computer as well as unplugging Microrendu. Now I have unplugged and restarted Microrendu. I have restarted computer and Roon. Roon does not see the Microrendu at all. It is not one of my zones or listing under settings. Roon sees my other two zones. The problem is communication between microRendu and Roon

Networking gear a verizon router.

I went to and the webpage sees the Microrendu. I restarted Roon ready on the webpage. Roon still doesn’t see the microrendu. I tried to run Roonready diagnostic and got a response ERROR 500 service unavailable. The web service is unavailable. Don’t know how to proceed from here.

According to the AudioApp swticher Roon ready is running.

is the device working with other music programs? Reach out to where you purchased it or to Sonore. Might be a bad SD card or device. Are you running 2.7 or 2.8?

I’m running 2.7 right now. I emailed support Jesus R. I haven’t heard anything back yet. I’ve not had much luck getting a response from Sonore in the past. I hope they respond to my email or someone on the forum has some idea of how to get it working. I haven’t tried any other music programs. All my other zones are working fine with Roon.

Check your power supply, the cable, and take the card out and reinsert it a couple of times. Clean the connection points with contact cleaner. Gently wiggle the cable at connection points to make sure its intact. Those are simple connection cleanups. If you have a bad card, contact @agillis at Small Green Computer and purchase a 2.8 card. They are $29.

Hi Thanks for the suggestions. Well I disconnected the MicroRendu from the Mytek Liberty DAC I was using, and then connected the MicroRendu to another Dac. Roon then saw the MIcroRendu and music played through it. When the Mytek is connected to the LIberty DAC, Roon doesn’t see the microRendu.

An iPhone worked fine on a different Dac, but not on the Mytek Liberty. Problem answered must be the DAC right? Then I connected the Mytek Liberty DAC to a Windows computer and it worked fine. I’ll try to see if there’s a firmware update or something for the Liberty, but this is a strange situation.

So then I plugged the MicroRendu into the Mytek Liberty again. Roon sees the Liberty. Played music through Roon and it just skipped through songs. So the problem seems to be communication between the Mytek Liberty and the MicroRendu. They both work fine separately. I don’t know how to fix this. There are certainly Roon users with MIcroRendus and Myteks there must be working together for a lot of people.

Reach out to Andrew at Small Green Computer and Mytek…

I run both of my microrendus through Sonore UltraDigitals and split the signal to two DACs in each setup.

No experience with the Mytek. This is a guess, but make sure you are not upsampling in excess of the specs of the Mytek. If the Mytek is limited to 24/384, don’t send 24/768 signal, or at a high DSD rate. Try it at 16/44.1 CD rate.

If the Liberty is linux based and uses the xmos usm you may need a firmware update. My PS Audio SGCD required new firmware for same reason.

1 Like

Typo. Should read XMOS usb

Separate question, can the SGCD update be accomplished by the end user or did you have send it in? Thanks?

Not familiar with the Liberty. I could have updated the SGCD myself but had to send it in for another reason so they did the update for me.

I would contact Mytek.

No my question was specific to the Stellar Gain Cell DAC. How do you update it from home.

Andrew at Small Green Comp. Was helpful in determining that the issue was with the DAC

Sorry. Misinterpreted your question. Since i sent it in i am not sure. They were going to send instructions.

1 Like

My problem appears to be upsampling. If I play music without upsampling, no problem. If I upsample, then it either skips the tracks or won’t play at all. It’s not that I’m upsampling at too high a rate either. This happens at several supported rates.

I’m always happy to help with all Small Gree Computer hardware issues or issues with Sonore hardware. contact me at for support.

1 Like

Hi @Robert_Bee,

Do you have any issues with upsampling on the Mytek when you bypass the MicroRendu?

If I put the Mytek on my Windows computer endpoint, it will upsample to every sample rate. The problem is specific to the Mytek Microrendu combination.