Roon Lost connection to Audio device - Sonos

Dell XPS 15 laptop core i7, 1TB SSD Windows 10 running Roon and Synology 918+ with the music database in FLAC format. Also TIDAL

Roon v 1.6 build 416

Networked in building wiring using powerline adapters to Sonos Connect

I have just installed Roon on a 14 day trial basis - this is day 2. It is running on a well specified laptop which should be more than up to the job. Playing it today it would cut out after 1 or 2 minutes and give the message (Roon lost control of Audio device). The display on my Android tablet shows the music as stopped - I press the play button and it starts playing again for a couple of minutes. This seems to happen regardless of whether I am playing from the server or from TIDAL.

I tried playing the same music using the Sonos interface and there was no problem.

If I decided to stay with Roon then I would plan to buy a dedicated PC to run Roon but don’t want to go down that path if I am still going to have problems.

Any ideas gratefully received. I have read some of the other similar threads but they seem to relate to much more complicated setups than mine and to be honest I don’t understand them!


Hi @Clive_Pollard,

Welcome to the forum, I’d be happy to assist you here.

Can you please confirm if this issue occurs on other zones or just the Sonos zone? If you try outputting to “System Output” (your PC’s speakers) for example, do you notice similar behavior?

We have often seen issue surrounding powerline adapters when using Roon. In most cases, we have found that powerline adapters do not pass multicast traffic through properly, and Roon relies more heavily on multicast than other music streaming apps. Is there any change in behavior if you connect both your Core PC and your Sonos via Ethernet to the primary router?

This happens to my Sonos Play:1 occasionally since a Sonos update a few months back. Restarting my Roon Core (ROCK) resolves it.

I connected another Sonos device to the network (ethernet) and all was fine, also playing through the laptop speakers was fine.
I have reconfigured the Sonos for wireless - I have a mesh wifi system in my house but have the same problem.
The problem is that my main music system is at the other end of my old house to my router etc - the house has 3ft thick walls so running a cable is not an option.
I am guessing that I have run out of options?

Hi @Clive_Pollard,

Just to confirm, are they connected to the WiFi or to the SonosNET mesh network?

Not necessarily. What type of Mesh Network are you running, can you let me know the model/manufacturer? Does the Mesh Network have an Ethernet output you can temporarily connect your Sonos Connect to?

What if you temporarily connect the problematic Sonos Connect via Ethernet, does that function as expected? This would help us differentiate if the issue affects _just_that Sonos zone or if it affects all Sonos zones via Wireless.

I have rebooted the mesh network (BT WholeHome).
The Sonos was setup on my home wifi - I have now set it up on Sonosnet so everything working over wifi.
Over a period of 10-15 minutes of listening everything seems to be working ok.

What I haven’t tried yet is connecting the Sonos play device to the mesh via an ethernet cable. I am away for a few days so will do some further testing / experimenting when I get back after the weekend. I will then let you know if it is all working.

Many thanks for your help


1 Like

Hi @Clive_Pollard,

Thanks for the update here, do let me know how further testing goes when you’re back from your travels!

A post was split to a new topic: Roon not seeing Sonos Connect

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.