Roon Lost Connection

I’m having a problem whereby Roon frequently loses connectivity, and I wonder whether it would be possible for you to turn diagnostics on so that the problem can be looked at?

I’m running ROCK on an Intel NUC; networked devices are on fixed IP addresses. I’m routing through a non-managed switch.

I think that it is Roon specific - for example, if I play an album or stream from Qobuz using the Naim app, then this problem doesn’t occur.

Any pointers would be much appreciated.

Many thanks


Hi @Mark_Hartt-Palmer,

When you say Roon loses connection, is it that remotes are disconnecting from the Core machine? Does it happen for all remotes at the same time?

Has this always happened or is this a new issue?

Hi Dylan

The music suddenly stops, with a lost connection error. This happens on library albums stored on a Synology NAS, Roon Radio and Qobuz. However, if I stream from NAS, radio or Qobuz directly from the Naim app (ie not using Roon at all) then all is fine.

This is a fairly new issue, but it’s been going on a while now. All networked equipment has its own dedicated IP address.

Many thanks


Hi @Mark_Hartt-Palmer,

To clarify — Are your remotes still staying connected to the Core at this time? Is it just that music is stopping on the Naim?

If you play to a different endpoints, like System Output of a remote, does the same behavior occur?

Hi @dylan

No, the remotes are showing lost connection simultaneously - iPad, iPad Pro and Roon for Windows.

This behaviour occurs whatever output I play to, including System Output.

If you could put a debug trace on my system, then it would be much appreciated as the dropouts are happening so frequently that’s impossible to use Roon at all at the moment.

Thanks for the clarification, @Mark_Hartt-Palmer.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thanks @dylan - latest is at about 20:25.40.

Thanks, @Mark_Hartt-Palmer.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thanks @dylan. You’ll see that I’ve just had a couple of further dropouts. I can see when I have Fing running that the device IP is temporarily dropped, reappearing again when the connection resumes.

Hi @Mark_Hartt-Palmer,

We reviewed the diagnostics report and we are seeing networking errors, but nothing specific that points to an issue on RoonServer or ROCK.

When this occurs, is there any change to the lights on the Ethernet port of the NUC?

Based on the details you’ve provided above (the IP address drops out temporarily) it would seem that there is something occurring with the network connection, but it’s hard to say just what that is yet. In the past we’ve seen intermittent network drops stem from a bad cable — Have you tried using a different Ethernet cable yet?

I’d start with a different Ethernet cable and, if that doesn’t result in any change, I’d try connecting directly to the router. Can you confirm the model of the router as well? The goal here is to simplify the setup and remove variables so we can see if there is any change.

Hi @dylan

I’ve tried using a different ethernet cable (which initially I thought had solved the problem) but I’m still getting lost connections - the last one at about 19:40BST.

I was already connected directly to the router, which is a Fritz!Box 3490.

Many thanks for your help!


Hi @Mark_Hartt-Palmer,

It’s possible that this is hardware failure on the NUC or that it’s an issue with the network. To help determine this, here’s what I’d recommend:

Connect another machine to the network with this Ethernet cable in the exact same way. Use this machine as your Core temporarily. Does the same behavior occur? Does the IP address drop and you lose the connection? Or is this just specific to the NUC?

Hi Dylan

Apologies for the long silence - I just needed to find some time to sort this all out. As it turned out, I was having other dropout problems - both with internal equipment and external connection/DNS issues. I ended up doing a factory reset and assigned static IPs on all equipment I could. So far, there have been no Roon disconnections over the past several hours.

Fingers crossed this continues. Thanks for your help!

1 Like

Hi Dylan

Unfortunately, the issue is still continuing. Every time it loses the connection and eventually reconnects, Roon scans my NAS drive, where my music is located. However, the dropouts can occur both when listening to music from the NAS, or via Qobuz.

The last dropout (the 3rd in a very short time) occurred at around 1700 BST.

I’m not sure if the fact that the NAS drive is getting full (90% used of 1.6TB) or whether it’s something else, but I wonder if you could check the logs for me again please, assuming they are switched on (I wanted to send you these from the app, but I don’t have a support ID for this case).

Many thanks


Hi @Mark_Hartt-Palmer — Apologies for the continued trouble here!

When we last spoke you mentioned that you were having some external networking connection issues and that a factory reset and static IPs seemed to help. Are you continuing to have the external networking issues? Has there been any change at all since your initial report?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.