Roon lost control of audio device - KEF LS50 W

Core Machine (Operating system/System info/Roon build number)

NAS QNAP TVS-873 | 64GB RAM | Roon Server sits on a Samsung T5 SSD connected to NAS via USB 3.1 slot
OS: QTS 4.5.1.1480
Version : 1.7 (build 667) stable
QPKG-Version : 2020-07-15
Process ID : 12623

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NAS:
QXG-10G1T network card 10 Gb port (out)

connected to:

Switch
NETGEAR GS110MX 10 Port Gigabit - 10Gb port (in & out)

connected to:

Switch
NETGEAR GS110MX 10 Port Gigabit - 10Gb port (in) | 1Gb port (out)

connected to:

Speaker
KEF LS50 Wireless

All connections via Primewire - CAT 8 Network Cables

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LS50 Wireless (connected via Cable network as described above and in Roon via KEF Streaming protocol)

A few Sonos Play:1 and Sonos One speakers (connected wirelessly to the network, Sonos Streaming protocol in Roon)

HK Aura and Libratone Zipp 2 (connected wirelessly to the network, AirPlay protocol in Roon)

Description Of Issue

Whenever I try to play music (via Roon) on the Kef’s I get a Roon lost control of audio device within 20-30 seconds from start … I can press play when it stops and will immediately resume playback to drop it again within similar 20-30 seconds.
Here’s the signal path screenshot:


This happens irrespective of the music source (Tidal or Personal collection stored on NAS).

The speakers work flawlessly when controlled via KEF app (also Tidal streaming) or using any other inputs (Optical, PC, Bluetooth).
Also, Roon controls flawlessly all the other speakers in the house, just not the KEF’s (the ones I’m most interested in and main trigger to subscribe to Roon in the first place)

Maybe worthwhile mentioning I’ve been using Roon for about 7 months now and I’ve experienced this issue once before but it “solved” itself out (maybe firmware updates, I’m not sure but I haven’t done anything particular in this regards). I was waiting for the same this time around but it’s now not working since the summer so I figured it might be more of a “structural” issue, hence this post.

I was also looking on KEF’s website and saw now they’ve launched KEF LS50 W II speakers which have Roon ready mentioned for, compared to the 1st version I have which have a Roon tested mention (whatever that means!!! have a vague impression 1 year and a half ago when I bought my speakers they had the Roon ready mark but I might be wrong).

I guess my question is, should the setup above work or is it by design that’s not possible (KEF streaming protocol vs. Roon protocols, etc.) ?

Would appreciate any thoughts / feedback towards a positive resolution.

Thanks,
GB

Hi @GB29,

Does this issue only occur when playing 96k content or does it occur on 44.1/16 content as well?

Is there any change in behavior if you try to factory reset the KEF speakers?

Hi @noris,

Thanks for your reply.

I’ve tried some 44.1 content and it worked … but strangely, now all the content works without hiccups: 96k, Master Tidal, etc.

I didn’t try the factory reset yet so not sure what happen. Happy with the outcome btw, but any thoughts on what could’ve been the cause … to try and avoid the reoccurrence?

Apparently I was too quick on the trigger there … it’s again not working, irrespective of the quality of the content.

Will try to factory reset the speakers to see if that does anything.

1 Like

Hi @GB29,

If the factory reset does not help, you can also try to switch Cores to see if just the QNAP has this issue or if other Roon Cores on the same network do as well:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

This topic was automatically closed after 259 days. New replies are no longer allowed.