Roon lost control of device (MOTU DAC)

Core Machine (Operating system/System info/Roon build number)
Core on NUC7I3BNH PC running Windows 10 64 bit, Roon 1.7 build 511 64 bit.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Library on WDmycloud hard drive, Via Ethernet cable connected to modem/router (hitron CGNM-2250), netgear switch, AirPort Extreme 802.11n (4th Generation) in bridge mode, netgear switch, NUC core. All hard wired no wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Core attached via USB 3 cable to Motu 8a (ASIO driver).

Description Of Issue
When I play a track, I get an error message that states ‘roon lost control of audio device’. If I press play again the track plays just fine. Sometimes it’ll keep on playing more tracks in the playlist, other times I have to press play again for each additional song.

Hi @Omid_Mostachfi,

Does this behavior only happen when playing certain types of tracks (one sample rate/DSD/MQA)?
Does the WASAPI driver experience the same issue?

No. Funny enough that’s a problem I have encountered and figured out. Before I changed the settings to ‘no mqa support’, Roon would skip mqa encoded songs (my motu DAC doesn’t have mqa capability) but still played other files types.
This is a different issue, Roon refuses to play and says it lost control of the device. If I push play a second time it’ll usually start playing (same file, no skip).
I just conducted a test to confirm, and it stalled on a tidal Flac file that was non MQA.

Hi @Omid_Mostachfi,

Thanks for the additional info. Can you please confirm:

Also, are you using the latest driver for this DAC?

I have the most recent driver and firmware for my DAC.
I ‘ll try WASAPI (I was hoping to avoid it, extra layer of window software).
I’ll report back.

1 Like

I tried WASAPI. Roon skips every song regardless of the file type MQA or not (on the bright side, it doesn’t complain that it lost control of the device!).
I then switched to ASIO4ALL as the driver, and it seems to play fine, without skips or lost control problems!

1 Like

Hi @Omid_Mostachfi,

Glad to hear the ASIO4ALL driver is working as expected in your setup!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

For anyone using a MOTU DAC. I was having problems with Roon losing control of the device. I initially thought using the WASAPI driver solved the problem. It didn’t.
The issue occurred when Roon played a track at a different sample rate than the MOTU was set to. Once I set the motu to 96kHz, and had Roon convert all files to a sample rate of 96kHz, the problem went away.

1 Like