Roon lost control of Sonos


I’ve used Roon since December and loved it. But a week or so ago, my Roon stopped connecting to my Sonos speakers. Whenever I try to play something, I get “Roon lost control of the audio device” message.

I tried rebooting the speakers, PC, network router. I disabled and re-enabled the Sonos device.

I use Roon on a Windows PC, with songs on a network hard drive (MyBook), with a pair of Play:5 speakers. Computer and hard drive are on Ethernet, Sonos on WiFi. Sonos play Spotify and radio just fine, but will not play Roon. Roon will play my library on my PC, but not on the Sonos.

Also tried disabling the Sonos device, enabling the Air-Play Sonos device (didn’t work) and switched back to the Sonos device (still not working).


Thanks in advance,

Hi @Jeffrey_Gray,

What model/manufacturer is your router? Is there any change in behavior if you temporarily try connecting your Play:5s via Ethernet to the router as a test?

Router is from Comcast/Xfinity, XFi Gateway, Voice and Data Modem, Technicolor CGM4140COM.

I plugged in the Ethernet cable to hardwire Sonos to router, cycled the Sonos PLAY:5 power (both speakers). Now I can play radio or spotify on the Sonos, like before. Then tested Roon.

On Roon, using the Sonos Streaming audio connection.

When I tell Roon to play, in the PC’s Sonos App I see it get the Roon song info (actually just a code) in the Now Playing window… then Sonos app says ‘unable to play to’ (it went fast, did not catch the numbers), and the Roon app says “Roon lost control of the Sonos device”.

Next steps?

Thanks for the help!


Can you look to see if there any Sonos updates via the Sonos app.

Hi @Jeffrey_Gray,

Thanks for trying the Ethernet connection.

Is there any change in behavior if you ungroup the PLAY5 speakers? Does one work and the other one does not when ungrouped?

This is also a good suggestion.


I realized my cell phone also could not connect to my Roon core, or another PC in the house.

It turned out somehow my core machine had connected to my network differently, and Windows now classified my home network as a ‘public’ network, where Roon isn’t allowed to cast. I changed it to a ‘private’ network, and everything is working again!

Thanks ged_hickman1 and noris for your help.



Happy to help @Jeffrey_Gray, glad to hear you sorted the issue out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.