Roon lost control of the audio device (KEF LS50W)

Roon Core Machine

Win10 pro, Lenovo Thinkpad L14 Intel(R) Core™ i7-10510U CPU @ 1.80GHz 2.30 GHz, RAM 16Mb SSD 512Gb

Network Details

Set of 3 Eero set as access points (not set as router),

Audio Devices

KEF LS50
Connections between Laptop and Eero and speakers and Eero on Wifi

Library Size

22,000 tracks, Tidal subscription. Problem is with both.

Description of Issue

This is an issue that I’ve had for years, and have asked on the forum before: loss of connection with warning “Roon lost control of the audio device”.

With a previous machine (Surface pro4), 2 previous access points (first TP-Link OnHub, then Netgear WAC104) I had the same problem on and off. If this is a clue, I remember that with OnHub and for sure with the Eero now, the problem starts showing up only weeks after installation.

With the Netgear, connections were wifi, then because of the problem, wired with ethernet cable to both the speakers and the laptop. Problem persisted and to make it go away I would disconnect and reconnect the 2 cables. It would go away for awhile only.

Now with the new Eero on wifi connection I thought the problem had gone away but after a few weeks it showed up again. As with previous machine and access points, the connection goes away after precisely 29 seconds (!) into the track. I can press play and the track continues, for the next 29 seconds only. (This started yesterday, today it’s fine, so the problem is not consistent)

Yesterday I restarted the speakers, Roon, the machine: none of this helped. Is this a clue: after restarting Roon, the sound level on Roon showed as 0 though the actual level was the same as before as I restarted it. Moving the slider would readjust the sound level. This happens only when the disconnection happens.

The Eero access point is mostly in clear sight.
With previous laptop, turning off the firewall for similar/same problem worked, could it here? Haven’t tried that with this laptop yet.

KEF has a warning during installation not to use a mesh network, only directly the router (which I can’t b/c it’s too far), but the speakers seem to work normally: the KEF app on a Galaxy S10e phone shows them as being normally on and I can play Tidal music and my library using same KEF app when I get “Roon lost control…” warning.

What can it be? This is very frustrating, kills the pleasure of listening to music.

Hey @Bernard_Rene,

Thank you for setting aside the time to walk us through the history of the issue and to explain how you’re experiencing it now. I’m sorry…:sweat:

By creating this post you have done the first best step - you’ve let us know of this issue. Thank you. We’d love to help.

KEF has a warning during installation not to use a mesh network, only directly the router (which I can’t b/c it’s too far), but the speakers seem to work normally:

While I cannot guarantee that the above is the cause, it would be wonderful to rule it out. Do you think that temporarily you might be able to connect your KEF directly to the router, even if it is not the ideal location?

Disabling any antivirus or firewall you might have enabled, again, just temporarily, would help too.

Please, let me know how it goes :pray:

Connecting the speakers, even temporarily, to the router is not simple, especially since the speakers disconnect with the “Roon lost control…” warning on a very irregular basis. (and the instructions to avoid using a mesh network is for the speakers to work properly. But they do work properly: I am always able to use them with the phone app. It’s the communication with Roon that is the problem). Anyway, I’ll try.

Now I know it’s not the firewall: after Roon disconnected from the speakers with the “lost control” warning, I turned off both the private network’s and the domain network’s firewall and it didn’t make a difference, even after restarting the laptop and the speakers.

If you had a stronger idea about what’s wrong and how to fix it, it would be wonderful.

Hello again @beka, will I get any more support for my “lost control” issue? It happens about once a week, last time last night, and it would be nice to have somebody look into it.
Thanks,
Bernard

Hello @Bernard_Rene,

I am grateful that you’ve brought this thread to the forefront. Please, allow me to check with our technical team and get back to you :nerd_face:

Hello @Bernard_Rene,

I’ve just heard back from our technical team. They would love to rule out the WiFi connection. Could you please connect your KEFs via Ethernet and see if the issue occurs?

Millions of thanks :pray:

Hi @beka, I finally tried to connect the speakers via ethernet but it doesn’t work: the access point doesn’t have ethernet ports and connecting the speakers to the laptop directly doesn’t work. (Connecting them with a USB cable works, but the sound quality is not good and the volume very low).
But before the Eero access point, I had a Netgear access point which was also sometimes disconnecting even when both laptop and speakers were connected via ethernet…

Hi Just to add, I use LS50W version 1. My LS50 is connected via LAN no WiFi, roon runs on a Rock Nuc on the same LAN. I use a PC on the same LAN as my controller.

I often have Roon has lost control of the device issues. I just live with it. I just close Roon restart the LS50W and start playing music again. I do this once or twice an evening. I am so used to it I treat it as a “cost of doing business”.

Ha!

(that’s all I had to say but the reply must be 10 characters minimum)

Hey @Bernard_Rene,

Thanks so much for trying out the steps we suggested, even if not exactly everything was possible. It is good to know that the connection was stable via USB.

This leads us back to the network connection. To help, I’ve looped in our technicians. You’ll hear back from them on this thread :nerd_face:

1 Like

Hi @Bernard_Rene,

Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

Hi @dylan thanks for your message. I’ll reply as soon as I can!

B.

Hi @dylan I got the “Roon lost control of the audio device” warning 2 or 3 times a few minutes ago: at 7:08 pm while Symphony No. 7 Allegretto was playing.

Thanks!
Bernard

I run a mesh network and often had the same issue with my Sonos speakers disconnecting. My mesh network has ethernet connectors, after plugging one of my Sonos speakers into ethernet, some 18 months ago, I have not had another disconnection (the sonos system creates its own wifi network when one of the speakers is hard wired into the network).

I understand that mesh networks create issues for these speaker systems because the different mesh units often use different wifi channels.
That is my understanding of why they state not to use mesh networks.

From my experience, I believe the mesh network is the most likely culprit to the issues you are experiencing.
Maybe not what you want to hear, but I hope this helps.

Hi @dylan I got the “Roon lost control of the audio device” warning 2 or 3 times a few minutes ago: at 7:08 pm while Symphony No. 7 Allegretto was playing.

Thanks,
Bernard

This topic was automatically closed after 4 days. New replies are no longer allowed.

I have the same problem. LS50 is connected to my synology router ethernet port directly and so is my Roon running under windows 10. LS50 randomly disconnects from Roon even in the middle of the song. It is now happening very frequently (within one hour of playing). I now see there are many KEP LS50 owners reporting a similar problem. Very frustrating.

1 Like

No solution here, but maybe I can help raise the importance.

Roon looses control of my LS50W daily. Sometimes on/off on the KEF solves it, but generally I have to unplug the KEF and cycle it that way.

Mine are connected via ethernet cable - so for me I’m pretty sure it is not a network issue.

2 Likes

Mine too. Daily now where it used to be maybe once a week. Very annoying. Unplugging the kefs or restarting the core (Synology ds218+) restores the connection. Until the next dropout.

2 Likes