Roon lost control of the audio device (KEF LS50W)

Follow up: probleem seems to arise when switching remotes. I.e when my wife has used the remote app on her iphone 6 without problems, when I use my iPhone 11 next, the “Roon lost control” message appears whenever I first try to play anything.

Same here.
KEF ls50 wireless v1 rev 2 (with wake on lan capabilities).
Roon is loosing control. My KEF are ethernet connected . Contrôler is iPad Pro 2021 or iPhone or Windows on an Ethernet pc.
Roon server is on a asustor nas, ethernet wired.
Switching KEF on/off sometimes helps. Sometimes I have to un plug kefs.

Reading previews posts, I assumed issue could occur when Roon app tries to connect or reconnect to the core and then core connecting to kef (not sure if it’s working that way) . I don’t know if it makes sense but I tried to give a fixed IP to my Kef and so far, I had no error message anymore. I can’t explain why and I will continue to make tests as it’s been 10 hours since I started testing it.
It’s difficult to understand what might have changed considering the fact that despite dhcp, kef seemed to always have the same IP, but so far, it looks like it solved the issue. I’ll keep,you posted and please let us know if it helps with your specific network conf.

1 Like

I’ve seen a lot of improvement in the control of my LS50W and LSX with the latest release (1.8). I hope is continues to work well.

I get loss of control message but it seems to happen less often than before fixed ip

still having this every day for almost two years.
I just can’t understand how Roon doesn’t fix this.

Keep in mind the LS50W is only Roon Tested, not Roon Ready.

did anyone find an easier solution than switching the speakers off and on?

I eventually found the cause for the issue “Roon lost control of the audio device”, and a quick fix.

Every time I leave the Roon application open on my desktop and laptop at the same time, the error will appear very quickly as soon as I try to skip a track or play something else.
The solution is not to leave the Roon app open if I’m switching between computers.

Now, when the error happens I can either unplug the speakers from the power source, but that will take some time for them to connect again, or a faster solution which is playing something from Roon as AirPlay (KEF AirPlay source). As soon as the speakers starts playing with AirPlay, Roon gets control again on the device and you can go back to the KEF streaming source.

1 Like

KEF advised me to connect the Roon/Kef network to the router instead of any access point or mesh. I did and I haven’t gotten the “Roon lost control…” message since, though sometimes the music hangs there for a few seconds before starting again. So, this is big progress for me.

I used to have this issue when I had router miles away. Then I went hard wired to router and it hasn’t been a problem since.

Follow up 2:

The last few days again random dropouts. Without switching remotes. After one dropout (roon lost control…) i decided to leave the system as it was. Didn’t touch anything didn’t play anything. The next morning it worked again. Until the next dropout. I am completely baffled. Cannot find any pattern in this behaviour. Wired connection to the router by the way.

So I’m a long term kef ls50 wireless owner. I had pretty much never encountered the above problem in the 4 years I’d had the speakers.

That was until recently - I had to send my kefs back to get fixed after the board went in the slave speaker. Unfortunately the courier company managed to drop the package on the way damaging the speakers. After a lot of wrangling with them they eventually agreed to pay up on the insurance I’d paid extra for. Kef were great during this time and found me a replacement pair which were in great condition and actually newer than mine.

The new ls50s arrived on Wednesday and were perfect (basically looked brand new) and sounded great. Until they developed this issue

It’s happened multiple times and the only solution I have is to turn the speakers on and off.

What’s really weird is that everything else is identical - the rock, the network, even the cabling is the same as with the original pair. The only thing that’s changed is the units themselves.

Not sure if this data point helps but I hope we find a solution soon - it’s unworkable if it carries on like this

1 Like

Welcome to the club :slight_smile:

Hi guys…

I’ve tried to solve the “Roon Lost Control Of The Audio Device” (LS50W Series I) nuisance for a long time. The setup is by ethernet all around. Thinking that Windows was the culprit, I replaced it with ROCK on a NUC 5i3RYH. It still happens; however, whereas with the Windows Core I had to completely restart the computer to get it back, with ROCK I can simply press PLAY again to resume playback. Do you think it’s a KEF problem? Has anyone heard of the issue occurring with the LS50W II?

Hey @Michael_Brezinsky,

We’re sorry to hear that you’re still having this issue. We can definitely empathize with how frustrating it must be to have this problem while other KEF owners are running problem free.

Let’s try seeing if a RAATServer refresh helps. You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings. I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Please let us know if this helps. Hoping for the best! :crossed_fingers:t2:

I had this issue as well with my LS50W Series I which were ethernet connected, as is my NUC running ROCK. Occasionally it would seem to improve, but on average it would happen once or twice in a 2-3 hour listening session, always between (not during) tracks. I upgraded to the LS50W II a couple months ago and have not had the problem since. My guess (purely speculation) is that the electronics in the LS50W I are somewhat less capable for streaming purposes.

1 Like

I reinstalled the codec and haven’t had a problem since. Still, I’m sure the LS50W II and Roon are more congenial, as the second edition is “Roon Ready,” while the first is not.

Could “Roon lost control of the audio device (KEF LS50W” have something to do with the speakers’ standby mode set at 20mns instead of 60?
Since I switched back to 60, I have had a lot less if any, disconnect.
And 60 and 20 are different: With 60, Roon interface shows the speakers even when they’re off, and pressing Play turns the speakers on. Not so with 20mns.
Of course, with my luck, posting this is going to jinx my system again.