Roon lost control of the audio device - Ropieee on USBridge Sig to Ayre Codex

I’ve got an Allo USBridge Signature running RoPieee I just purchased that I can’t get to work with an Ayre Codex DAC. Any time I try to play something, from Tidal or my local library, I get a “Roon lost control of the audio device” message:


The Codex works when connected to my Windows PC via USB, and the USBridge Signature running RoPieee works with another DAC (DragonFly Cobalt) but not with the Codex.

Does RoPieee have a list of supported DACs?
Anyone else have a similar setup?

You can find supported DACs (from a DSD perspective) here:

Some past people have reported that a re-flash helped, but uncertain if this applies to your situation.

1 Like

Hi @CostasD

In general RoPieee supports all USB DACs, so there is no list of supported DAC’s.
The list on the website is about native DSD support.

That being said… it looks like ‘something’ is causing your DAC to disappear. Can you send me feedback with the DAC connected and playing? And send it after such event.

You can find this feature on the ‘advanced’ tab of RoPieee’s web interface.


1 Like

Thanks @spockfish
Feedback sent; 2d2f761db23584f1


Few things: you did not mention it’s an XL and not a regular RoPieee. Just to be sure I would suggest to disable (set to OFF) all the other services except Roon.

Furthermore I see a clear disconnect from the DAC on USB level. To be clear: you did not remove it manually? This is actually log after such a ‘device lost’ message appeared?

1 Like

Hi Harry,
I did not remove it, that is the log immediately following the “lost control” message.

I can confirm it is doing the same thing with regular Rooieee as that is what I originally installed but then upgraded to XL as a troubleshooting step. Same result.

Ok clear. Then this is really on device level.

I see basically 2 additional steps you can try:

  1. see if there’s an update for your DAC
  2. try this with a Pi4. On the Pi4 we’re using a different (newer) kernel, and it might be that this DAC does not ‘behave’ properly on the USB bus which leads to the disconnects.
1 Like

Thanks for your help Harry.

  1. I will followup with Ayre and see if there’s an update
  2. Not really an option as the USBridge Signature uses a RPi compute module and I don’t believe they’ve released a RPi 4 compute module.

Ow it’s on the Usbridge. Sorry, missed that.

It’s indeed a disconnected, followed immediately by a new connect. That’s enough for Roon to detect that the device is gone.

1 Like

The response I received from Ayre was a little disappointing. They confirmed my Codex is at the latest firmware and said:

You might try a powered USB hub like the one in the link below. The CODEX does not have internal buss power. It may not be getting enough juice…

I flashed another SD Card with DietPi to see if that made a difference; it played for about 10 seconds and then Roon lost control of the device. Not sure where to go from here.

Incidentally, the previous owner ran it from an SOtM-sMS-200 without issue.

Hmmm… I didn’t expect anything else tbh.

However, the remark about the bus power is an interesting one. This could indeed be the case, so that’s one you could investigate a bit more.

I just bought the USBridge Signature and am having the same problem with an Ayre Codex and QB-9. Any updates on this? I can successfully play 44Khz material, but any with higher resolution gives me the “lost control” error during the first song. Until that happens, it sounds spectacular! So, I’d really like to get this working.

I did try a powered USB hub, but that didn’t resolve the problem.

Not much more I can do here: I don’t have the device at hand and it is confirmed on 2 distro’s. I’m pretty sure this is device specific.

You could ask the vendor to figure this out: if they state they support UAC then it obviously should work.

I suspect the issue lies with the USBridge Signature. I have an open dialogue with Allo and I’ll post any updates here. It might not hurt for you to reach out to Allo and let them know you’re also having an issue with Ayre DACs.

The USBridge manual says that we need to update the ethernet drivers on any non-included OS. They don’t provide instructions for how to do that on Ropieee. Apparently, you’re supposed to copy two files and then recompile. But it doesn’t say how to recompile. Does that happen automatically on reboot?

I think I read that Volumio is also able to be configured as a Roon endpoint. Have you tried that? It’s my next step.

No, I haven’t and I don’t think Volumio can be configured as a Roon endpoint.

With RoPieee, it immediately loses control of the DAC and according to the RoPieee logs, the DAC is disconnected. I have also setup Roon Bridge on DietPi and I can get it to play for 10-25 seconds but then it also loses control of the DAC. I’ve sent logs to Allo and they’re looking into it.

I tested Ropieee with the USBridge on my Chord Mojo, and it works just fine. This suggests that we can rule out a software issue with Ropieee. I wonder if there is a USB config file somewhere we could tinker with.

I noticed that there is a “Clock Master Priority” setting in Roon device settings, under advanced. I’ll mess around with that a little to see if it does anything.

I’m currently running a test with Roon limiting my device to 48kHz and 24 bits, and it’s still playing. I really want this to work with 96kHz, but I could be happy if it downsampled everything so it would be stable. I’m using this in a new headphone system for my bedroom, not in my main system. Unfortunately, I’ve got 3 Ayre DACS: 2 QB-9s and one Codex, and they all have the same problem.

I wasn’t able to configure Moode to play my library–kept getting an ALSA error. I was hoping to see whether a completely different OS was able to control the DAC, but your test with DietPi seems to have that covered. I really think it’s a clock issue between the DAC and USB Bridge. I’d consider trying a USB regenerator, but I don’t really want to go to that expense on my bedroom system.

I recommend opening a support ticket with Allo and sharing your findings with them. I haven’t been able to get it to play any content, not 16 / 44.1, nevermind 24 bit.

I just posted this on the Allo USBridge forum, and I wanted to update it here as well:

Everything is working now! I am able to run at full resolution with dropouts. I have tested this up to 192/24 and it’s stable. I can only think that this was fixed as part of the 2.450 release of Ropieee. The release notes include these 2 items:

  • IMPROV: firmware update for Pi 4 USB Controller
  • IMPROV: bump Linux kernel for Pi 4

I get some occasional crackles and pops, like I’m listening to an LP; but that only seems to occur with Tidal streaming. The USBridge is connected to my network via WiFi (actually using a Wifi ethernet bridge and running a cable into the ethernet port on the streamer), so I’m willing to chalk that up to WiFi. But it’s strange that it only seems to happen on Tidal.

Still, considering where I was a few weeks ago, I’m very pleased!

I worked to isolate the issue with the clicks and pops, and found out that it only occurs when I use the Allo USBridge with my Ayre DACs. I brought the system downstairs and hooked it up using a wired ethernet connection and still got the same problem: so it’s not the Wifi. I connected my Ayre DAC to my Mac Mini as the streamer and the sounds disappeared. I connected the USBridge to my Mojo DAC and the sounds disappeared.

So, this still seems like a problem with the USBridge working well with the Ayre DACs. I no longer have the dropouts at higher resolutions, but the clicks and pops are too distracting to live with. So, I’m going to return the Allo USBridge and try something else. I’ve read good things about the SoTM SM-200 and SM-200 Ultra. Maybe that’s my next step.