Roon lost control of the audio device - Sonos

Core Machine (Operating system/System info/Roon build number)

PC Windows 10 Home 64 bit Roon Version 1.7 (build 667) stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Vigin Media Hub 4

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos in 7 rooms - Connect in 3, Connect Amp in 1, Play 5 in 1, Play 1 in 2. Connect in living room
connected to router by ethernet cable via switch box, sonos components connected together by Sonos mesh wi-fi

Description Of Issue

I downloaded roon and installed it yesterday. There was no problem in importing the music library. I enabled the Sonos devices and they appear in the correct zones. However, when I attempt to play anything I get the message `Roon lost control of the audio device’. This happens in every room and has happened every time - it has not played once.

I have one SonoS zone and over I have had that message a few times over the last few years. I resolved the issue by disconnecting the SonoS device from the network and restarting it. It is found again in a minute or two.

Not sure if this will work for you.

Thanks for the idea. I tried it but unfortunately it didn’t work. It was worth a try though.

Are you running Sonosnet or WiFi and ate they on different channels.
I have a virgin media hub and Sonos and I used to use a Boost but swapped it out for a Mesh (Orbi) and Sonos plugged in at the main switch and a couple of other strategic places.
It has been so much more reliable since I have made those changes.

Roon does want a solid network so if you are going to continue with it , it is worth spending time working in it.



Hi @Peter_Allen — Sorry for the trouble here!

First, can you confirm that you’re able to play okay to System Output of the Core machine? It’ll be good to just confirm that this is specific to the Sonos devices.

As a test, can you take one of the devices off the Sonos mesh and connect it to your router? Does that result in any change?


Thanks for your reply. I have a Sonos Connect connected by ethernet cable to the Virgin Hub 4 (via a switch box). The other Sonos components are on wi-fi, although I believe Sonos say they connect on their own mesh. I must confess I don’t really understand that. I’m not sure what I could do to make the connection more stable.

Thanks Dylan. The selected track lines up to play, there is a delay of a few seconds then the message ‘Roon has lost control of the audio device’. Is that playing to System Output? Sorry for my ignorance.

I’m tied up with work for the next couple of days but after that I will try your suggestion and let you know. Thanks for that.

Peter are you playing hi resolution music files or lower such as 320kb tidal.
Sonos mesh is pretty good, but relies on 2.4g networking for the most part. If you have a lot of channel congestion that can cause a lot of issues.
I found that mp3 files played great but struggled to play CD quality flac files.

It’s usually a sign of less than perfect networking and it can be tweaked. It’s one of the reasons most people on the forums recommend wired networking. I chose mesh with dedicated back haul which made m networking completely stable



Peter, I had a lot of trouble playing Roon on my Sonos devices before I switched them to use the standard wi-fi network rather than the Sonos dedicated mesh (SonosNet). That completely flies in the face of all the Sonos “received wisdom”, but it definitely made a huge improvement in my case. I wonder whether it would be a worthwile experiment for you?

If it would be helpful, let me know and I’ll dig out the links I followed to switch modes.

Ian yes that is what I trying and failing to say.
Mesh with dedicated backhaul makes a huge difference when playing high resolution music without stuttering or skipping



Thanks Ian. I would be grateful if you could find the links as I would like to give it a try. Thanks for the idea.

Roughly speaking, these are the steps I used:

To check whether your Sonos system is using SonosNet or wi-fi, use the menu item Help->About your Sonos system in the Sonos app and look for the wireless mode (WM) against each device. If WM is 0 it means the device is using SonosNet, whereas WM 1 means wi-fi.

In my case it was using SonosNet so I switched to standard wi-fi like so:

Go to Settings->System->Network->Wireless Setup and enter the WiFi SSID and passphrase. Turn off the wired Sonos device and the system should switch over within minute or two.

I hope this helps – good luck!

Thanks Ian, very useful to know. But my immediate problem seems to be resolved. I had an electrical problem and Sonos and the NAS (with my music library) both lost all power. After the problem was resolved and Sonos and the NAS were working again I tried Roon and it now works through Sonos without any problem (so far). But I may well try your suggestion anyway, so thanks very much for that.


Hi @Peter_Allen,

Thanks for letting us know that the Sonos gear is now working following the electrical issue being resolved! If you have any further difficulties with Roon, please just let us know and we can take another look!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.