Roon (MacBook) stops playing to USB DAC (Chord Hugo 2/Mojo) after 1-2 minutes in [Resolved - Update to OSX 10.13.1]

@support would love some tips on how to solve this…

Roon Server
• MacBook (Retina, Early 2016)
• Running OSX 10.12.6
• Music stored on internal SSD
• 1.3 (274)

• Chord Hugo 2 (connected directly to MacBook via USB-C hub)
• Chord Mojo (connected directly to MacBook via USB-C hub)
• Audioquest Diamond USB and a USB 2.0 certified generic cable from Amazon

• I’m using default settings as presented when connecting the USB DAC
• Playback to a Raspberry Pi running Roon Bridge over the network works rock solid but not to the hardwired DAC

I would try without the hub first – the rest of your setup looks like it should be solid.

If that doesn’t help, let us know.

This silly MacBook only has a single USB-C port :tired_face:

I use a USB-C to Power+Ethernet+USB dongle to add some ports. I can try another one.

Tried a new dongle/hub (Amazon Link) and running into the same issue. No dice.

For example, when I play an album the first track plays through for about 90s then it skips to the next track and gets stuck on 00:01s. Roon indicates playback is going on (animated bars) but the time tracker doesn’t move forward and no music is playing.

Hi @NBD ---- Thank you for touching base with us after trying with the new dongle/hub. The update and feedback are both appreciated!

I would like to enable diagnostics on your account so we can try to get a better sense as to why you are experiencing the mentioned playback issues, but first, can you verify for me if at any point during your troubleshooting of this issue you perhaps tried with one of the mentioned DACs mounted to another device acting a Roon remote? Say another laptop or desktop computer?


I’ll try with another laptop today and get back. I’ve mostly given up on USB. Coax out from a Allo Digione sounds pretty much the same as one from iPad + CCK + Intona.

Forgot the reply to this. I do have another Raspberry Pi + Also DigiOne endpoint. I don’t recall the coax out from that being connected to this. Will double check tonight.

  1. Disconnected to Coax input from Raspberry Pi running RoonBridge. Music still stops after about a minute when playing from USB.

  2. Ran Roon app on another laptop (MacBook Pro) and connected the DAC over USB and using this laptop as a RAAT endpoint (music is still stored on the other laptop). It works fine. Music plays as expected.

Next steps, going to upgrade the original laptop to the same OSX version as the working one and see what happens.

Hi @NBD ----- Thank you for touching base with me and sharing the observations that were made during the proposed test. Very appreciated!

I know from your most recent, you mentioned that you were going to bring the MacBook (currently hosting RoonServer) up to the same level as the MacBook Pro and verify if there are any changes in behavior with the mentioned DACs. Just wanted to touch base and see how that test went, let me know and we can continue from there.


Upgrading to 10.13.1 fixed the USB playback issue. It’s running “roon-solid” :muscle:

1 Like

Excellent! Glad to hear @NBD!

Happy listening!