Roon makes Yamaha Steinberg USB ASIO unavailable in other (audio) applications

Core Machine (Operating system/System info/Roon build number)

The Core is running on a Windows Home Server 2011 (Windows Server 2008 R2).
Roon Version 1.7 (build 511)stable(64bit)

Remote (for this question) is a Windows 10 (version 1909) PC (i9-9900K/16Gb memory/64bit)
Roon Version 1.7 (build 511)stable(64bit)

Other remotes: Linn Akurate DSM and two Sonos devices (working ok, not relevant for this question)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

The PC and the WHS are connected with UTP to a Netgear GS108Tv2 switch. Part of my music is on the WHS and part of my music is on a QNAP TS421 (also connected to the Netgear with UTP).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I have a Steinberg UR22 mkII external USB audio device connected to my Windows 10 PC. In Settings/Audio there are two entries related to this:

  1. Steinberg UR22mkII - WASAPI
  2. Yamaha Steinberg USB ASIO - ASIO

When using “1. Steinberg UR22mkII - WASAPI”, Roon doesn’t send hires (96/24) to the UR22, so I want to use “2. Yamaha Steinberg USB ASIO - ASIO” driver. But, as is reported by others, I get the “ROON LOST CONTROL OF THE AUDIO DEVICE” message when changing from CD to hires. Inconvenient but I could live with that.

The real problem is that the UR22 device disappears in other audio applications. For example after I get the “ROON LOST…” message the driver is gone in WaveLab (also from Steinberg). Only after quitting Roon and restarting WaveLab, the driver reappears in WaveLab. So now I am forced to use the lower quality System Output from the PC in Roon.

In other audio applications that I use: Foobar2000, Reason, WaveLab, Dorico, Cubase, Ozone, RX7 there is no problem with this driver. I can play/change all sample-rates from all of these applications and use all these applications “at the same time” going from one to the other without losing the ability to play. Roon is the only application that doesn’t work nicely with this driver.

So I don’t think it is the USB driver that causes the problems, but the way Roon works with the driver. Could adjust your interface with this driver so that it behaves as all other audio applications.

Regards
Ron

PS. Is there a specific reason why the buttons “Cancel” and “Save” in Edit Album are in different order on Roon desktop (left Save in blue, right Cancel in white) than on Roon iPad (left Cancel in blue, right Save in white). I always have to be careful not to cancel my changes on the iPad.

1 Like

Hi @Ron_Westdijk1,

If you use the ASIO driver, this has exclusive mode enabled by default, see https://kb.roonlabs.com/Exclusive_Mode. Exclusive mode doesn’t allow other apps to control the DAC while in use with Roon.

It sounds like the other applications aren’t using the ASIO driver because otherwise it would have Exclusive Mode enabled. Are the other apps using WASAPI by any chance?


I suggest that we take a look to see why WASAPI is not working correctly for you.

  • Are you presented with any error messages when trying to output 96/24 content?
  • Can you share a screenshot of your Device Setup tab for the WASAPI zone? It can be accessed by going to `Roon Settings → Audio → Cogwheel next to WASAPI zone → Device Setup and this is what Device Setup looks like for reference:

Thanks for the quick answer. Based on your answer about exclusive mode I experimented a bit further and it is clear now. The other applications also use ASIO exclusive mode. But the Steinberg application, e.g. WaveLab, Dorico have an option to release the driver “when in Background”. If I deselect that option in WaveLab, Wavelab is in exclusive mode and Roon cannot find the driver. So that is cleared up.
Do I understand it correctly that you “take control” (and for the USB devices in exclusive mode) of all audio device that are Enabled, regardless whether are selected/active? Probably so that I can Group them?

Now about Wasapi, this is the Device Setup:


image

This is the Signal Path during plaback

I don’t understand the sample rate (96 to 44.1) conversion, the UR22mkII can easily handle 96kHz

This is the Signal Path during USB ASIO playback :
image

It would be nice if the same (USB ASIO) Signal Path would be possible with WASAPI.

But now I understand the Exclusive Mode behavior, I will probably use the USB ASIO driver more. I just have to remember to completely quit Roon before using an other audio application.

For this it would be nice if you prevent/solve the “Roon lost control of the audio device” message and just switch from one samplerate to the other without a message. (That is something WaveLab can do easy :slightly_smiling_face:)

Regards
Ron

My understanding of this aspect is that Roon takes exclusive mode while there is content playing. Once playback has stopped for a certain amount of time (a few minutes), Roon releases the audio device, but I can double check with the hardware team.

It’s strange that you can’t set the maximum PCM rate here. I am looking over the UR22 Manual and it seems to indicate on Page 8 that you can manually switch the sample rate for this device via the Yamaha Steinberg USB Driver. Do you have this driver installed by any chance? What is the sample rate configured in the driver interface?

I wonder if a small re-sync delay will help with the sample rate switching, see our Resync Delay Docs.

Yes I have the Yamaha Steinberg USB Driver (ver. 1.10.4) installed, that is where all my previous questions/remarks are about. The sample rate in the driver interface changes depending on what is played e.g. the sample rate is controlled by the audio application that has the exclusive control. Actually in the driver interface I can see that Roon changes the sample rate, just before the display of the message “Roon lost control of the audio device”. So Roon looses control after changing the sample rate in the driver.

Setting a re-sync delay whether small or large doesn’t help.

Hi @Ron_Westdijk1,

Thanks for clarifying the behavior. I spoke to our hardware team regarding your case here, and we would like to gather some more information on the ASIO “Lost Control of Device” issue. Can I please ask that you:

  1. Reproduce this behavior and note the exact local time + date when it occurs
  2. Let me know the timestamps in this thread
  3. Send me a copy of your Roon Core logs by using these instructions via private message (click my username here -> message)?

Ok I played a 44.1/16 file today (Sunday 01/19) at 10:41 and the next 96/24 file at 10:42, after getting the “Roon lost control…” message.

Hi @Ron_Westdijk1,

Thanks for sending those log files and timestamp over, I have forwarded them to the technical team for analysis.

This is just to inform you that the issue with the Yamaha/Steinberg USB ASIO driver is still present in the 1.7 (build 521) release.

And now I want to inform you, that the issue (I use UR44C from Yamaha/Steinberg) is still present with the USB ASIO Driver in Roon 1.8)
Device lost control when selecting another title.
Am I right, that choosing the WASAPI Driver solves the issue? But sound quality is not as goo, right?

Correct. I noticed it also in 1.8. Currently I just hit play again after the message and Roon continues.

1 Like

Hello @Ron_Westdijk1 ,

Has there by any chance been a change in behavior here with our latest release? Can you please provide a clear set of reproduction steps? Is it any 44.1 → 96/24 file that will cause this issue?

The behavior is exectly the same as before:

  1. I play a FLAC 44.1kHz 16bit, no problem
  2. If I then want to play a FLAC 96kHz 24bit, I get the message “Roon lost control of the Audio device”. After that disappears ea second click on play starts the track.
  3. The same message appears if I go back to the track of 1. With the same working: hitting play again starts the track.

The message only appears with a change of sampling rate (44.1 to 48 etc.), not with a change in bit depth (16 to 24).

Also if I am in the Queue, choose “Play from here” and the message appears, the Queue disappears, as if I click on the back-arrow,

I am now using: Windows 10 PC with “Roon version 1.8 (build 764) stable (64bit)” and “Roon Optimized Core Kit with Roon version 1.8 (build 764)”. The audio device is Steinberg UR22mkII with Yamaha/Steinberg USB Driver v2.0.4. This whole setup is comparable with the setup before, but with updated software versions.

1 Like

Still the same for version 1.8 (build 778).

Perhaps addidionally: the message also appears when switching to or from a DSD64 track to 44.1/16.

Hello @Ron_Westdijk1 ,

Thank you for the additional information, I have passed this on to the technical team. We are looking into this and if we require more information, we’ll let you know, thanks!

Still the same for version 1.8 (build 783).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.