Roon Maxing out CPU and hanging

Core Machine (Operating system/System info/Roon build number)

Mac mini late 2012 used as a server
2.5Ghz Core i5
El Capitan

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubuqti networking mostly, some Netgear switches in rooms.
Server and player player wired ethernet, server on a Netgear switch, hangs of a Ubiquiti switch in the middle, the player I’m testing with just now hangs off another Netgear switch. All this has worked with no problems for quite some time.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Testing with Raspberry Pi, analogue audio hat
Have a variety of other playback devices, mostly Pi based.

Description Of Issue

Roon has been previously rock solid on all the parts described, no changes on the network.
Recently I had been noticing that Roon CPU utilisation would creep up then playback would get flaky, a restart of Roon would fix it.
Today I’m seeing Roon run for around one track, then the CPU will slam to 100% and playback stops, players disappear from the zone list. If left alone it sometimes comes back but it doesn’t remain stable.

I usually stream from Tidal, but playback of locally stored material shares this problem,

I’ve been playing material since I started writing this and its been ok, Roon CPU util on the server is around 15% but spikes up frequently and regularly gets to 75% or more.

Are there any debug tools I can turn on to see what’s going on?

I’m on Roon 1.7 build 667

Its still happening, streaming to a laptop, audio stopped, watching Roon suposedly at >200% of the cpu, is there something I can be checking for in Roon?

Hi @Andrew_Lucas,

When you say players disappear here, does this include the System Output zone on the Mac or just network-connected devices?

Is there any change in behavior if you try to toggle your WiFi adapter on the Mac (even if you are not using WiFi)?

Do you have any background activity going on in Roon?

Hi, thanks for replying.

I’m reasonably sure its only network players that drop off.
I moved the core to a MacBook overnight working onto the same switch as a network player and left that playing to that player overnight, this seemed more stable, but it looks like it stopped playback after 2 hours.
I did see that my SkyQ boxes had their wifi re-enabled somehow, these create their own mesh network and being connected to the same switches as the server and endpoint might have caused some network funnies, I’ve disabled those.
My initial plan was to move the server in case the switch is playing up, and then leave it playing both onto a local output and a network player and see what happens. I can try toggling the wifi settings then.

Are there any logs that would help?

On background activity, Dropbox is monitoring the Roon backup folder, backups are uploaded to the Cloud when changes occur. Nothing else other than the usual macOS stuff.

Hi, I moved the Mac mini server into my wiring closet where the central switch sits, this improved matters considerably (although it does still stop occasionally, is there a log that would show why?).

So I went round all the switches and eventually noticed that I have a cable that appears to be a source of errors, it all looks terminated ok, tried different patch cords, switch ports etc and it tests ok for continuity so now I have a puzzle on how to fix this as its behind a lot of plasterboard and replacing the cable would mean lifting floors probably…I’ll try a different switch brand and see if that changes anything. I have noticed its got worse now I have put the socket back together so perhaps one of the sockets is bad… or there’s lots of interference from something. Very annoying. Its one cable out of many, the rest look good.

That all said, I’m happily streaming video over that cable to multiple receivers without issue, is there any particular reason why Roon is so intolerant and it would be helpful if there was a dashboard somewhere describing the quality of the path to the players.

Hi @Andrew_Lucas,

Yes, Roon logs are accessible by using these instructions!

There is, and we call it “Signal Path”.

Is it CAT 5e cable or one of the older cable types rated for 100M only?

Have you by any chance tried to perform a reinstall of Roon to see if this would help?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Hi, just to update and close off this query, Roon has been perfectly stable since moving the server. Definitely a cable/switch issue, for some reason Netgear is more tolerant than the Unifi switch i’d moved to which exposed the issue. The cable in question is a recent Cat6 install.

Appreciate the replies.

1 Like

Hi @Andrew_Lucas,

Thanks for letting us know you were able to narrow down the issue to the cable and have been able to successfully resolve it! Hope you enjoy the music :headphones:!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.