Roon, microrendue Transporter i5 "Lost Connection" ills

I also run Roon using my Mac . Zero problems. Works flawlessly .

I have returned the I5 for a replacement . I’ll let you know how the new I5 fares

I notice with the Sonictransporter attached to my Ethernet switch that there is no light lit up on the front of the switch when it is idle or playing music . It’s the the only device that does this .
Tried other Ethernet cables , still doesn’t light up .
Anyone know why this would happen ? Switched ports too , it followed the port .

Is this with the replacement ST or the original.

The replacement , though I have to say I didn’t really check with the original .

Very odd. I’d get @agillis to help.

Do you have a Sonictransporter on a Ethernet switch ? Does it light up on the attached port ?

I have another switch coming in on Friday to see if it lights up . Maybe that’s why I have nothing but connection problems.

Yes. ST i5 connected to unmanaged switch. Port lights up when ST is powered on. Is your switch a managed switch? If so, could be a setting.

It’s a gigabit unmanaged switch .

That’s what I use.

Well I will let you know on Friday if the new switch resolves my connection issues .

Does the LAN port on the ST itself light up?

Yes it is lit amber .

I have the same setup, an ST i5 and an unmanaged D-Link switch. Both the ST and switch are lit. Since the switch is the only thing you haven’t changed I guess it’s likely the problem but that will be an odd one if that turns out to be the case.

Well I’ll find out on Friday .

Well, I hope it’s some odd problem with the STi5. I’ve never spent so much time testing a device.

Damn thing. It would occasionally play for an evening then couldn’t finish a song. I’ve never hated an audio component more because so of a possible users network issue. But Roon is rock solid on my desktop and my laptop so…

Yeah i have no problems with using my mac as a core .None. it flawlessly connects every time and it goes through the same ethernet switch as the sonictransporter.

@Michael_De_Salvo I would be happy to help you. Go to and press the contact us button for support. I can help your directly via phone or email.

It not the switch . Just tried another . No sucess .

So I have done the following :

  1. tried a different router - same connection issues
  2. attached the ST direct to google wifi router and turned everything else off - same connection issues
  3. tried different Ethernet unmanaged switch - same connection issues
    4 ) tried different Ethernet ports and cables - same connection issues .
    5)placed google wifi 3 pack in different places - same connection issues
  4. tried android tablet in place of iPhone , iPad - same connection issues .
  5. reset everything - same connection issues

I can use my mac as a core and never have a problem connecting .
This is very very frustrating .
I never had an issue until the last few Roon software updates with the ST.
By the way , all other devices work fine on my network . All of them

This is interesting: I just recently could not connect so I used a memory cleaner app on my iPad ,go back to Roon and I connect immediately .

Anytime I have a problem connecting going to clean memory allows me to connect .

So what on earth does this mean ? App is called Battery Saver.

Does this mean that the Roon app is a memory hog? These are newer iPhone ,iPads . 6 plus S iPhone

This effect is reproducible every time when I cannot connect . I go to battery saver , clean memory and the Roon app will connect .

Hopefully someone from Roon or Small Green Computer can respond to this issue .