Roon missing music files on Salk Streamplay III

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Nighthawk X10

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Salk Streamplayer III

Description Of Issue

I loaded a master recording of a 2019 concert on my music server to a folder 2019/CTO/Concert 1. The folder contains multiple mp3 files, lets call them song 1, song 2 … song 9.

In Roon, when I search for 2019, it shows Concert 1, but only shows song 1, 2, 8 and 9. How do I add the other files and play the whole concert?


Hello @Scott_Minick and welcome to the forum.

Have you checked if the missing files show up in Skipped Files?

Hi @Scott_Minick,

First, I’d like to point out some documentation we have that may be helpful here. In our KB we have an article about Skipped Files and an article about why some files might be missing from Roon .

If you go to Settings > Library > Skipped Files do you see any of your missing files there?

I’d like to recommend looking at a couple of specific examples of tracks that did not get imported into Roon. Are they supported files? Are they showing up in Skipped Files? If it looks like they should be importing, let me know! Screenshots of these files in their storage location would be helpful for discovering what may be happening.

Thanks, sure enough the missing files show up in Skipped Files with the notation that the “File is Corrupt”. However, the same mp3 file from the same disk drive plays fine on other media players such as iTunes or Groove. The files are in the same location as the other mp3 files that are imported and play with no issues. Here is one example (from exported Excel file)

corrupt_file 8275916 8/11/2019 5:45:16 AM 8/11/2019 5:45:16 AM /music CTO 2019 Concert 1/01. ABCDEFG 072619.mp3

Thanks for the help. I’m clearly a Roon newbie.

Hi @Scott_Minick,

Would you mind sharing one of these files with us so we can take a look? You can send it in a Private Message to me using a shared Dropbox link (or any other file sharing service).


yes, but I don’t see a PM link anywhere, please let me know how to send via PM to you. Sorry for being such a total noob.


Hi @Scott_Minick — I just sent you a PM. You can respond to that with the link.

Hi @Scott_Minick,

The file worked okay for me — Is this device (Salk Streamplayer) your storage device? What are you using as your Core machine?

The Salk Streamplay III is both my storage device and my Roon core machine. It comes preloaded with Roon core. I use it to store my own media as well as to stream Tidal and it has worked well for both. You can see more about it here:

Also, Jim Salk has been very responsive in answering questions and you can reach him at (248) 342-7109.

I’d appreciate any ideas for how to get these recordings working.



Hi Dylan. Curious to hear whether you’ve figured out what the issue with Roon playing this file might be.

Hope you have a great Thanksgiving.


Hi @Scott_Minick,

Apologies for the delay here. I checked with the technical team and we’ve done some additional testing and in all cases this media was importing okay.

Can you try doing the following:

  1. Make a backup of your Roon library
  2. Make a copy of this album outside of your Roon watched folder
  3. Delete the file on the Salk
  4. Share a screenshot of Settings > Library > Clean Up Library in Roon

Once you’ve shared the screenshot we can discuss next steps — Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.