Roon Newbie - Disabling DSP Engine?

Roon Core Machine

Intel NUC 8i5BEK, i5 8259U (4x2.3GHz), 16GB DDR4

Networking Gear & Setup Details

BT Whole Home dual band mesh wi-fi with 4 discs
Roon Core machine connected by 5GHz wi-fi
Music stored on Synology DS213J, ethernet connected to wi-fi disc
File transfer speed between Roon core machine and Synology typically 20MB/sec
Broadband: 1GB duplex FTTP

Connected Audio Devices

6 x Bluesound Pulse Flex 2i
1 x Bluesound Node 2i
1 pair KEF LSX Speakers

Number of Tracks in Library

75,000 tracks

Description of Issue

I’m one week into a 3 month trial period and have some performance issues - a message saying that a track is taking a long time to load. Sometimes this leads to playback stopping. If I leave music playing for a few hours, it normally stops at some point. So I’m trying to use process of elimination to find the bottleneck and fix the problem.

I figure DSP is likely to take quite a lot of horse power so I’d like to completely switch off the DSP Engine as part of my testing. It seems that whatever I do I still get a bright blue star in my signal path - specifically, crossover and eq. This applies whether I play lossy MP3s or lossless FLACs.

Is this just part of the Bluesound devices, or is Roon adding its own processing? And can it be switched off?

I also don’t get the Processing speed indicator which would help to inform me whether DSP is part of my performance problem or not.

Any ideas?

That is nothing to do with Roons DSP if you look at the signal path it’s in your Amplifier not in Roon. When a system is Roon Ready they are obliged to show what it’s doing. You must have some settings on your amp that Roon is being told are active.

The. Processing speed is an indicator of the real-time processing Roon is getting to send your audio, it’s x real-time anything under 100 shows up anything below 1.5 your in a danger area of dropouts and pauses amongst other issues.

With no Roon DSP active which you do not have any active then all being good it should not show up at all.

If it does then It indicates that you have some latency in your configuration. if it’s showing that low it’s likely due to the fact your core and all zones are essentially on wireless. The error message your getting is a clear indicator you have a network issue.

It is strongly recommended by Roon and pretty much most users to have your Roon core hardwired and I don’t mean to a single wireless mesh disc it should be one of the discs that is connected by a wire to the router, same should be done for the nas.

Your adding several wireless hops between it all which adds tremendous amounts of latency. Fix this and you may well find this all goes away. Sorry but mesh systems are not good for Roon due to its high bandwidth usage unless your connected the core and its music sources to the main hardwired node.

1 Like

I have the whole home mesh, fine for distributing to the end nodes but you need the core plugged into either the router or into the mesh node that is hardwired into the router.
Roon is very picky about networking.

1 Like

Thanks, I didn’t mention that my house also has stone walls that are 3 feet thick, not Wi-Fi (or Roon) friendly.

I’ll move my Core so it connects to my router with Ethernet cable. If the problem persists, I’ll then move the NAS and also connect it to the router using Ethernet. If that still doesn’t fix it, maybe I can’t be a Roon user after all!

Hey @Chris_Starkey,

I wanted to follow up on this thread to see if you were still running into connectivity issues during your Roon trial?

Now that isn’t something I see or hear very often, you must have excellent insulation!

I’ll be on standby for your reply :+1:

Thanks for your interest, Benjamin. I’ve decided to buy a new more powerful NUC to run Roon exclusively. This has become a Christmas present so my Roon trial is on hold until 26 December. I’ll transfer my Roon setup to the new machine and re-start my trial.

So this problem can be closed now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.