Roon no longer sees Meridian 218

Core Machine (Operating system/System info/Roon build number)

Macpro OS Catalina. Roon 1.7 (Build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

New Movistar Smart Router (Telefonica, the fiber optic provider, deploying thousands of them among Spain and South América customers). Askey HGU RFT3505VW.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian Home Theatre connected by a Meridian 218 device to Macpro/Roon

The problem:

My original configuration was as follows:

Router + Powerline + Switch + connexions to 218, MD600 and 861.V6. Everything worked fine until
I changed the Router following Movistar instructions. Now I can’t see the 218 device but I can see it using Soolos browser (ControlMac no longer available).

Following indications from a community member, I connected the 218 directly to the router to bypass the powerline network and check if the powerline was the problem, but the problem remains.

Would the Router setup be preventing the 218 to be seen as a Roon available audio device?

Please help


I would like to get an answer from ROON support.

Customer since 2015



Hi Jagoras,

This is a duplicate support ticket since you already opened a thread here: 218 Controller dissappeared in Roon

However, I am going to close that thread so support can focus on this one. As your environment information provided here is much more precise.

I too am a customer since May 2015.

A couple of quick questions to help support. Just to clarify, in your original configuration, all the equipment (218, MD600 and 861.V6.) were connected to the switch and then the switch was connected to the router via powerline, correct?

How is the Roon Core connected to the network?

Did you re boot the power line adapters?

Hi Daniel,

The connection is as follow: Router with two ethernet connections: (1) Macpro with Roon Core and (2) Powerline.

The powerline ends in the living room end then: cat5 …passive switch… Md600 and M218, the two of them connected to 861 via smart link, etc, as usual.


1 Like

Yes Chris, I rebooted the powerlines a couple of times.


1 Like

It may help, I have one cat 5 cable from my router to a basic switch, then everything else connects to that switch.

1 Like

Ok Chris, I will try this alternative wiring but first I must to buy one.


1 Like

They are not expensive so it’s worth a go.

I agree.

I will tell you if that works

1 Like

Hi Chris,

It worked!!

You were right. I solved the problem putting behind the new switch not only the Powerline, but also the MacPro running the Roon App. and the Core.

Thank you very much



Great news, well done…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.