Roon No Longer sees NTFS USB Drive on Mac, but other apps can [Solved - Install Tuxera NTFS for Mac driver]

Roon Build 884
MacBook Pro, OSX Monterey v12.1
External NTFS USB Harddrive

For months I’ve been happy as a clam listing to music on an external NTFS USB hard drive from Roon on a MacBook Pro. After restarting the MacBook, Roon no longer sees the USB disk and I’m unable to re-add the disk. It just does not appear to Roon any longer.

Yes, I can access the music on this same USB drive through Finder and play music from it with iTunes.

Appreciate any ideas!

Roon no longer sees “NTFS Master Music Lib” and Cannot be manually reattached.

Trying an ExFAT formatted USB thumb drive does work. Wondering why the NTFS USB Disk that has works for weeks is now unrecognized by Roon yet seen by all other Mac software tested on the same computer can access this disk?

see the security settings to see if roon has access to full disk and or files and folders under privacy

Grab 2022-01-12 at  13.27.22

I did not see Roon Server but I did see Roon enabled under Full Disk Access.

Funny thing, I can add a USB thumb drive and Roon see it. I dismounted and re-attached the USB hard drive and and no-joy.

Roon is working great for music on the main hard drive.

I run server too so thats is why its there…might want to check the files and folders settings too

Enabling “Full Access” shows also as full access under files and folders. Enabling under Files & folders indicates that access under Full Disk Access. One or the other can be set and that value is reflected in the other. I enabled it both ways and still no-joy.

Really appreciate the ideas!

I swapped out the MacBook for another one and that one works. I need to figure out why the first Mac went south when it’s been running Roon fine for several months. The Mac is dedicated for Roon, and no other SW was installed in the intervening time until after it didn’t work and I updated the OS.

reinstall roon maybe…backup your database first tho just in case

I removed and reinstalled Roon and Roon still cannot see the USB hard drive. Did confirm proper permissions for Roon.

What mystery. Every other app tested on the same MacBook can see and access this USB disk, except for Roon.

Hey @David_Welch,

It seems that this is a known issue that is being addressed by our team. Updates will be posted here:

In the meantime, what seemed to work for our team was installing Tuxera NTFS for Mac. It might be worth giving that a try if you can :nerd_face:


Thanks @beka I took the plunge and got the Tuxera driver and all is good. Roon immediately found the old library.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.