Roon no longer sees RoPieee zone

I added a Raspberry Pi/HiFiBerry/RoPieee zone in our living room last June. It has been trouble free until today. Don’t know if this is related to the latest Microsoft update or what.
All my other zones (Mytek Brooklyn connected to the Roon core), two PC’s, and my iPhone all still show up in Roon as active zones.

When I select the RoPieee tab from my favorites list on any of my PC’s it says “Can’t reach this page”.
The iPhone app for my eero mesh router network reports ropieee as recently used on network but shows no IP address available.

I tried unplugging re-plugging the power to the pi, but no luck.

Its been so long since I set it up and its been so stable, I have pretty much forgotten what I did to get it working in the first place. (It sucks to be old.)

What should I try next?

Not cool to reply to one’s own post but here goes.
I downloaded Nathan’s Beginners Guide and decided to re-flash the SD card.

First issue: when I attempt to download the RoPieee image I get pages of gibberish rather than an image.
So, I flashed the old image from last June to a new 16GB micro SD card via Etcher.

Etcher said the download was successful.

Now with the SD card installed in the Raspberry Pi 3 and a known working Ethernet attached I am attempting to reload the image.

After more than 20 minutes I’m still getting rapid flashing.

Do i perhaps have a hardware problem? The Pi has been on constantly for 10 months. Is it worn out?

Any guidance is appreciated.

Try a different SD card…plug a HDMI screen into the RPi and see whats going on when its booting

For now I would rule out the Pi itself as it’s been running for quite some months.
It could be the SD card though…

But first: why weren’t you able to download the latest image? What browser do you use?


Thanks for the reply.

The original micro SD was a 32 the one I flashed last night with the old image was a new formatted 16.

My browser is MS Edge. Will try Firefox or Chrome to try to get the current image.

Will attempt later today and report back.


Harry, it’s a known problem that you can’t download the image from your site using Edge - all you get is:

Yeah, I constantly forget that there are people that use Edge :wink:

So I’ll need to add a line with text explaining that. Is there a way to get it properly downloaded on Edge? Right mouse or something?

I’m afraid the “save target as…” right click trick doesn’t work either - something is telling Edge that the file is an HTML file, so if you save it, you still just get an HTML file of gibberish…

Good old Microsoft. Maybe try it as a zip file instead of img?

I’m not sure that it’s Microsoft’s fault. There’s something about the configuration of Harry’s site that is making Edge think that the file is an HTML file instead of an image file. I know that other browsers work, but there’s something odd here - a real edge case…

I was able to download the latest Ropieee image using the Google browser. I formatted my 16GB micro SD card then successfully flashed the image to the micro SD using Etcher.

I installed the micro SD into the Raspberry Pi and turned it on. (Turning it on means plugging in the micro USB plug from the wall wart, right?)

I re-verified the Raspberry Pi was connected to a working Ethernet cable.

The green light LED to the Ethernet plug soon began flashing rapidly and continued rapidly flashing for more than twenty minutes. After a half hour no change. I’m not getting to the 1Hz blink rate.

Entering http://ropieee.local finds nothing, nor does my eero network see ropieee.

Finally, I attached a small flat panel display via HDMI.
When I first connect the Pi to power I see a string of “OK” text lines then the screen goes blank.
I repeated this step several times.

One final attempt will be to format my 32GB micro SD card, (the one that has worked perfectly for 10 months) copy the latest RoPieee image to that and make one more attempt.
Failing that I will just buy a new Raspberry Pi3 for 35 bucks and start over.
I don’t think the issue is related to the HiFiBerry DAC+ do you guys?
Thanks for the help!

Try a new SD card first. I doubt it is the RPi. A 8gb card will suffice and they are cheap as chips. To find out the ip address to browse to you could use something like this

Back in Business! I reformatted and copied the image to the 16GB micro SD. My IP address changed. When I found that, I was able to configure.
Thanks a bunch all!!

1 Like