Roon no longer works with my dCS Rossini Player


A friend wanted to try his Moon 380D Streamer in my system using Roon. So I removed my dCS Rossini Player from the system and installed his Moon 380D. Roon recognized the player and we enabled it. Everything worked great. However, now that his 380D has been removed from my system, and the dCS Rossini Player has been reinstalled, Roon does not recognize the Rossini when using the select audio zone button. Roon seems to think the Moon 380D is still installed. I am no longer able to use Roon with my dCS Rossini Player. Any suggestions?


Stan Robinson

Hi Stan,

Can you post a screenshot of your Settings > Audio tab? Can you see the Rossini or Moon?

Try and restart your Roon Core.

Cheers, Greg

Hey Stan,

Was Ken’s MOON connected via USB or Ethernet?

Power cycle the NUC and that should reset things, but if not then there’s a larger issue. Can you see the Rossini from the dCS app? If you go to the front panel menu on the Rossini and select Info > Unit Status do you have an IP address assigned (you may have to cycle through a couple of pages of info).


Thanks for your fast response.

How do I restart my Roon Core? I am using a Roon Rock. Should I just unplug it and plug it back in, or is there a way to restart it using software?




I am listening to the Rossini using the dCS app now. Works fine. Ken’s Moon was connected via Ethernet.



Hi Stan,

In your first screenshot the Rossini seems to be unnamed. Type in a name. Then select it by clicking the button at the bottom of the screen, as seen in the second screenshot.

Cheers, Greg

I have tried multiple times to type in a name. The name is not accepted.

Should I just unplug the Roon Rock to restart it, or is there a way to restart it using software?

You can use the web interface by typing the IP address into a web browser.

Then click on the red power button at the top right of the screen.

You can find the IP address in the Settings > General tab in Roon.

Cheers, Greg

Andrew and Greg,

Thanks for your help. I unplugged the power supply from the Roon Rock, waited 30 seconds, then plugged it back in. Everything works fine now.



1 Like

Hi Stan, meant to ping you this morning, but we had a little excitement here involving a swarm of bees. Good times.

The ROCK NUC has an embedded web page for simple management tasks. The easiest way to find it is to go into Roon’s settings menu and select Setup:

The first item in the list is “Configure Roon OS Devices.” Click on Configure which will bring up a window showing the RoonOS / ROCK devices on your network:


Click on the IP address of your Roon Core (should show up as Roon Optimized Core Kit) and that will open a web browser page that looks like this:

You can restart your core by clicking the “Restart” button under the “Roon Server Software” entry. You can reboot it completely by clicking the red power button in the upper right.

Now having said that the easiest way to restart everything is to power off the NUC and power it back on. Pulling the plug works, but isn’t recommended as that can cause some problems.

The power button is on the front panel of the NUC:


Press and release the button and the NUC should shut down cleanly in a few seconds. Press it again to turn it back on. If there’s no response from the button then press and hold it until the NUC powers off.


Thanks for your help. I now know how to safely reboot the ROCK.

After using ROON for a few months, I am now convinced that it’s worth the cost.

By the way, I was at a ROON demonstration at LMC recently. It was a good talk. The DSP up-sampling function seemed to help the sound a little in the store environment, using a Linn streamer. I don’t hear any real difference using DSP up-sampling playing CD quality music at home using the Rossini. So I leave DSP disabled. I am just expressing my opinion.

Thanks again,


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.