Roon - No Sound when app is open

Hi All,

I installed the roon 14 day trial a couple days ago and everything was working nicely. Then today i tried playing a track and i get no sound. I opened up Spotify and sound was playing through that…until I opened Roon. Closing the Roon application brings all the sound back. What gives?

My Setup:
Windows 7 64 Bit
PC --> Optical output --> DAC --> Preamp --> Powered Monitors

There is some sort of buggy behavior happening with Roon that is fudging up the sound in my PC.

Thanks in advance.

Shahram

If I’ve understood the issue correctly, I’m wondering if you are using exclusive mode ( https://kb.roonlabs.com/Exclusive_Mode )? In which case, I think this is by design.

I would be fine if other apps did not have sound if Roon was running. But I have no sound in Roon as well!

So I changed the volume mode in the audio setting to fixed volume and my issue is solved. When I have it set to WASAPI mixer i get no sound from my entire system.

Hello @Shahram_Baradaran,

I’m glad to hear you were able to get things working. Due to the way digital audio works, using volume control on the digital output of your PC may cause issues like the one you are seeing. It is always best, when using digital output, to allow a device further down the chain to perform the volume control.

-John

Hi John,

Yes I have my Schiit headphone amp/preamp handling volume control and that works just fine. Can you explain the difference between fixed volume and DSP?

Thanks,
Shahram

Apologies, I didn’t read your initial post thoroughly enough - glad you have it sorted now.

Hello @Shahram_Baradaran,

Fixed volume will send the audio stream of Roon to the digital out of your computer with bit-perfect accuracy (as long as you don’t have any other DSP Engine options configured). DSP Volume works by modifying the audio stream to add more “silence” to the track than what was originally there. This can sometimes cause issues with devices further downstream.

-John

Ah that makes sense. Fixed volume is the way to go it seems. Thanks for the info.