Roon not able to log in into Tidal [Resolved - Cleared cache]

Roon Core Machine

Synology DS916+, NTEL Pentium N3710, 8 GB RAM, DSM 6.2.4
Latest Core build 1.8. 814

Networking Gear & Setup Details


Connected Audio Devices

Not relevant for the problem, various endpoints Ropieee, Auralic Aries, SONOS all work w/o problem with Qobuz

Library Size


Description of Issue

Roon is not able to log in into my Tidal Account. I am not able to pass the authorization step with Tidal. I have changed my login id with Tidal, are able to access Tidal thru the Tidal native app, but Roon fails to authorize, as after I perform the authorization in the Tidal web service, upon returning to Tidal, I remain stuck at the same initial screen requesting to login. Also the Tidal specific albums completely disappeared from my Roon library (several hundreds of them).

Hi @Radovan_Cechvala

What browser are you using to sign in? Is there any change if you use a different browser?

Roon Client on macOS calls out to Safari. I am afraid I can not influence that. I have tried to authorize on Roon Remote on Android, where the call out was to Chrome, but the situation is exactly the same. The credentials are obviously not propagated on any of the platforms.

A post was split to a new topic: Can’t sign into Tidal in Roon app

It is actually getting worse now. I see only Qobuz and local library content in Roon and I can play it from there, but I can not more search in Qobuz anymore nor see my favorites in MyQobuz. Qobuz connection status says library was synced (just now). Any kind of search also results into an error. See the screenshots. And I can still not connect to Tidal at all… This is currently absolute of no use.

I have hidden the username in the last screenshot…

Can you use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? I’ll take a look at what’s happening there. Thanks!

I have created a Dropbox folder and copied the compressed logs in there. Here is the link: Dropbox - Radovan_Cechvala_Roon - Simplify your life

Hi @Radovan_Cechvala

Can you try doing the following?

  • Exit out of Roon/Roon Server
  • Navigate to your Roon Database Location - Database\Registry\Core
  • Locate your tidal_account file and delete it
  • Try to start Roon again

Also please try this:

  • Stop RoonServer on the Core
  • Find and open your Roon database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer and verify if the issue still occurs

Let me know if there is any change after doing so. Thanks!

Dear Dylan, I ahem navigated to the Registry/Core, but there is no tidal_account file - see attached

Moreover, the Cache folder is a pretty big one, the Core is running on NAS, so probably no way to move it to my desktop, so I should move it wherever to on the NAS?

Hi @Radovan_Cechvala,

That’s okay if no tidal_account file is showing, we can skip that one.

As for the cache, you can go ahead and delete the Cache folder in that case. We like to move it in case we can identify a particular file on our end that’s causing the issue, but it won’t hurt to just remove it.

Dear Dylan, thanks a lot, so I will remove the content of the Cache folder and restart Roon Core, is this correct?
Unfortunately I will be able to do so only on Monday and will report back whether that helped.

1 Like

Hi @Radovan_Cechvala, definitely give that a try! In the meantime, I’ve also passed some information over to our QA team so they can provide some additional feedback.

Dear Dylan, I have removed the Cache folder content and restarted the Core. Subsequently, I was able to connect to Tidal accordingly. Seems my library got synchronized as well. I am also able navigating the Tidal Favorites directly, although the only option is to see them in an alphabetical order, but this is the case for Qobuz as well I believe. So seems the issue got resolved, thanks

1 Like