Roon not connecting after MS EDGE update

I have been using Roon with Tidal in my system for a few years now without issue on the exact same hardware. A few days ago my HP all in one computer did an update which included a Microsoft EDGE update and now when I attempt to launch Roon from my desktop, or from my Android, it gets hung up and indefinitely attempts to connect but never does. I have a HP all-in-one computer as the core with Intel Core i7-6700 CPU 2.8GHz, 64-bit OS with Windows 10. It is connected via ethernet to my Nighthawk 7000 NETGEAR router which is connected to a broadband cable modem. My audio gear is a PSAudio DSD DAC connected via Ethernet. Any help would be appreciated as I’m really missing my Roon capability and it’s difficult to troubleshoot when the application will not even open. Thanks Much.

Check that the firewall is not causing issues. That isn’t uncommon after an update.

OK. Thanks Henry… What specifically should I check on the firewall? I’ve been using Kaspersky Internet Security for years and I don’t think it did any update…

I did try disabling the firewall in Kaspersky as well as completely disabling protection of Kaspersky overall, and neither had an impact.

I think Henry means check MS Firewall which may have also been turned on even though you are using Kaspersky.

Was this a Windows Update or some Update from HP? Is there a reason you mention Edge?

From what I can tell the MS firewall (Windows Security/Windows Defender) firewall is turned off because Kaspersky is in place. It was a “system update”, but I mentioned MS Edge only because this was the “noticeable” update that was obvious other than Roon not working after the update.

You can try turning Kaspersky off to test if that is the issue or not. You could roll back the update as well. I’ve had several Window 10 updates over the years be wonky. I roll them back, wait a month or two and then re-do them.

I did turn Kaspersky protection completely off and it did not improve the Roon functionality. I’ll check into how to roll back the update

That might be a last ditch effort, though, kind of a nuclear option. Let’s try some other things first.

Just to clarify. You are using the HP as the core. Are you running Roon or RoonServer?

I’m using the HP as the core. As far as I know I’m using Roon and not RoonServer.

You might try clearing the cache. In the file explorer go to
C:\Users\daniel\AppData\Local\Roon where in your case “daniel” would be your username. In that directory there will be a folder called Cache. Rename it to Cache_old. Then try and start Roon again. Roon should rebuilt a new Cache folder.

OK. I was able to rename the folder and tried to restart Roon, but it still gets hung up attempting to open and stays on the Roon equivalent of the “spinning donut” Roon icon.

Another culprit, is that sometimes Updates from Microsoft also change the system drivers. Try downloading the lastest video drivers from HP for your all in one.

By the way, I am just a friendly fellow user. Actual Roon Support should be by to engage.

Ok… Thanks Rugby. I did an “all updates” on the HP side this morning as well, so I think the video driver should be the latest and greatest. Thanks for the help!

No problem. What is the model number of the HP. Sometimes it is good to check if the actual video card manufacturer has newer drivers.

It is a Model 27-a010. There is also a product code # V8P05AA#ABA

One more bit of information… Since Roon was not working I tried to access/connect TIDAL to my PSAudio DAC with MControl app which has worked before, but now that will not let me connect to my TIDAL account through MControl and gives me an “Invalid Token” notice. But I can log into my TIDAL account just fine on my desktop “core” and on my phone direct to the TIDAL app…

Hello @EaglesMan, thanks for the details! Have you tried rebooting your core and network since this issue started? Also just so I can verify what’s going on so far. You’re unable to get into Roon on the core after an update, you’ve disabled your firewall and AV, and MControl won’t play TIDAL either?

Hello Nuwriy… Yes, I have rebotted the core computer and also the network. I have also disabled the firewall to no avail. Not sure what you are referring to with “AV?” Also, I can’t get TIDAL to load up in the MControl app on my phone and get the error code “Invalid Token” message. I have noticed that this TIDAL issue is chronic with other users having the same issue.