Roon not connecting: (Innous ZENith mk3) ”Remote connection, waiting for remote core=😡!

Roon Core Machine

Innuos ZENith mk3 controlled thru Apple iPad

Networking Gear & Setup Details

TP link Wi-Fi, all other devices are working fine. Have worked fine before and continue to work fine —EXCEPT Roon (no vpn)

Connected Audio Devices

Simple system that worked before I went on vacation. Fiber to house,TP-link modem /router, extender, Innuos ZENith mk3 streamer latest version OS v.2.3.2, (also sense app), Schiit Yggdrasil DAC

Number of Tracks in Library

Just getting started? Maybe twenty CD’s, but plenty of playlists on Tidal

Description of Issue

No music. Cannot access “settings” if it never connects. Don’t want to lose my playlists from a reload.

Have no way or knowledge on how to backup if necessary. Have spent hours online going in circles clueless about computer/software acronyms, etc. was sold on painless and simple — anything but.

I need a 10 minute phone call from a live person. Maybe my Roon version is out of date — how would I know when this is happening? Thought I was on automatic updates because I was prompted to update and reset which I did when things were working.

Hi @Douglas_Ebert,

Welcome to the Roon Community. Sorry to hear that you are experiencing problems. I’m just another community member and let’s see if I can help you a bit with your problem.

Two questions to begin with:

  1. Can you reach the Innous with the Innous app? To check if the Innous can be reached.
  2. You mention an extender, so that is Wifi. Do you use it to connect your Innous? Roon advises to try to use network cables (ethernet) because Wifi can be unstable and/or slow.
  3. Did you recently update the Roon core software on it?


You paid a lot for a music server that has Roon functionality. If it’s not working / possibly needs a Roon update and you don’t know how this works, it seems to me that Innuos should support you in this.

It is indeed possible that the Roon core software on the server is not up to date while your iPad updated from the Apple App Store. There are certain version combinations between Core and remotes that don’t work together.

Maybe another Innuos user can guide you through checking the Roon version and updating it, otherwise Innuos should help

1 Like

Dear Joost_Hoogland,
Thanks for the kind response. You seem empathetic. Per questions:

  1. Yes thanks. Been there done that.
  2. Yes, WiFi. To note: extender worked fine before. ALL (not shouting, only emphasis) status lights are lit up green and ready as ever. Only two devices on entire net—Innuos and an iPad. That’s it. No firewall, no network, no doorbell cameras, no smart TV’s, nothing extra. High speed fiber to house and cat7 Ethernet cord between extender and Innuos. Nothing has ever been slow when using iPad.
    3.”it”. Not sure what that refers back to. If you mean the Innuos, then yes it’s all buttoned up on the Sense app. and has the latest OS v.2.3.2 update.

How would one know what version of Roon is trying to run if I can’t get past the “circle of doom”, “grinding lock”, “hourglass from he//“?
Sincerely appreciative,

1 Like

Dear Suedkiez,
Thank you for the info and the empathy. I’ve reached out because despite having a couple degrees and many skill-sets, computer geek-speak is not one of them.

In spite of driving 9 hours and 648 miles (not counting stops) to give an official Innuos dealer my purchase—he has only gone so far as to give a list of steps for the Sense app. Now it appears that un-named dealer is not answering phone calls or emails for assistance.

I’ve also reached out to Innuos (email). We’ll see. Trying to remain positive and in “problem solving mode” in spite of having spent the equivalent of a small car on this now silent system. (problems started Dec. 26, 2022 just before I was departing on vacation)
When I was working, someone told me that a crowd forms to take credit for success and it’s a ghost town when it’s time to take blame.

My hope in all this is the former.

Best regards,

Not a good performance from the Innous dealer for the price :frowning: I hope the official Innous support is better.
But I know for sure that there are many knowledgeable Roon users on the forum and some probably have experience with the ZENith mk3, so hopefully someone will show up and help

Well, based on your answers I agree with @Suedkiez that your best option would be to have Innuos Support assist you with this. Or perhaps some other Zenith owners on the community.

@Douglas_Ebert, I added (Innous ZENith mk3) to the topic title in the hope of stirring up some takers :slight_smile:

To eliminate your TPLink/extender from being the culprit any way, move your Innuos directly next/close to your modem and physically plug it in. I dare say Innuos would probably recommend the same thing. If you’ve been away for some time there would be numerous updates to perform on your unit.


You are great. Thank you for that.


1 Like

Dear Mark H.,

Yes that was a concern when I put this front end into the system nearly two years ago. It was never an issue when all was working. (And a dongle that came with an Oppo player was fine as well.).

But, you are right to suggest it. I had that same thought earlier today and dismissed it after someone knowledgeable told me that Roon recognized the dac and the ZENith mk3 together. He told me to make sure the dac input was on USB when touching the Roon app on my iPad. That did not change the outcome. Now that I realize I don’t have to carry both up the stairs to try this,I will. Thanks for the reminder.
My suspicion is that this is a software “handshake” problem. But, the Innuos is fully updated and the iPad is fully updated. Here is the Catch22… if I have to connect to Roon to check on versions or updates, I can’t because it won’t connect. If I log into their site it only shows pretty pictures and offers billing options.

Dear JH,
Excuse me if I repeat myself in saying that I’m waiting for a response from Innuos support. Maybe they will do a remote diagnosis.

I will not refuse any reasonable suggestions in the mean time.

Seeing that you are a community member—I respectfully ask if Roon ever shows up with a direct answer. Tell me if the patients in the waiting room are comparing ailments and trying to diagnose each other. I worry that Innuos will point to Roon and Roon will point to Innuos. I get ahead of myself.
Best regards,

Good morning Douglas Ebert,

my apologies if this question was redundant, but you didn’t mention anything of the sort: have you ruled out your router/extender as the cause?

If you are not sure, please switch off all devices, unplug them for 5 minutes and switch them on again in this order:
ISP modem/router/extender/Innuos/audio devices/iPad.

(I wish it may be so easy and simple.)

Unfortunately, since Roon support is a small team of 4 people working through the queue to your case, you will need some patience.

Best, Axel

G’morning A_L,
This format for typing doesn’t allow me to see what I’ve written to whom. (hence the qualifier).
Next point—I’ve been dealing with Innuos problems for quite some time off and on. I’ve been more than patient and courteous with the aforementioned dealer who has now stonewalled me.
Next point—I will try your suggestion (and I appreciate it) after coffee, after I try the suggestion to extract my ZENith mk 3 from the rack and carry it up a flight of stairs to test connection next to the modem/router.

But, to note, I’ve done hard boots to iPad, ZENith mk3, router,extender before and gotten no results. All the while, there is perfect connectivity to Sense app/recognition of device, Wi-Fi is fast and stable for tasks on iPad.

Next point—since I’m new here I didn’t realize they had such a staffing shortage for all of North America. I have an informal sample space absorbed through many hours of reading other people’s problems in search of an answer. Their bigger problem may be chasing extra features (adding complexity) to the neglect of basics ie. 1-800- no., remote diagnostics, live chat, or even connectivity. The Innuos is literally/figuratively a black box—no displays of any sort, only an on/off switch. I was sold a pitch not to worry that all was plug and play that any problems could be monitored by these software entities in real time and immediately remedied. Not sure I would have bought in seeing the vast array of topics in this forum! As they say, buyer beware.

Just want to grab the bull by the horns and move on.


Hi Doug,

Perhaps something you have already tried and is very obvious, but is it possible to update the Roon core on the Innous through the Innous interface (app or web?) I don’t know the device but one would expect that this would be possible.
And I would still try to connect the Innous directly by cable to the router that also has your Wifi to which the iPad connects. Just to be sure that it is not a network problem.
These are my last ideas. If they don’t help then wait for Support to pick up. They normally do within a couple of days (after the weekend of course.)

Hi Mark,

How ya doing? Took your suggestion and will now try to down load a picture of the result.

![image|666x500](upload://rDwDJUkpIpsfHx0vti3K27dAD5A.jpeg) Hope this picture opens for you. The code on my side looks like gobelygook.

If it doesn’t, the result was negative. So, by deduction, that rules out the extender as the culprit. Next test is a hard wire connection and the reply comes later down the page in the discussion.

Best regards,

Add images

You need to upload or copy&paste the picture and then, after the code appears, press Enter and continue writing on a new line, not on the same line.

Hello J_H,

How are you? Thanks for the involvement. I took your advice to extract the ZENith mk3 from the downstairs rack, tote it up the stairs and hard wire it to the modem/router. Here is a photo of the results:

And here is a photo for M_H:

Guess that puts to rest any theory about weakness in the extender or the Ethernet. Next I’m trying the suggestion to reboot everything (but, I’ve done that before without success).

Re: You have a good idea about accessing Roon through Sense app. but two things give me trepidation. 1. Why the “H” doesn’t Roon give access directly? 2. With my novice eye to all things Geek acronyms—without a big ‘old red button “reset to default settings Y/N” I would surely dig myself into a deeper hole! No thanks, I’ll wait until someone familiar those menus walks me through it. Might attempt it with an online tutorial though. Anyone have a link?

May the wind be at your back,

And the “Select a different core” button on that screen does nothing or searches forever? I occasionally got that after an update or restoring a backup, although everything in the network was fine. Then clicking this button would bring up the usual Core anyway (the only one I have) and I could reconnect.

Maybe you tried that already, of course, just making sure

1 Like

I do actually get that frequently after an update on my Antipodes Core.
And yes, select a different Core brings up the Antipodes instantly with a green ready status and connect and away we go.
Great point, if the op has not tried it.

1 Like