Roon Not connecting to Nucleus+ & Apple iPhone7 app not connecting with Roon

I have approached the Roon community before about Roon software not being able to connect to my Roon Nucleus+ and my Apple iPhone 7 Roon app not being able to connect with Roon but have not yet found any solution to this problem. I have tried rebooting my modem/router, ethernet switches and the components on my home network. I have tried disabling my firewalls & have reinstalled Windows 10 and updates & also Roon software. Nothing is working so far for me to solve the problem.

This problem appeared “out of the blue” as all was working fine before & I don’t know what caused it. It is frustrating because I have had a computer consultant (albeit one not necessarily experienced in music systems) work on this problem on two separate occasions, to no avail. When I click on the Roon icon a circle keeps moving but it is unable to connect to the Nucleus+. The Nucleus+ is recognized as on my home network when I investigate through my modem router.

From the Roon community I see that this has been a problem which different community members have had. Some have been able to solve it in different ways but their solutions have not so far been able to fix the problem that I am having.

I have a home network system controlled by Windows 10 on a Dell XPS 8700 desk top computer. I have a Hitron modem router & two ethernet switches and on the network are a Vortexbox ripper server, a NAD M50…2 riper server and a Devialet Expert Pro 220 integrated amplifier.

Is there anyone who has any ideas on what is causing this problem and can help me?

Hello Greg, I’m trying to understand your setup. Specifically Roon software not being able to connect to your Roon Nucleus+. How is the software separate from the Nucleus?


What I mean is that if I try to use my Dell Desktop XPS8700 desktop computer or my Apple iPhone 7 to access Roon, it is not able to find what it calls the remote core. When I try to do so on my desktop computer it asks me to chose my core but when I choose the Nucleus+ a round circle keeps moving & eventually states that is searching for the core is taking longer than expected but it does not find the core.

I see everything you listed above has been rebooted. I didn’t see the Nucleus listed but I assume you cycled that as well. If you know the IP address of the Nucleus can you pull up the web UI from your browser?

1 Like

Yes I have rebooted the Nucleus+ several times & I can pull its IP address up on the web.

Ok, so Nucleus is available, per the WEB ui. Are the Nucleus+ and the PC both wired to the router or is the PC wireless? If both are wired then I’m stumped.

The Nucleus + and the PC are both wired to ethernet switches (non-managed).

I had a computer consultant (non-music system & non Roon experienced) look at this problem of not being able to use my PC to find the Roon core.

He believes that the issue is either my modem not passing communications to my Nucleus+ or the Nucleus+ itself. My modem/router is a Model #CGNM-2250. Is there anyone in the Roon community who has any experience or thoughts about all of this that can advise me as to what to try?

Hi @Greg_Johnson,

Is the behavior the same if you bypass the switches? I would try connecting the Nucleus an dDell directly to the Core as a test to eliminate the switches as being the issue. If the issue is still the same:

We have often seen ISP provided gear have poor performance, as noted in our Networking Best Practices Guide.

Do you have a standard router you can use instead of the combo unit and have the model/router combo act as just a modem? You can place it into what is called Bridge Mode to have it be just a modem, and I’d also make sure to turn off the WiFi on it or your might end up with two separate networks.

I plugged the Roon Nucleus+ (which is the core) directly into my Hitron Model # CGNM-2250 Modem/router thereby bypassing my ethernet switch & then rebooted my Dell XPS8700 desktop computer. I then clicked on the Roon icon but it still cannot access Roon even though the Roon Nucleus+ is recognized by my computer.

Regarding replacing my Hitron modem/router I do have an ASUS RT-AC66U dualband gigabit 802.11ac Wireless AC1750 router that I could use but since I am not that computer or network savy I will get some technical help to do that. Before I do that, does anyone have any experience & suggestions regarding a good router to use for music network systems like mine that use hard wired ethernet connections for the music hardware on the network & WiFi for the Roon app on my Apple i-phone 7 and for my wife’s notebook? I have in the past had music drop out instances & messages that there were Roon performance problems, when I was able to use Roon.

1 Like

Hi @Greg_Johnson,

Yes, I do agree that this solution would be better than the current one. Do keep in mind though, you should remember to enable multicast on the router:

Networking Best Practices Guide

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

I have an ASUS GT-AC5300 that works very well in my home. It is classified as a gaming router but I’m not a gamer, just wanted the best coverage i could get. It has 8 Ethernet ports, 3 wireless bands and provides good wireless coverage in the house and in my shop 40 feet away from the house.

I have been having a problem, for some time, of Roon not being able to connect with my Roon Nucleus+ server core, from either my desktop (Windows 10 operating system ) computer or my Apple i-phone 7. I have tried numerous fixes used by the Roon community but they have not fixed the problem.

On July 12, 2020 I had a computer consultant remotely take control of my computer and spend approximately 2 hours attempting to solve the problem but he was unable to do so.

On July 21, 2020 had another computer consultant also take remote control of my computer for about 3 hours and make numerous diagnostic checks. All drivers & software appear to be up-to date & he said we can rule out there being a problem with my Dell XPS 8700 desktop computer. Here is what he said: " I feel we can deduce that something is amiss with the Roon Nucleus+ at this point. Whether it can be fixed by something we can do remotely, I cannot say. You said there’s 100K plus songs…I saw that it’s taking up maybe 40-55GB on the device (the music files are actually stored on a Vortexbox server and on a NAD M50.2 server both of which are connected by ethernet to the Roon Nucleus+). Your next course of action may be to backup the music and reset the core". Can anyone give me advice o doing so?

I have also contracted for higher internet service provider speed. I have not tried a different router. We have bypassed the two ethernet switches by plugging the Nucleus+ directly into the Hitron modem/router and replaced the ethernet cable between the Roon Nucleus+ and the ethernet switch & tried numerous reboots of components, unplugging and re-plugging of the modem and un-installation & re-installation of the Roon software but the problem was not solved.

Is there anyway to elevate the attempted solving of this problem to a higher level or does anyone in the Roon community have other advice?

I’ve read your information in this post but don’t quite understand it. You mentioned having a home network system controlled by desktop and a Hitron modem/router. How does that all work together? @noris added a link to a networking guide. I see it suggests to try a simple setup bypassing complicated network configurations to see if that works.

You mentioned having a ASUS RT-AC66U router, do you also have a modem that is not a combined modem/router. I think I would try connecting the modem to the internet, the asus router to the modem, the nucleus+ Ethernet to Asus router then see if the iphone remote can connect to the Nucleus over the ASUS wifi. That is as simple as it gets. If that doesn’t work then it does seem to indicate an issue with the Nucleus+.

Sorry i don’t have a better answer to help you. I have the simple setup, modem, Asus GT-AC5300 router with Ethernet to NUC and endpoints. I have wireless and Ethernet connected remotes and seldom have any issues.

I finally got around to connecting my ASUS TR=AC66U Dual-band Gigabit router to the HItron Model #CGNM-2250 Modem router instead of using the Hitron router & got that combo working. I then by-passed my ethernet home network switches by directly attaching my Roon Nucleus+ to the ASUS router. I still have the same problem of my Dell XPS8700 desktop computer & my Apple i-phone 7 not being able to connect with my Roon Nucleus+ core. I would now like now pursue having the Nucleus+ core looked at to see it is causing the problem.

My home networked music system consists of:

  • a Home ethernet network with several switches.
  • a Nucleus+ core
  • over 100,000 songs stored on a Vortexbox ripper/server & a NAD M50.2 ripper/server streamer
  • a Devialet Expert Pro 220 integrated amplifier.
  • Dell XPS-8700 desktop computer using Windows 10 operating system.

I have a problem with Roon, either through my desktop computer or through my Apple i-phone 7 app, not being able to connect with my Nucleus+. I have tried numerous fixes suggested by the Roon community but none have worked. I have had several computer experts look at the situation and they are suggesting that there is something wrong with the Nucleus+. What steps should I now take to have my Nucleus+ server diagnosed?

As with most thing network related, if you remove the network aspects (or isolate it to the bare minimum) does the system work as intended? Is the network all on a single subnet? Do you utilize static or DHCP addresses? Just some things to help “self” diagnose.

The network & switches were bypassed and the Nucleus+ plugged directly into my router but still Roon is unable to connect with the Nucleus+ either through my desktop computer or my Apple I-phone 7.

I have a dynamic internet setup (DHCP) where IP’s are automatically assigned although the Nucleus+ acts as if it has a static IP address. I believe I have a single subnet.

Hi @Greg_Johnson,

Are you able to access the Nucleus Web Administration Interface?

Yes I am able to access it.