Roon not connecting with Qobuz

Roon Core Machine


Networking Gear & Setup Details

VirginMedia Hub

Connected Audio Devices


Number of Tracks in Library

65,000 tracks

Description of Issue

A few days ago Roon stopped playing music from my Qobuz account, error messages like “network error: please check your connection” would appear.
I tried looking at the forum, tried logging out of my account and now Roon won’t let me sign into my Qobuz account to have another try saying “network error please check your connection”
Tried using the Room app on my iPhone and same problem.
Tried playing music via the Qobuz iPhone app and Windows app, both play fine.
Network connection seems fine, no other problems.
Contacted Qobuz and they said “no problem at their end try contacting Roon”
So here we are.
Any ideas

You may already have tried this but if not:- Have you tried Stopping then Starting you Roon Server on the QNAP and or rebooting your NAS? Then try to login again.

I’ve had issues like these. What I did was to change the DNS servers for TCP/IP v4 on my Roon Windows 10 Pro x64 system to be and (Google). That helped.

[Updated second IP address to show valid Google DNS IP.]

The Gold star award goes to Scotav today. Thank you.
I stopped the NAS, I restarted the Router, I restarted the NAS and everything came back online.

I guess it’s a lesson for those of us who have read Humble Pi by Matt Parker about the pesky ways those 1’s and 0’s affect us and to remember to restart your devices once in a while to avoid these glitches!

Thanks again to the community, rock on.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.