Roon not correctly reporting M-DAC+ modes

Possibly a newbie question, but I can’t find an answer anywhere. I installed Roon v1.4 (64 bit) yesterday on an Intel NUC running Windows 10, connected to an Audiolab M-DAC Plus DAC via USB. Roon is converting everything to maximum 96kHz PCM, and when I look in the device setup in the Bit-Perfect format support it shows:

Green: 44.1kHz, 48kHz, 88.2kHz, 96kHz
Red: 176.4kHz, 192kHz, 352.8kHz, 384kHz, 705.6kHz, 768kHz, DSD64, DSD128, DSD256, DSD512

The M-DAC Plus actually supports PCM up to 32-bit/384kHz, DSD64, DSD128 and DSD256.

I’d be grateful for any suggestions.

Those rates are only available using USB, is that the connector you are using?

If so, have you loaded the windows driver. And then have you selected the driver as the audio output in Roon. Make sure, system output is disabled.

Thanks for your reply.

  1. I am using USB
  2. I am using the Windows driver and have selected it.
  3. System output is disabled.

Playing the same content directly from Tidal uses the correct bit rate (although I haven’t found any DSP content on there to test that).

Hello @Nick_Cassidy,

Please provide a brief but accurate description of your current setup using this link as a guide. It would also be helpful if you could include the screenshots of your current audio settings. Here is a short tutorial on how to take and save screenshots in Windows 10.


Roon v1.4 (64 bit)
Intel NUC i5, 8Gb RAM, Windows 10
Audiolab M-DAC Plus DAC, USB connection to PC
Local music QNAP NAS
Streaming Tidal

My audio settings are in the 5 attached files.


Thanks @Nick_Cassidy!

Could you download and install the AudioLabs ASIO driver and report back? I’m including a direct download link to the drivers from the Audiolab website, when you click on the link it should begin to download the ZIP file with the installer.


@john, that’s the driver I do have installed. I have seen an ASIO capability described for the M-DAC+ in other discussions, but it’s showing up as WASAPI in mine. I’ve been through all the settings in the Windows audio settings and the device manager, it doesn’t have any options for ASIO.


I would attempt to reinstall the driver if possible. If Windows isn’t recognizing the ASIO driver for the M-DAC+, Roon has no way of discovering the ASIO output either. You should know if your driver is installed correctly by looking at page 8 in Audiolab’s USB setup manual, here’s the link to it.


Well that’s baffling. I was definitely running that version previously, I checked in device manager, but having reinstalled it, there is now the driver control panel that wasn’t there before, and Roon is now seeing separately selectable WASAPI and ASIO options. It looks like it was only partially installed.

Not all the M-DAC+ modes are available, but Roon can now do PCM up to 96kHz and DSD64, which I think will have to do.

Thank you for your great support, it is very much appreciated.

1 Like