Roon not decoding MQA file for McIntosh C52

Core Machine (Operating system/System info/Roon build number)

MacBook Pro 15", Roon Version 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired internet through USB-C, Motorola modem supplied by Comcast

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Using USB connection (through USB-C on MBP) to McIntosh C52, wired internet through USB-C

Description Of Issue

I selected C52 in preferences, audio, device set-up, and Roon recognized my McIntosh C52. I have a “master” subscription to Tidal. Unfortunately, Roon is playing all the master files at 44.1kHz instead of MQA 48 or 96 or 192. The system plays my non-Tidal, high-res AIFF tracks at full resolution (e.g., up to 192kHz). And the tracks show up appropriately when played through Tidal, but I can’t get Roon to recognize and play the tracks at full MQA-decoded resolution. I’ve attached a screen shot of a master Tidal file in Roon, together with the signal path.

Would appreciate any help or guidance. Thank you.

Set the MQA setting for your DAC in roon to none, so Roon does the unfold.

What does your device setup for the C52 look like Graham? If you don’t know how to get there go to settings/audio and click on the gears icon next to the Zone for the C52. It’s likely that is not setup correctly for the C52.

Thanks for responding. In “Device Setup,” for MQA Capabilities, it is set to “No MQA Support,” which is selected when I chose McIntosh C52 as my device.

Can you take a screen shot of device setup and make sure advance settings is open?

Thanks. In the “Device Setup” menu, I first selected McIntosh, then selected C52, which Roon recognized.


I’ve attached a screen shot of my Device Setup menu.

scroll down in Device Setup, open up Advanced and take another screen shot

Not sure what is happening here but it looks like something is not right at the other end of the playback chain the signal path shows the source file is only 16 bits and is not showing MQA which are usually 24 bit files. Do you get the same for all MQA files?

Would still like to see a screen shot of the Advanced section of Device Setup, but in any case, you should make sure in that section Max Sample rate is set to “Up to 384kHz”, Max Bits Per Sample is set to “32” – this is what your device supports. And Make sure Enable MQA Core Decoder is set to “Yes”.

That will likely address your issue but if not it is beyond me and you should flag Roon Support. Good luck!

I looked at your original screen shot and you are playing a 16 bit regular pcm flac source.

@DrTone, Agreed, this looks like a metadata issue (false positive for MQA) let’s tag @support.

@Graham_Galt, can you select a different MQA album from Tidal, and then check the signal path.

Roon is not playing mqa version looking at the signal path.

Hi @Graham_Galt,

It appears that the file you selected to play is 44.1/16 according to the signal path which is strange. I just tried on my end and this album was played as 192Khz/MQA.

Is this issue occurring for all MQA albums or just this one? Is the behavior still occurring at the present time?

Same here … (with a UK Tidal account) seems there’s more to it than just a MQA false +ve.

Thanks, Craig. Here’s a screen shot for the advanced section of Device Setup.

The “Max Sample Rate” section is definitely set to “Up to 384kHz,” which aligns with the C52’s capabilities.

Here’s a screen shot of another MQA file, which shows MQA being 96kHz, but the signal path sees it as FLAC 44.1kHz.

Hi. Thanks. Yes, I get the same result on all MQA files – they all turn up in the signal path (and on the C52 as 44.1kHz files, regardless of what the MQA format displays in the album browser window.

Thank, CrystalGipsy, and thanks to everyone else who is working to help me. Much appreciated!


Thanks, Carl. Weird, huh?

1 Like

Your issue is likely not a device setup issue, but something that causes Roon to get a non-MQA 16/44.1 stream instead of the MQA stream from Tidal.

I remember seeing the same problem reported two or three times before, but is not clear to me what exactly the solution was, e.g.

Perhaps try this:

  • Logout and disable Tidal account.
  • Shutdown Roon Core
  • Find your Roon database and delete the tidal_account file (Database > Registry > Core > tidal_account)
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop, or just delete it
  • Reboot Roon Core and login Tidal again