Roon not detecting changes to Library after rescan

I’m currently 7 days into my trial of Roon.
I am running Roon Server on a SSD connected via USB 3 to a Synology DS916+ NAS. Roon is pointing to my library on the NAS. All my music files are also on my windows 10 x64bit PC. From there using MediaMonkey I add/edit the files. Then when happy with my changes I sync the files up to the NAS.
As a test I uploaded the deluxe version of REM Murmur into two separate directories
\share\music\rem\murmur - live
Which Roon picked up ok on initial scan and displayed as two separate albums.

I then corrected it on my PC to
\share\music\rem\murmur\1-01 track1
\share\music\rem\murmur\1-02 track2 etc
\share\music\rem\murmur\2-01 track1
\share\music\rem\murmur\2-02 track1 etc

Whilst settings>storage is set to watching for new files in real time Roon did not seem to pick up the change so I forced a rescan. After the scan Roon was still displaying it as two albums, but had changed the file locations. I attempted to merge the two in a single album, but the album was now unknown. So did a “Identify Album”, but Roon could not find the correct version.
Therefore via album editor I deleted the album and files , then copied the files back to the NAS from my pc and forced a rescan. This time Roon would not pick up the “new album”. So I ended up having to restart Roon service and then force another rescan. Now the album is displaying correctly and Roon’s database picked up the correct version.

Is this normal behavior, will I have to follow a similar procedure every time I make a change. Seems a real overhead.
Hope this makes sense, thanks for reading.

I am not 100% sure about this, but I have an explanation. (correct me, if anyone knows better):

I guess Roon already recognised both albums when you copied it on the NAS in 2 individual folders. Roon keeps track of renamed files. So even if you rename a file, Roon already connected it to one of the initial identified albums.
“Force Rescan” will just check your storage if there are files that have not been added to your library. But these files were already in your library.

What you could have done is to merge the 2 Albums into one within Roon and use the “Re-Identify Album” feature.

Thanks Crieke,

I tried the merge and re-identify album, but Roon Database could not find a version I was happy with.
As I also had REM’s Reckoning album across two folders, I decided this time to delete it from Roon, uploaded the changes and then forced a rescan, and that worked. So I think in this scenario it’s best to remove the album and start again.