Roon not discovering Bluesound speakers

I have two Bluesound Nodes and two Bluesound speakers. Roon has discovered the two nodes and is functioning well with the nodes - and, with Roon 1.3, Roon is incorporated in the Bluos App for the nodes. However Roon has not discovered my two Bluesound speakers. They are on the same wifi network and appear, along with the nodes, in the Bluos app.

Are you sure the speaker’s firmware has been updated?

That’s all I’ve got.

Cheers, Greg

Thanks for the prompt reply. The firmware had been updated - I just tried turning the speakers off and turning them on again and they have been discovered in Roon! I suppose that it proves the old computer maxim of rebooting to solve all problems.

1 Like

2 posts were merged into an existing topic: Bluesound Sample Rate Conversion and grouped zone dropouts

FWIW to others, I also thought Roon was not finding my Power Node, until I realized that, from within BlueOS, I had combined it into a Fixed Group with my Vault2. Roon displays only the Vault2, but music from Roon comes streaming out both that and the PowerNode just fine.
At this point, I’m assuming if I ever break apart that Fixed Group pair, Roon will suddenly “see” the PowerNode as a separate end point.

I’ve noticed some devices dropping off, and it doesn’t matter if they are wired or wireless.I have to power cycle the speakers in order for the Roon software to find them again. When it does it remembers the Zone Name that had previously been assigned.

Every now and then my pulse mini drops out of sight. It reappears generally if I reboot the mini
Not related to grouping in my case

Don’t recall this occurring in the BlueOS app

I’ve just had a Vault2 drop off the Roon list. It still appeared and was operational from within the BluOS app, but it required a power cycle of the Vault to get it back on the Roon list (an initial reboot of the Roon Core did not remedy the issue).

I had a wired powernode2 and a pulse mini drop; only way to get them back was powercycle of the two devices. Only happened once since 1.3 has been out. At the time input it down to network weirdos.

Interesting point was that those very same endpoints were there in the bluesound app, just not roon. I could even stream Spotify to them. It was only roon that could not see them. If it happens again I’ll note the time and submit my logs.

Logs would really help roon, no doubt.

I’ve had my powernode2 and pulsemini disappear without reason (still visible in BluOS and not grouped), and a power cycle didn’t help (nor did closing apps, closing core, rebooting CPU, or cycling the wifi/router/modem and the bluesound devices again!).

Th only thing that helped was going to work for the day and returning home… and I’d rather that not be required daily!

@support my Powernode 2 (hardwired) also went missing as a zone. I could still play music through BluOs.

Visa versa roon was also not visible anymore from within the BluOs app.
A restart of the server (on Linux) and remotes did not solve it.

Only restarting the powernode 2 solved it. As there’s no on off switch this is not something we should be doing I think…

Can you please look into this.

Hey @stevev1 @Afullmark @Adam_B @paul_kraft @Stephen_Rice @Scott_Fletcher and my old buddy @Paul_Williams – we will look into this and see if we can reproduce in house. If we can, we should be able to either resolve it on our end or pass on to Bluesound.

That said, I would be interested to know what Bluesound support has said about this issue, since it’s resolved by restarting their hardware, as opposed to restarting your Roon Core. If you haven’t spoken with Bluesound, I would recommend you touch base with them.

If you see this issue again, please confirm that what I said above is true :slight_smile: meaning, restarting your Roon Core does not resolve the issue.

It might also be helpful to see logs from Roon when this issue is occurring. If you see this again, please zip up the entire Logs folder from your Roon database, and PM a Dropbox link (or similar) to @support. Make sure to let us know when the issue occurred.

Thanks all!

I have a Flex and it too drops while playing music.

If I wait it will return, but then there are issues playing to it - looks like it is playing, but no sound.

I will try to reproduce and have some clean logs.

Thx…

HI Mike,
Do you wish to see the logs from before, or after, we reboot the Bluesound product (or does it even matter).

Hello All,

I’ve talked to the folks at Lenbrook and we will start to flag someone from their team to tighten and close up the loops here… I’ve tagged @Andrew_Haines and he will work with us to explore issues in this forum.

Ideally, you would zip up the entire logs folder, and send us time stamps for when the failure occurred, and when the reboot (or either device) resolved the issue (or didn’t resolve the issue).

Hi Folks, the bug for player discovery that was in Roon 1.3 has been cleaned up by Brian and we have added it to our RAAT package. It will be in the next BluOS maintenance update and will solve the issue. We will get it into a QA build likely tmo or Monday for testing. Andrew

2 Likes

Hi Andrew,

@Andrew_Haines @brian @mike

Any news on the ‘conversion to 48K’ issue affecting Bluesound speakers (but not, intriguingly, Node or Power Node)?

I’ve bought Bluesound kit (node 2, pulse soundbar, pulse mini, 2 pulse flex), think that they are a worthwhile improvement on the Sonos kit I had and am patiently hoping that this gets fixed - but I know (from comments made by others) that some Roon users are holding off purchase because of this issue.

Sigh. I’m reluctant to purchase Bluesound products while integration with Roon is so suspect. Please advise when this, the MQA problem and others are resolved.

Hi Andrew. According to TonyW (from BlueSound) the fix hasn’t been shipped with the 2.10.6 Bluos update. Could you comment on the status of this issue? Thank you.