Roon not displaying tidal playlist

hi, my roon installed on macmini and used to work fine with tidal. Now suddenly, when I go to tidal, I get to the ikons for music, when I click on them I get to some playlists. When I click on the playlist, then next window is empty and I get “This play list is empty” message. Also when I do search in roon, none of the tidal songs are found.

Hi @Alexander_Vetstein,

Since experiencing this issue have you tried rebooting your Core machine?

If you log out of TIDAL in Roon and then log back in is there any change?

I did logout of tidal, reloaded mac. did not help(

Hi @Alexander_Vetstein,

Thanks for giving that a try. Can you describe your Core and networking setup?

Can you share a screenshot of what you’re seeing

2 posts were split to a new topic: TIDAL and Qobuz albums are not loading

Here is the problem

i have an optic internet in the apartment. Then through a switch to mac. I have a nas with music files, that is also connected to the switch. My macmini 2014 with 8 memory is also connected to the switch.

Tidal used to work fine on this setup, but suddenly stopped showing the playlist. It does display all the usual icons for new arrivals and so on, but when I click on them, I get an empty play list

Tidal works fine on audiorvana on the same mac

All local files work fine.

Thanks, @Alexander_Vetstein.

Any change if you reboot the router? Can you describe your networking setup?

We’ve also seen Google DNS or Cloudflare DNS help with this type of issue — Any change if you use one of those?

Hi I did both, reboot of the router and use of the google DNS, no help.
Network setup, what do you want to know? I use DHCP as the address on my MAC

Thanks for giving that a try, @Alexander_Vetstein.

Any information on the hardware you’re using (router, switches, etc.) and how your devices are connected.

Let’s also try clearing your Roon cache and see if that helps:

  • Close Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and let us know if there is any change

Hi, I did what you said. No change. Should I move the cache back to roon library?

Router from isp provider of fiber optic , huawei through cable to dlink switch then cable to macmini 2014

There is a cache folder inside roon folder in the library, that folder has some files inside. Also there is one cache folder inside database folder, that one has no visible files.

Thanks for trying that, @Alexander_Vetstein.

No, no need to do this.

Just to confirm — Is TIDAL content syncing otherwise? Are you able to play TIDAL content okay? If you go to Settings > Services > TIDAL what does the last sync time show? Can you share a screenshot?

Tidal is working fine with audiorvana. I cannot play tidal in roon, hence I’m writing to you.

Hi @Alexander_Vetstein,

Thanks for clarifying. I just wanted to be sure that TIDAL content already in your library was also not playing so I could understand if it was related only to the display of the TIDAL section of Roon.

Since playback is also not working for you, this points to a bit broader of an issue which is most frequently caused by networking issues when communicating with our servers.

First, can you clarify something about your networking setup? What is the model of switch that the Mac is connected to? You mention it’s a Dlink switch — Is this switch managed?

Next, I’d like to try logging out and back in again. We recently made a change regarding how we log in with TIDAL so you’ll it would be good to see if this results in any improvement. Note that you’ll want to make sure you’re fully up to date for this to work.

Finally, assuming that the new log in method doesn’t help, I’d like to propose a test that will help us further narrow down the root cause here. Do you have another Core machine that you could temporarily use as a Core machine? If so, does it experience the same issues with TIDAL? As I mentioned before, this seems like a networking issue, and this test will help us confirm if this is the case by removing several other variables.

Hi Dylan,

Well I just tried my playlist that I made when roon was working and it does play tidal songs. Please see below the screen.
I did log out, and reboot and login, the problem with the tidal not displaying playlist is still there. My dlink is not manageable.

i could arrange for remote access if you like.

Hi Dylan

The tidal in my library or in playlists that I have made earlier is working.
I also tried to set up roon on another machine as you required and I experience absolutely the same problem. SAme error.
Any other ideas?

Hi @Alexander_Vetstein,

Just to be clear, did you set up the other machine as a Core or did you connect to the current Core as a remote?

Assuming you used the new machine as a Core, that means that this issue persists even on a new machine with a new database. In this case, it is only the network that is the same between setups, so something about this network setup is causing issues here.

As a quick test, can you try using hotspot from a mobile device and connect your Core machine to that? While this is not an ideal setup, it would be interesting to see if the same behavior occurs in this scenario since this would be a completely different network.


2 posts were split to a new topic: TIDAL playlist not showing in Roon