Roon not finding Node 2i on network

I hope I’m able to resolve this issue. I wasn’t able to during previously trial period so had to quit using Roon. I’ve taken advantage of the current promotion to get a new trial period…

Running Roon Core installed on Windows 10 PC. (Roon 1.8 Build 831) Node 2i is also hardwired directly to another LAN port. Firewall is set to allow Roon, Roon Bridge and RAAT to connect. I tried setting up the Node through Wifi but that didn’t help either. Updated to latest firmware on the 2i, still no luck. Both Roon and the 2i are working perfectly on their own but Roon can’t find it on the network.

Any advice will be much appreciated.
Thank you.

I would first turn the Firewall off temp to just verify that Firewall settings are not the issue. I assume you have looked in the 2i settings to make sure that Roon Ready is active.

On the same switch, on the same router?

Thank you for the reply. Router is the same…only have one. I did turn the Firewall off and still no luck. Checking my Node 2i settings on my Android device I could not find any Roon ready setting. Under what heading should I be looking?

No problem. BTW, just a fellow user not official support. If you want to engage support you would need to post in the Support section. If that is what you want I can move the thread.

When I set my 2i up, I don’t remember where it was, maybe services, and I had to give the Node 2i a “name”. I did it via the BluOS software on the PC, not on a mobile device. So, settings and options may differ.

Def use it wired with ethernet rather than over wifi.

Thanks again…The Node 2i did have a name. I changed it by still no luck. Still not finding Roon ready settings on Android…However, I did download BluOS on the PC and it’s not finding the Node either so I suppose it’s a network issue. . With that bit of information, any other ideas? I guess I should post in the Support section.

I neglected to mention this earlier but I have several devices connected to the same LAN port as the 2i via a LAN hub. Thinking that might be the issue I connected the 2i directly into the LAN port but that didn’t seem to help either.

You should detail the network chain including part numbers, so others can see what it is, otherwise we make assumptions.

like mine would be

ISP> ROUTER (FIOS) > ethernet > Netgear Switch > Ethernet > Core Computer (Win 10)
… . … … … … … … . . . . … … … … …> Netgear Switch > Ethernet > Node 2i

this tells you that the incoming network from the ISP goes to a FIOS router which is then connected via Ethernet to a Netgear switch and the both the Node 2i and the Core computer are attached to the same Netgear Switch.