Roon not importing some files from scanned folder

System info:

  • Windows10/Microsoft Surface Go/Roon v1.7 Build 710
  • Synology NAS+UltraRendu over Ethernet

*Description Of Issue
As the title describes, Roon is not importing several files from my library. In this case, they are FLAC files. What’s odd is that some files from the folder are being imported but others are not.

  • these files do not appear in the “skipped files” list
  • when I browse the folder in the Roon " storage" screen the files appear to be there.
    Also, jRiver has no problem identifying, or playing these files so I doubt there is a file corruption issue.

Any thoughts?

Worth checking this out. Synology uses a Linux file system that allows some characters in filenames that Roon or Windows don’t like.

Thanks, and yes I read that FAQ.
Here’s a little more detail. Roon will import and show/play the files from album a), but not album b).
They were ripped at the same time (dbpoweramp on a Windows machine), they are in the same folder - “Ludwig van Beethoven” and appear to have the same semantics as far as I can tell. As I said, JRiver, or even Foobar2000 has no problem with these files.

a) S:\Lossless\Classcial v2\Ludwig van Beethoven\Beethoven; The String Quartets; The Late Quartets, Disc 6\01 Emerson String Quartet - String Quartet No. 15 in A minor, Op. 132; I. Assai sostenuto - Allegro.flac

b) S:\Lossless\Classcial v2\Ludwig van Beethoven\Beethoven; The String Quartets; The Early Quartets, Disc 2\01 Emerson String Quartet - String Quartet No. 4 in C minor Op. 18 No. 4; I. Allegro ma non tanto.flac

Hum… I guess you need Roon support, not obvious what’s going on there. One thing that has got in my way in the past are invisible characters in filenames, like weird versions of space. But it could be something totally different.

Without counting those look >255 chars is that not a problem with Windows

No 207 & 208 characters respectively !!

I know JRiver has an experimental way of importing long filenames if you select it , not sure about FooBar

There was a thread recently on accents in file names

Also I am not sure about Semi Colons ? Without testing

They look alike , I too wonder if you have an odd “invisible” character


My C# skills are still working !!

I cannot see any odd ASCII characters in the second file name (all valid a-z, A-Z etc, so no hidden nasties over to @Support

Came across this,the%20OS%20from%20interpreting%20it.

Doesn’t explain why one and not the other though!

Just to confirm, @Michael_Buchanan — If you use look for these tracks by path do they show up?

That’s just for when the Linux shell interprets text in commands or shell scripts. Filenames can contain ; but you need to escape the character when typing that filename to the shell.

Ah, yes, they show up under the tracks browser exactly how they’re sequenced in the Explorer folder. This was a box set, organized by Early, Middle and Late Quartets with several discs for each period.
However, when I search on the Album (or artist, doesn’t matter) some of the discs are shown with the wrong artwork(Early Quartet and one Late Quartet disc), a couple are with the correct artwork(a couple of Late Quartet discs), and several discs/files are not shown at all (the Middle Quartet discs), but again, they all appear in the tracks browser. The files with the incorrect artwork appear to have been combined from separate discs (again each disc in the set is shown individually with correct title and correct artwork in JRiver as I would expect). I know classical metadata can be a nightmare. Maybe some kind of metadata parsing problem? Strange.

Ah !

No Linux experience :stuck_out_tongue_winking_eye:

Are any of these missing tracks duplicates? like same song but on a different album or anything like that? Also, if Roon is not reading multi-disc releases correctly than it could be putting together multiple Discs but only listing one. In settings in the general settings tab there is an option to turn on or off “Show hidden albums and tracks”. If that is off, turn it on and see if the missing albums show up

Hi @Michael_Buchanan,

BlackJacks’s link above should help:

If you follow our recommendation for folder structure it will help Roon properly group multi-disc albums and display them correctly.

I recently moved my music to a NAS (Synology) and migrated my database and core to a Roon Nucleus. There are at least two folders that Roon is not scanning, the ones with the red dots in the attached image. I tried removing punctuation characters from file names, removing the folder and then adding it back. All to no avail. The files in the Bach folder are all FLAC and the Tchaikovsky ones are AAC. Audirvana finds them just fine. What am I doing wrong? Thanks!

Have you looked at the contents of Settings > Library > Skipped files? It’s a useful diagnostic for some import failures. The other potential issue is that depending on what your source operating system and how the music folders were copied, file/folder names may end up with a character encoding that’s not compatible with Roon. At different times, I’ve had issues with some folder/file names with non-ASCII characters, or ending in a space character.

Thanks, Fernando. I had looked there and those files weren’t listed, but there is also the caveat at the top about some folders not being listed if the name couldn’t be read. I’m going to try a rescan later tonight.

I forgot to rescan last night, but magically all four albums are showing up in Roon this morning. :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.