Roon not opening OS X Sierra [Resolved]

Clicking on Roon App and nothing opens. Roon goes to the Dock and I get a menu but nothing works. No Opening animations or windows.

Tried to re-download and reinstalled and did not help. Did a time machine restore still no luck. Problems started after three power outages yesterday that shut down my Mac Pro.

Need help getting Roon back up and running.

I have a test Mac Mini Core 2 Duo. (The last version made) I have El Capitan installed and I have the same issue.

Not sure what is going on but this morning Roon opened as usual.

I am still unable to use it :frowning:

There have been discussions of two issues that cause Roon to not start of fail to fully start on MacOS: 1) application gets the wrong execution privileges; 2) MacOS firewall blocks Roon. There’s no clear reason why those things happen, but there are work-arounds.

1 Like

Thanks for pointing this out. Will try it later on today and report back.

Thanks again!

Tried those suggestions and did not help. Have been using Roon since its inception and never had any issues. Really strange but alt least it is working now.

Worked like a charm!

Glad it worked. BTW, the recommendation in that doc to turn off the MacOS firewall is too extreme, it’s enough to go to

System Preferences>Security & Privacy>Firewall>Firewall Options… and make sure that Roon and RAATServer have “Allow incoming connections” set. You may need to enter your password to access Firewall Options.

Well turned off my computer and restarted and back to Roon not opening again?

Start Roon and it shows in the dock but nothing opens. No animation start screen or messages. When it first starts I get a greyed out menu bar but as soon as I click on the desktop menu bar returns to normal. If I click on the greyed out menu bar with the Roon options nothing works. As soon as i leave it click on desktop etc and activate another app it disappears and will not return when I click on roon in the dock. I can right click on roon in the dock and quit.

Have donne all the suggestions above and they do not work. No other problems with any other programs. Have tried downloading and reinstalling but that does not work.

How do you completely uninstall Roon and associated files so you can start fresh? There is obviously something corrupted in the Roon file system that keeps causing this issue to reoccur.

Have you tried this?

Well feel really stupid now… I found how to delete everything and did a fresh reinstall. When I clicked on the freshly downloaded Roon app I got the same behavior - Roon in dock but no animation or windows. It then dawned on me to turn on my TV that I have as a second monitor for streaming online content and there was the Roon app with the setup window? For some reason Roon was going to my second monitor (TV) and not remembering its saved state when I closed it. So I believe this has what has been happening for the past week.

Fortunately I have the Roon backup running every 3 days so a quick effortless restore and I am backup and running :wink: