Roon not picking up new music

I am having a similar issue. Forced rescans and reboots of the Core (and the NAS) have not worked. Roon is not picking up some (not all) new files on the NAS.

Other than deleting the whole Roon directory file and starting from scratch, is there anything else I can try?

Hello @Mark_Worsey,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Details on your Core machine (MacBook Air - mid 2012 i5 4GB 10.12.6)
Networking details (iMac wired connection to WD external HDD holding main copy of Music.  Music on this external HDD copied wirelessly using Carbon Copy Cloner to Synology NAS DS415Play; DS415Play wireless connection to MacBook Air Core)
Audio devices in use (Dragonfly Cobalt into Preamp)
Library details as above - 13,418 files showing on the NAS, 13,341 tracks identified on the Core.

Question - why are there 77 tracks on the NAS which will not show in Core? Many of these are files that I have moved from one folder to another on the HDD and then copied the folder changes to the NAS using Carbon Copy Cloner. The HDD and the NAS folders and tracks etc are identical sizes and I therefore assume have all files exactly the same. Some of the files missing from the Core are 2+GB.

I really hope that provides information which can help me. I am considering trashing the library and restarting, but that’s a last resort of course.

m4A files not being seen by Roon is the problem. I am converting to FLAC.

Hello @Mark_Worsey, were you able to import your files once you converted to FLAC? We’ve noticed in the past that .m4a files that have DRM (like some older iTunes purchases) cannot be imported. If you .m4a files don’t have DRM those should import. Let me know if you have questions!

Thank you.

Yes. I converted to FLAC last night and the import is OK. But now the files do not play in Mac Music app.


Hello @Mark_Worsey, thanks for your patience here! I’d like to test those original .m4a files on my side and see if I have the same result. From there I can see what we need to do to fix them. Could you please provide one of the issue .m4a files here? Thanks!

Continuing the discussion from Roon not picking up new music:


I found that none of the M4A files worked in Roon. So I had to convert them all to FLAC. But now these FLACs do not play in iTunes. Is there a lossless format that will play in both?

Apple lossless ALAC

Hello @Mark_Worsey, just checking in on those files. If you would like, I’ll test the files if you upload them to the link provided above, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.